New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Unity Integration: 0.2.2 Crashes Unity Project

xanderdavisxanderdavis Posts: 87
Hiro Protagonist
edited June 2013 in Support
After integrating OVR SDK 0.2.2, it crashes my Unity project on my main scene (but not on other scenes, like my much smaller and simpler Sandbox). Rendering seems to break as well, even if I switch to a standard camera and controller.

I am pushing Unity to its limit on the scene in question (seems I'm always battling optimization lately for this scene in particular, which is epic), but it worked just fine on 0.2.1. As soon as I switched to 0.2.2 it crashed. Sometimes I would get an Out of Memory crash warning. I restored a backup build from the night before with 0.2.1 and repeated the stability test. As soon as I swapped out OVR for 0.2.2, it would crash on this scene.

Remote Consulting to Clients Worldwide in UI / UX / VR: http://www.xanderdavis.com

Comments

  • petergiokarispetergiokaris Posts: 170 Oculus Staff
    Hello there,

    Were you able to import and try the Tuscany demo to see if it installed and worked properly on your system?

    Also, if it's possible to strip the project file down as far as you can and send me the unitypackage, I will be able to further debug it from here.

    Thanks,
    Peter
    Peter Giokaris
    Senior Software Engineer
  • stentsstents Posts: 7
    I have a similar issue. Imported the new 0.2.2 files into my unity project and now Unity will crash on clicking the play button after I testing my scene (ie when I try to stop playing). It works fine up to that point... it's just when I try to stop the in editor playback preview.

    Had to revert to 0.2.1 for now.
  • LaurentMTLaurentMT Posts: 57
    Same problem here.
    The app crashes at launch but only the first time I try to run it. The next tries are ok.
    Same problem in editor and built application.
  • MorbidDonkeyMorbidDonkey Posts: 284
    Hiro Protagonist
    Any progress on this?
    -: MorbidDonkey :-
    ===================================
    LOGISTICS - Oculus Prototype 1
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    No progress, but give us a moment to look into this issue further.

    Personally, I have not seen this issue, so we just need a consistent way to reproduce it.

    It is possible for one of you guys to create a simple test project that has the problem and upload it to this thread? That may assist us in pin-pointing the problem.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • LaurentMTLaurentMT Posts: 57
    I've tried to troubleshoot this issue.
    I can reproduce it in Unity editor when I stop the game.
    I've got the following traces in Unity logs. Don't know if it can help you.
    ========== OUTPUTING STACK TRACE ==================
    
    (0x66536F0B) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x324b
    (0x66537026) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x3366
    (0x665355A6) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x18e6
    (0x6653735D) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x369d
    (0x66537D92) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x40d2
    (0x66535CA2) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x1fe2
    (0x6653CE3D) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x917d
    (0x6653CEC3) (OculusPlugin): (filename not available): OVR_GamepadController_GetButton + 0x9203
    (0x74A9C556) (MSVCR100): (filename not available): endthreadex + 0x3a
    (0x74A9C600) (MSVCR100): (filename not available): endthreadex + 0xe4
    (0x77028543) (KERNEL32): (filename not available): BaseThreadInitThunk + 0xe
    (0x775FBF39) (ntdll): (filename not available): RtlInitializeExceptionChain + 0x85
    (0x775FBF0C) (ntdll): (filename not available): RtlInitializeExceptionChain + 0x58
    
Sign In or Register to comment.