New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Somehow DK2 became my 1st monitor... help

HiCZoKHiCZoK Posts: 230
Art3mis
edited September 2014 in General
So I received it yesterday and it's awesome. Everything was working fine ad I was fiddling too much and identity numbers have swapped in windows 7 somehow. They still show fine in amd ccc tho....
My dell main monitor is now number 2 and rift is number 1.
That wouldnt be a problem, except that now ALL demos start on dell and cant be "shift+winkey+arrow keys" moved to rift because my monitor is running at 720p to achieve 75hz and then alt-entering them on the rift dont make em properly full screen.

So how do I swap those numbers for my monitor to be 1 again? It is still primary monitor, it just have identity number 2 and that sucks for expanded use.
Already cleaned and reinstalled drivers. didnt helped. Windows just remembers that. When i disconnect dk2, my monitor is "1" again, but it gets back to "2" as soon as I start the rift.

Comments

  • LagahanLagahan Posts: 181
    HiCZoK wrote:
    So I received it yesterday and it's awesome. Everything was working fine ad I was fiddling too much and identity numbers have swapped in windows 7 somehow. They still show fine in amd ccc tho....
    My dell main monitor is now number 2 and rift is number 1.
    That wouldnt be a problem, except that now ALL demos start on dell and cant be "shift+winkey+arrow keys" moved to rift because my monitor is running at 720p to achieve 75hz and then alt-entering them on the rift dont make em properly full screen.

    So how do I swap those numbers for my monitor to be 1 again? It is still primary monitor, it just have identity number 2 and that sucks for expanded use.
    Already cleaned and reinstalled drivers. didnt helped. Windows just remembers that. When i disconnect dk2, my monitor is "1" again, but it gets back to "2" as soon as I start the rift.

    Swap the slots they're physically plugged into on the GPU, I think that's what dictates this anyway. If you only have 1 HDMI slot grab a DVI>HDMI adapter and use the Rift on it.
    I think what you want is to set the Rift as primary though, nearly everything starts on the primary monitor by default.
    Check out Bilago's Rift launcher tool, he has a thread here in the forums, its handy for this kinda stuff I hear.
    DK1 status: Delivered, DK2 status: Delivered
    Rigs:
    CPU: i5 2500k @4.8GHz GPU: R9 290 @1.1GHz RAM: 16GB OS: Windows 7 Pro x64
    CPU: i7 4710MQ 3.3GHz GPU: 2x880M 8GB RAM: 8GB OS: Windows 7 Pro x64
  • HiCZoKHiCZoK Posts: 230
    Art3mis
    swapping cables is no go. I have rift on hmdi and pc on dvi.

    making rift primary screen now also doesnt work. Most demos dafault to monitor with identity "2" and that is my dell monitor, no matter if it's set as a main monitor or is rift set as main monitor.

    It was ok before. Windows must remember that info somewhere
  • Gypsy816Gypsy816 Posts: 513
    Nexus 6
    Hello! Can you change the display mode through the Windows Key and "P"?
    Oculus Community Manager - kweh!
  • HiCZoKHiCZoK Posts: 230
    Art3mis
    Sure I can. with win+p "Computer only" switches rift as main monitor but it's identity is still "1" and apps automaticly assume that rift should be 2 so it dont work.

    here is a screenshot of my problem
    CcAqd4l.png
  • pittsburghjoepittsburghjoe Posts: 514
    Art3mis
    i7 skylake, EVGA Classified, 2 EVGA 980 sc's, Thermaltake TR2 RX(1000W), 32GB DDR4, Win 10 on an SSD
  • I had this same problem twice actually, fortunately both times I had left the control panel > display settings window open prior to this happening, so I had to inch along that window using the rift (which splits it in 2) and eventually reset it manually.. it was a pain and took like 10 minutes, I hope they fix this..
Sign In or Register to comment.