New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

3D Window Manager

mite51mite51 Posts: 31 Oculus Start Member
edited November 2015 in Showcase
http://share.myflare.com/8vnmy3

This is something I've been working on for a while and its far enough along that I want to get some feedback. Its a 3D windows manager for the oculus, currently named 3DWM, but I am thinking of calling "WorkSphere". The goal is to re-create the desktop environment in 3D and allow the placement of windows on a virtual sphere around the user, a virtualized multimonitor setup(?). Ideally ( eventually ) a user should be able to work and use windows while using the oculus, hopefully making the oculus able to replace the monitor entirely.

I am happy with the progress so far, but there still a lot of work to do. If you try it out please let me know how it goes. Be sure to read the Notes.txt file included in archive in the link above.

[email protected]
J
«1

Comments

  • mite51mite51 Posts: 31 Oculus Start Member
    Seems like it will work in Windows 7, but in extended mode only atm.
  • Just tested this on Windows 8 Pro x64 and the only thing it currently does (3DWM_Release.exe, 3DWM_Release_BetaMouse_Stereo.exe and 3DWM_Release_Stereo.exe) is to show a very blue screen on my Oculus... That's it :P
    The BetaMouse also locked my mouse so I had to kill the process. (with only keyboard)

    The other 2 .exe files did absolutely nothing visible.

    I did change and run the .reg file supplied, and I'm pretty sure I have the newest updates for everything from Windows update to Oculus drivers and software.


    If this is half of what you say it is, I'm very much looking forward seeing this developed!

    (PS: maybe choose another download site, my antivirus went bananas. I spent 15 min scanning your files with virustotal.com before trusting them :P )
  • mite51mite51 Posts: 31 Oculus Start Member
    yay, I reply! So the orientation will reset on startup, depending where the headset is you have a good chance of not seeing anything. The secret kung-fu for resetting orientation ( and mouse ) is ctrl+shift+alt. I'll have to look into how to ensure proper orientation on startup.

    As for the mouse beta mode, it does lock the mouse to the application window, this is because the "virtual" mouse is using only movement deltas, which might let the real (windows) mouse cursor wander off and interact with things unintentionally. The standard mouse mode will only show the "virtual" mouse when its over the app window, this allows the user to continue to use the real desktop to do things like kill the app. If you use the beta mouse .exe, the best way to kill the app is to find the systray ( ctrl+shift+alt, helps ) and right click the app and close. Its annoying I know but its a bit of a tricky issue, thus the beta tag.
  • Well I don't think that's the problem here, lemme clarify with a picture ;)

    http://imgur.com/dgakruH

    That is exactly what I see, no mater where I turn the Rift. I tried you trick with CTRL+ALT+SHIFT and I did see my mouse, but I could not get any widows upp, and when I tried dragging windows over from another screen, it blinked a bit and my mouse alone appeared on the Rift.
    Thou I must say I like the blue colour :P


    Spec:
    Motherboard: MSI Big Bang XPower II
    CPU: Intel Core i7 3820
    RAM: 2x Kingston HyperX 16GB
    GPU 2x ASUS Radeon R9 280X 3GB GDDR5
    OS: Windows 8 x64
    Rift: DK2
  • mite51mite51 Posts: 31 Oculus Start Member
    Well that is unfortunate. One known issue is that there maybe be problems acquiring the window texture with multiple graphic devices installed, however, even in that case you should see empty window borders. The only time I have see absolutely nothing like that is if there was another instance going that was still running. If you email me maybe I can send you a debug version that will dump out some debug info so that I might be able to track down the problem... I would really appreciate it. My email is [email protected]
  • mite51mite51 Posts: 31 Oculus Start Member
    I just realized there is one important thing you may not have done. did you run the. reg file? if so, was the path in the reg file the correct path? I'll have to look at getting rid of that registry entry, it will avoid a potential source of confusion
  • Yeah I did, but apparently I have forgotten to add the "bin" at the end :P
    It didn't helm much however, I can now see the edge of my windows, and tracking is working. But it's still VERY blue and I can't see the content of the windows nor anything else of my desktop.
    I also tried disabling all other GPU's, it didn't do anything at all. Even tried unplugging the physicly xD
  • mite51mite51 Posts: 31 Oculus Start Member
    http://share.myflare.com/NQ4cYh

    I have a new build up with lots of improvements and fixes, let me know how it goes, I would really appreciate it. Please read the notes.txt included in the archive.

    - tuned the spherical environment to feel a bit more spherical
    - ctrl+alt+shift will re-center the oculus, ctrl+alt+down will minimize the app and release the mouse
    - fixed some lag spike bugs
    - registry setup requirement removed
    - fixed some bugs with window selection
    - fixed double rendering caption text
    - display warning if aero is not enabled

    todo
    -control panel to live tweak settings
    -curved window meshes
    -fix issue with initial orientation
    ...
  • Protocol7Protocol7 Posts: 333
    Trinity
    This sounds very promising! I really like Virtual Desktop, this could be even better, using the whole virtual space.

    edit1: I downloaded it but when I unrar the file my Avast antivirus blocks it. It says DWMControl_32.exe infection Win32:Evo-gen [Susp]

    I guess this is probably a false positive?

    edit2: I ran it through Virustotal and it seems to be clean

    edit3: All I get is a blue screen on the rift. :cry:
  • mite51mite51 Posts: 31 Oculus Start Member
    I use hooks, so anti virus programs will probably have varying degrees of issues. I use a hooking API from madshi.net, which also unfortunately also gets used by malware. So the first possibility is that the antivirus removed some files for you, do you have all the same files on disk as in the archive?

    Does pressing ctrl+alt+shift help? That will recenter the view.

    One thing you could try, if you power off the oculus and then run the app and skip past the "oculus not detected" message box... Do you still see only blue?

    Thanks for the feedback, I want to work through these issues so people are at least able to try it out ;)
    J
  • PariasParias Posts: 3
    NerveGear
    This is really cool - thanks! Exactly the kind of concept I want out of a virtual desktop manager - the ability to go beyond just a limited set of display surfaces.

    I played around for a bit and it worked okay on my Windows 7 x64 install, but I did run into a weird bug (not sure if this is related or not). I use a custom theme (DarkGamma Matter Ray) which doesn't seem to entirely agree with 3DWM. When I exit, my start button is stuck looking like this:

    http://i.imgur.com/s2FVXoy.png

    If I restart the Desktop Window Manager service, the gray start button then covers almost the entire horizontal area of my taskbar - a weird effect.

    This is neat otherwise. I'd love to see some scaling options for the future, and perhaps a way to more precisely control windows (I had a bit of a tough time snagging the corners in VR to move them around or resize them). I hope this keeps up development.
  • mite51mite51 Posts: 31 Oculus Start Member
    I am relieved to hear it worked for you. Thanks for pointing out the windows start button issue, I had noticed but it wasn't on my todo list, now it is ;) Its nothing to do with your theme, it just happens for some reason, hopefully with some digging I will find the cause.

    I am going to continue developing, and I plan to add some scaling options in a new control panel. I was only going to provide a single slider to control the size of the desktop area on the surface of the sphere, all other scale would be derived from that. And of course the size of the sphere and how close the camera is to one side of the sphere, all of which will affect the apparent scale in slightly different ways.

    I'll also look into the resize issue. However, I don't think its a bug, between the scaling and the low resolution I think its just harder. Perhaps some kind of sticky mouse movement would help...
  • Protocol7Protocol7 Posts: 333
    Trinity
    mite51 wrote:
    So the first possibility is that the antivirus removed some files for you, do you have all the same files on disk as in the archive?

    Yes, I disabled the antivirus and extracted and tried to run it.
    Does pressing ctrl+alt+shift help? That will recenter the view.
    No change is observable
    One thing you could try, if you power off the oculus and then run the app and skip past the "oculus not detected" message box... Do you still see only blue?
    Yes

    I'm running Windows 8 64 bit.
  • mite51mite51 Posts: 31 Oculus Start Member
    I am going to PM you to debug this more.
  • mite51mite51 Posts: 31 Oculus Start Member
    New build! Be sure to read the README.txt
    link --> http://share.myflare.com/zRGKdL

    Mostly a lot of bug fixes but the major new features include:
    -out of sight mouse position indicator
    -a control panel to tune some basic parameters real-time
    -spherical mapping ( though now that its done I will probably switch to cylindrical )
    -a panoramic background image

    There are still plenty of issues, but here's whats on my todo list:
    ( ) figure out issue with multiple adapters
    ( ) figure out windows (7?) start button issue
    ( ) why does the desktop get stomped?
    ( ) drag/drop support
    ( ) if there is a capture window and the lbutton is down, use the captured window cursor
    ( ) render improvements
    ( ) Kinect 2 and LEAP support

    Try it out and let me know how it goes and if there is some feature or bug that you think needs priority attention. Also, its quite a bit larger this time, 95% of that is the panoramic texture ;)
    J
  • tola5tola5 Posts: 82
    Brain Burst
    Hi I get a system error the program can't start because MSVCR100D.dll is missing runing Windows 10 but is was the same on Windows 8.1
  • mite51mite51 Posts: 31 Oculus Start Member
    Thanks, I'll try it out. I'll have to install Windows 8.1 or 10. In the mean time you could try to install the msvc runtime and see if it makes the problem go away.
    32 bit
    http://www.microsoft.com/en-ca/download/details.aspx?id=5555
    64 bit
    http://www.microsoft.com/en-ca/download/details.aspx?id=14632
    J
  • tola5tola5 Posts: 82
    Brain Burst
    Hi thx for you will take the time to look at it
    I try the link got "A newer version of Microsoft Visual C++ 2010 Redistributable has been detected on the machine." :)
  • mite51mite51 Posts: 31 Oculus Start Member
    Was a silly mistake on my part, one of the exe files was compiled in debug and was looking for debug libraries. Anyway, rebuilt and repacked, here's a new link that should work better.

    http://share.myflare.com/4g3LN5

    I haven't tried Windows 10 yet, so I cant say for sure it if will work there.
    J
  • mite51mite51 Posts: 31 Oculus Start Member
    I finally got around to getting 8.1 setup and it doesn't appear to be working very well, even with the dll issue sorted out. I'll keep looking into now that I have everything setup.
  • tola5tola5 Posts: 82
    Brain Burst
    sorry the late reply as you white it look like there are som problem I can start it but the window are just are white I guess it should not be that way ?
  • mite51mite51 Posts: 31 Oculus Start Member
    No, ideally you should not see only white windows ;). I have seen this behavior before and it is caused by either not having Aero setup correctly or you have multiple display adapters active. If you do have multiple adapters and you want to run this app you will need to temporarily disable all but one adapter via device manager.
  • mite51mite51 Posts: 31 Oculus Start Member
    Another small update, just upgraded to 0.4.3 SDK and fixed an issue with the cursor sliding around..

    http://share.myflare.com/J4wGtp
  • mite51mite51 Posts: 31 Oculus Start Member
    After some testing it seems that last change actually made the mouse worse in some cases, mostly when moving your head and mouse at the same time. I'll have a fix shortly.
  • mite51mite51 Posts: 31 Oculus Start Member
    The mouse seems more stable overall and it definitely helps when trying to click small things like window frames.
    http://share.myflare.com/8vnmy3
    J
  • Would it hurt to upload a couple screenshots?
  • I agree with Clinky. I'm curious what this is capable of, and was about to try it until my antivirus raised a flag for win32 evo-gen when unzipping the latest file. Could we get some screenshots, and in the case of the virus warning has anyone else gotten it?
  • mite51mite51 Posts: 31 Oculus Start Member
    I'm making a video shortly, but I'm stuck in a milestone marathon at work. Its unfortunate about the warnings, I had to do some DLL hooking which is kind of a catch all anti-virus warning. I'll put up a link as soon as I have a video made... thanks for your interest ;)
  • JohnnyLeeJohnnyLee Posts: 16
    NerveGear
    This thing jacked up my Windows 7 machine bad. Nothing displayed on the rift, my monitor had a maximized white window and no way to exit the app. Ctrl-Alt-Del wouldn't let me see the task manager to stop this thing. When I finally got hold of my desktop again (Win-P, Alt-Tab like 60 times back and forth) then the freakin Start button was gone and only a small box on the left center of my monitor had the word "Start" in it.

    Had to reboot to get things normal again.

    DK2
    Windows 7
    NVidia GTX 560Ti
    Massive amounts of RAM
  • rony14rony14 Posts: 9
    NerveGear
    Hi,

    I was interested in developing something similar, I wanted to have a virtual desktop around the user. I am not able to access the file shared; maybe it has been moved. Can you please share again.

    Rony
Sign In or Register to comment.