New to the forums? Click here to read the How To guide. -- Developers click here.

Linux support in Quake2VR

jspenguinjspenguin Posts: 49
edited October 2014 in Games and Apps
I've added Linux support to Quake2VR. You can download pre-compiled binaries here: http://www.jspenguin.org/software/quake2vr/ or you can clone and compile it yourself from source: https://github.com/jspenguin/quake2vr/.

If you compile from source, you will still need the support files from the binary release, as well as libovr.so. You can use the one I included or the one that the SDK Makefile generates (just rename it from libovr.so.0.1.1 to libovr.so).

Currently, only the base game is supported, but if anyone wants it I can work on porting the mission pack.

Comments

  • haagchhaagch Posts: 95
    Hiro Protagonist
    Very nice.

    I downloaded the binaries quake2vr_linux_demo_1.9.3.tar.gz.
    Archlinux ships glew 1.11 by default. I tried "ln -s /usr/lib/libGLEW.so.1.11 lib64/libGLEW.so.1.10" and maybe that caused the next problem, maybe not. The game looks like this: http://i.imgur.com/NETUYV8.png and I can see a huge mouse pointer, if I manage to hit the small magnified area I'm seeing here. This is when the rift is powered off.

    When the rift is powered on, I see a black screen and some shaders fail to compile: http://pastebin.com/raw.php?i=UCEy5TUd
    (this was from inte graphics mesa). You may or may not want to look into this, when mesa has some problems with the sdk itself still.

    And maybe not specific to the project: I tried to compile it too. I have a file /usr/include/ovr-0.4.3/Src/OVR_CAPI_Keys.h so I did cmake -DCMAKE_INCLUDE_PATH=/usr/include/ovr-0.4.3/Src/ . and make, but then I still get this error: quake2vr/client/renderer/../OVR_CAPI.h:40:27: fatal error: OVR_CAPI_Keys.h: No such file or directory

    Am I doing this wrong?
    By the way, is there some standard name for pkg-config for the rift sdk? I have created one called libovr so that it can be used like
    pkg-config --cflags libovr
    
    .
  • I forgot to add that file to the Git repository. You should be able to do a pull and compile it yourself. I added GLEW to the binary distribution, so try that again and see if it works.
  • TianyiLiuTianyiLiu Posts: 1
    NerveGear
    Hi I am trying to play Quake2VR on Linux, but it seems the link above is invalid now. Could you share the link again? @jspenguin ; and @haagch

Sign In or Register to comment.