New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Head tracking stuttering/lag

WalkyWalky Posts: 357
Brain Burst
edited July 2015 in Support
I've been pleasantly surprised by my recently arrived Rift, and believed my first adaptation problems to be because of a lack of VR legs, but somehow I felt there was something wrong. I've been feeling some sort of stuttering/lag when moving my head around, even with really slow movement, as if the image "jumps" frames unevenly. This also translates to increased perceived motion blur and lag when looking around. It feels very unnatural and is really disorienting. This happens with every single demo/game I've tried (Unity/UDK/HL2, even those that run at 60 fps) and it's progressively making me more sick each time I try, as I'm now more aware of this. My brain struggles trying to compensate for the stuttering/lag, and it not only causes motion sickness but also eye strain. About an hour ago I downloaded the Vireio drivers and tried Dear Esther with them (mouse emulation)... the head movement is WAY smoother, no stuttering at all, and the perceived blur is greatly reduced. It feels much better than anything else I've tried (the caves are amazing). I don't have any other gaming PC to try the Rift on. I'm on a fresh Windows XP install about a week old (correctly updated) so there's not really much that could possibly be conflicting, but who knows (no Logitech software here)...

Any ideas?

Another problem I have is that I can't run the Oculus SDK IPD Utility, it tells me that I'm missing dxgi.dll (which seems to belong to DX10 and higher). Is the utility not compatible with DX9? The same happens with the Oculus World and Tiny Room demos.
«1

Comments

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    This could be an issue with a defective or incorrectly calibrated tracker.

    Is it possible for you to take a video illustrating the problem?

    If it is a hardware defect, we may be able to offer a replacement.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • WalkyWalky Posts: 357
    Brain Burst
    Thanks, I'll try to make a video of it. I hope it's just a conflicting software issue as I don't think I can afford to spend more money on customs for a replacement (another $175 would make a total of $745 spent on this so far, which is more than my paycheck :( )
  • guspazguspaz Posts: 170
    Warranty replacements are generally exempt from tariffs/brokerage/etc.

    Tariffs and taxes and brokerage fees are all based on the value of the item, which for a warranty replacement is $0. At least that's how it works shipping into Canada.
  • WalkyWalky Posts: 357
    Brain Burst
    guspaz wrote:
    Warranty replacements are generally exempt from tariffs/brokerage/etc.

    Tariffs and taxes and brokerage fees are all based on the value of the item, which for a warranty replacement is $0. At least that's how it works shipping into Canada.

    I really hope that's the case, but knowing how things work in Chile I really doubt it. I don't think they'll let their "handling fees" go that easily :(
  • guspazguspaz Posts: 170
    Yeah, and UPS is known to try tacking on brokerage fees to warranty replacements anyhow even when they're not supposed to.
  • WalkyWalky Posts: 357
    Brain Burst
    I tried to make a video but the stuttering is so subtle that my camera can't catch the difference. On the other hand, I'm beginning to think it might partially be a perception issue on my side (perhaps my brain handles the Vireio shader better?), today I felt less sick when trying HL2 so it seems I might eventually get my VR legs after all. I'll look more into it but more calmly as I don't want to force myself (my head still feels funny), nor want to make rushed conclusions. I also found a post by Geekmaster which lead me to change the panel brightness to 0, which actually seems to be helping on the motion sickness side.
  • WalkyWalky Posts: 357
    Brain Burst
    I can confirm that it was just a framerate issue, all while wrongly assuming that: a) 50-55 fps shouldn't feel much different than 60, and b) Games on the Rift should never go below 50% of the normal no-Rift framerate. The latter is especially notable with Source games, most specifically HL2, which used to run at 150+ fps at high settings with AA/AF on 1440x900 and surprisingly manages to drop to about 40 fps at many moments while on "Rift stereo" (even when sometimes it goes waaay up), even If I try lowering the graphic settings (this includes disabling all filters and even lowering the resolution to 1280x800). I hope it's just because of Windows XP and non-optimized drivers and it goes better once I go back to dual boot, but I'll sure need to get an upgrade in the future anyway :P . At least my VR legs are here to stay so meanwhile I can still easily handle a couple of hours of stroboscopic (~30 fps) TF2 without nausea :lol:, and certain demos manage to stay at 60 fps so there's still lots of stuff to try.
  • I have the same problem. Even slow head movements are jittery. The tracking is stuttering on my monitor and in the headset. I hope there is a fix. It does give u a headache. It's almost unusable. I can make a video. Where should I send it?
  • EvilBeaNEvilBeaN Posts: 29
    I have a similar issue that I've seen in my trials last night. The games run 50-60+ fps in unity (also TF2 around 80-90) and the mouse movements are always as smooth as can be on the monitor screen. However even the slightest head movement with the headset on the judder/blur is extremely intense.
  • WalkyWalky Posts: 357
    Brain Burst
    It's normal for the monitor to look smoother than the Rift (we see it at a different scale, after all, and distances between objects on different frames is extended, like looking at objects move 5cm by frame instead of 5mm). The blur is normal on the current model, the problem is the "stroboscopic" effect (I think that's what some people call judder) which is what I mentioned above and is excessive at framerates lower than 60. Judder will be there at 60+ fps, but it will be greatly reduced. Sometimes blur can eventually help make things look less choppy depending on the situation, not the ideal fix though. There's a nice writeup from Michael Abrash that explains the issue very clearly: http://blogs.valvesoftware.com/abrash/down-the-vr-rabbit-hole-fixing-judder/

    There's also a chance that you are experiencing a computer-side problem that is making you lose frames for some reason. There's a mention of an issue like this near the end of the first post on the following thread: viewtopic.php?f=20&t=1758
  • shellfrshellfr Posts: 12
    NerveGear
    edited August 2014
    Same issue here!

    apps with no stutter:

    vr Desktop (the one includes in OR software)
    Tuscany
    Radial G
    PolyWorld
    Cyberspace
    Chilling Space
    World of Diving
    Ocean Rift

    Apps with tracking stutter
    Kokiri Forest
    Virtual Desktop
    Red of Paws Big...
    Euro Truck Simulator 2
    Project Cars :(

    Sli < no Sli ; low or high fps ; vsync or not ; low persistence or not; all of that don't change anything.

    I insist, this is only a "tracking stuttering". When i move in game whith mouse or pad, it is really smooth, no stutter at all. Stutter appears only when i move my head.
    And i dont think it is a hardware defect, cause it work great in some apps.
  • shellfrshellfr Posts: 12
    NerveGear
    Here is a video:


    As you can see, even static menu is jumping when i move my head.
  • rtweedrtweed Posts: 58
    Brain Burst
    There are another couple of threads about this (search "judder" or "stutter") so it seems to be a common issue. It affects me too.

    The fix that seems to work most of the time is to set the Rift to extend desktop mode in the control panel, but still run the direct-to-rift version of the game/demo. Sometimes that doesn't work, in which case setting the rift as the primary monitor and running the game/demo on that desktop might work. I've avoided this solution because it tends to mess up my desktop and takes ages to get everything back where I need it.

    I also found that, as I have 2 monitors, turning one of them off also fixed the problem.

    The most likely explanation I have seen is that games/demos are artificially limiting their frame rate below 75fps even though they are capable of achieving that rate. This may be because instead of currently syncing to the Rift's vertical refresh at 75Hz, they are syncing to one of the other displays at around 60Hz.

    BTW, like most people with this problem, I am not getting it in either of the two Oculus demos (room / Tuscany). If you are getting the same problem in those demos, you most likely have a different problem to everyone else. You can still try the same fixes and report back on whether it made any difference, but you should indicate whether or not the Oculus demos are working, and which GPU you have.
  • MatuXMatuX Posts: 9
    Exact same issue with DK2. Haven't been able to solve it with anything.

    FPS seems to be fine. Its just the head tracking.
  • I too am having some head tracking stuttering in the Tuscany demo.
    I'm using a GTX260 gpu on 64 bit Windows 7.

    FPS is smooth, but turning my head causes the stuttering.
  • MatuXMatuX Posts: 9
    I have the same problem with HL2. I get the feeling this is all because of the damned "Extend Desktop to the HMD" option.
  • soggothsoggoth Posts: 5
    Same thing here, running on 21.5" iMac with GF 650M.
    I'm getting a noticeable jitter in both Room demo scene and Tuscany.
    FPS in Tuscany is 60-62, moving camera with mouse is ok, but head tracking is jittery in the headset. Picture on the monitor always moves smooth, so jitter is a headset-only issue. Fiddling with frequency and resolution does not help.

    I have also tried DK2 on my other laptop (17" MacBook Pro with Radeon HD6750M) - it looks better there, room demo was smooth, but Tuscany still jittery. Interesting thing - head tracking in Tuscany works more or less fine until I touch the mouse. If I move camera with the mouse even once - head tracking starts to jitter.

    Both Macs running the same version of MacOS and both GF650M and HD6750M cards are definitely powerful enough to run room demo. The most obvious difference is that iMac has USB 3.0 while MacBook is USB 2.0, not sure if it might be the case.

    I'll keep trying on other hardware I can get my hands on.
  • soggothsoggoth Posts: 5
    OK, looks like I should read the manual from the beginning :)
    " wrote:
    As with Windows, it is possible to mirror the same image on all of your displays. Oculus recommends against mirroring. Click Arrangement and ensure Mirror Displays is not enabled.

    Disabling mirroring and setting Oculus as primary display fixed the problem
  • AnonymousAnonymous Posts: 124
    soggoth wrote:
    FPS in Tuscany is 60-62, moving camera with mouse is ok, but head tracking is jittery in the headset.

    These low frame rates are where you're seeing judder. On traditional monitors getting consistent 60fps is a perfectly acceptable experience. In the Rift we humans happen to be very sensitive to dropped/incomplete frames when the display is covering our entire vision. To completely eliminate judder you're going to have to consistently get the same 75fps that the Rift is outputting. Any less and you'll see judder.
  • jhericojherico Posts: 1,420
    Trinity
    deanbeeler wrote:
    soggoth wrote:
    FPS in Tuscany is 60-62, moving camera with mouse is ok, but head tracking is jittery in the headset.

    These low frame rates are where you're seeing judder.

    Unless he has the Rift configured for 60 Hz.
    Brad Davis - Developer for High Fidelity
    Co-author of Oculus Rift in Action

  • soggothsoggoth Posts: 5
    deanbeeler wrote:
    soggoth wrote:
    FPS in Tuscany is 60-62, moving camera with mouse is ok, but head tracking is jittery in the headset.

    These low frame rates are where you're seeing judder. On traditional monitors getting consistent 60fps is a perfectly acceptable experience. In the Rift we humans happen to be very sensitive to dropped/incomplete frames when the display is covering our entire vision. To completely eliminate judder you're going to have to consistently get the same 75fps that the Rift is outputting. Any less and you'll see judder.

    After disabling mirroring and setting Oculus as primary display, I'm getting 75 FPS in Tuscany and judder is gone.

    It looks like for some reason mirroring to a second display gets only 60 Hz on my Mac
  • It's strange because it's not a frame rate issue.
    I have a machine with Titanium GTX 780, 64GB of ram, and i7 at 4,3Ghz. So with that got out of the way, i have a single model in Unity, no crazy shaders, nothing, building the game, and i still have stuttering. When i move the mouse, it's perfectly smooth, so it must be the head tracking. I think it's a Unity thing, because on the roller coaster Unreal4 demo, the camera is perfect, not smooth, not fine, but perfect. That's also why most unity demos/games do that. But it also extends to Minecrift. So at the end of the day, the guys at Epic Games are doing something in Unreal that others don't. Dunno, just my 2 cents.
  • RichardM1RichardM1 Posts: 4
    I've been struggling with this issue for the past few weeks. From my research, this is an FPS issue and only judders when looking around with the Oculus (hence why mouse movement is smooth). If the game drops below 75fps, then you will experience extreme judder, if it is at or above 75fps, then it will run super smooth. You can verify this by downloading Fraps and looking at your FPS. One possible solution is to make sure you are not running V-Sync because that may limit your FPS. Also, I found running demos in DX11 and 64bit builds with all other applications closed runs best.

    This wasn't an issue several months ago (in January) when I was using the DK2, so I am assuming that a new hardware driver update for the rift is to blame because when I reverted back to old software drivers (0.4.4), it still happens when in the past it didn't. The best explanation for why stutter happens when the rift is under 75fps is described in this post:

    http://forum.unity3d.com/threads/major- ... st-2142371

    Hopefully an update will address this issue so that the judder wont happen if the FPS goes under 75fps.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    V-Sync is always forced on with the Oculus SDK, so anything below 75fps will stutter (meaning it will run at 37.5fps). You need to optimize your application to always stay above 75fps.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • RichardM1RichardM1 Posts: 4
    Thanks for the reply. When I say stutter, I mean that what I am seeing is double images of everything when I am looking around, it's not just an FPS slow down. I don't recall having this issue several months ago and I know I was likely running many apps below 75fps. Do you know what feature was recently implemented that started causing the stuttering?

    Having a requirement of always running above 75fps seems a bit ridiculous to me, so I hope this gets changed... it would be nice if there were 2 methods of running the Oculus, one with the super smoothness and requirement of always running above 75fps, and another that might not be as smooth but doesn't stutter (like it used to be). The stuttering is a deal breaker.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Yes, it will look like a double-image. People call this judder, stutter, etc. it's all the same. So you really need to make sure you hit the full refresh rate. This will not really be changing (except to jump to 90Hz for CV1). However, time-warp can mitigate the issue somewhat, though you'll still not want to consistently be missing the performance target as it will be uncomfortable to players.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • RichardM1RichardM1 Posts: 4
    Gotcha. Well I see why John Carmack kept saying that you'll want to keep your graphics around N64 level then lol (although he was referring to GearVR of course). Keeping above 75 fps (not to mention 90fps) will be a challenge for developers but it'll be a fun challenge ;)

    How does one go about enabling time-warp? Is that only on the developers end before making the exe?
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    It's different for each engine, but on Unity I believe it's on by default.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • momotssmomotss Posts: 2
    NerveGear
    i found the solution go to the oculus debug tool and set Asynchronus Spacewarp to off
  • imTheSpoodermanimTheSpooderman Posts: 4
    NerveGear
    Type your comment 

Sign In or Register to comment.