New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

SOLVED - VR application closes "unexpectedly" whenever I put the headset on.

KingsfoilKingsfoil Posts: 1
edited March 2016 in Support
It turned out that the phone required an update to the Oculus store app (even though it had only been downloaded this morning) - not that it said anything about that in the error message. All fixed and up and running now.

Hi everyone, I'm really new at this and pretty excited about getting a Gear VR with my Galaxy s7 Edge. Everything went fine with downloading software, but whenever I put the headset on I get the following error message "VR application closed unexpectedly. Remove mobile device from Gear VR , then reinsert mobile device and reopen VR application". 

I have removed the phone and reinserted it a hundred times trying to get this to work, rebooted the phone, etc.. and all I get is this message. Apparently I'm meant to be 'good to go' now, but I'm not getting anywhere. Any advice? I'm sooooo frustrated with this :(

The last instruction doesn't seem to make any sense to me either. It says to reinsert the device and then reopen the VR application, but once I reinsert the phone I can't do anything (including reopening the VR application)!


  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Would you mind contacting Oculus Support about this issue? Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • bienorbienor Posts: 2
    edited March 2016
    Same issue here. I also got the update this morning, but it haven't solved the problem, still getting the same error message. I tried to contact support, but page is not working right now, fails with Error 500.
    (On Samsung S7 Edge)
  • ggqt3ggqt3 Posts: 1
    same here this sucks I think its because this is a new thing they dont have all the bugs worked out. Mine was awesome now it just says unlock phone and re insert in vr over and over so bummed I was singing the praises of this vr....not so much anymore
  • I just bought this thing and I haven't even been able to use it a single time because of this error.  How do. Update the store app?
  • Never mind, I got it working.
  • mburkemburke Posts: 1
    I was having the same problem but I figured it out, open the oculus app on your phone and click browse store, then it should say there's an update
  • bienorbienor Posts: 2
    Uninstall and reinstall the three Oculus app on my phone solved the problem.
  • zurich31zurich31 Posts: 1
    edited March 2016
    Same problem :( 
    Re-installing now ..
    (on S6 Edge)
  • swb53swb53 Posts: 1
    going to the store and downloading the update solved the problem for me as well;
  • tony921tony921 Posts: 1
    Yep, Update worked!
  • Ran update and now it is working!!! Thank You!
  • @cybereality I was at best buy for 3hours trying to fix that and we did everything and even factor reseting my phone do I still have 2 wait on the update?
  • @cybereality and I did sumbit a ticket
  • oonkeroonker Posts: 2
    Anyone having trouble with the app launching? I just got a Gear VR and (almost) every time I plug in my S6 Edge it crashes. Have re-installed the app, but that only works the first time. Does anyone have any solutions?
  • soularmotionsoularmotion Posts: 0
    Having the same problem on Galaxy S7 Edge and my Samsung Gear VR.  My overall experience is that this is buggy and un-intuitive.

    After the "unexpected closes" I launched the app and saw that it needed to update "Oculus System Activities". I hit "Update Now" and it downloaded something, but then went back to the same screen and said it needed to update the same thing. Tried again, repeat, rinse .... endless loop. Ugh.

    Tried completely un-installing and couldn't find it in the Play store (must be a Samsung-specific or other app store?), so I re-inserted into the GearVR to trigger the re-install, went through the same steps, and I'm still in an endless update loop ...
  • I have the same problem on my s6 edge plus with the new samsung vr
  • mkiebmkieb Posts: 1
    Same problem with a Samsung Galaxy 7. Very buggy, and pretty clear the instructions are written by a non-native speaker.
  • ManchershawManchershaw Posts: 3
    Continuing to have this problem with s6 edge plus.  Worked previously.  Up to date.  Tried uninstalling and reinstalling.  Crashes one second after screen goes black every time.

    I have app purchases.  This is starting to feel like a scam Occulus.  I've posted this in forums before.  If you don't at least reply I will be contacting the BBB and asking for a refund on the Gear VR and all application purchases.
  • jgheldjgheld Posts: 1
    The one I got from Amazon came with Chinese instructions.  Anytime I hook it up, the screen goes black, with a little X in one corner, stays for about 3 seconds, then disappears.  Happens on a Note 4 AND an S7.  I'm guessing I got a defective one.  I can't even read the guide to see if I am doing something wrong.  Will have to return and hope for an English one this time....
Sign In or Register to comment.