New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

"Oculus has stopped working" Oculus installer freezes after being launched

RedundantGamingRedundantGaming Posts: 6
NerveGear
So heres what happens when I attempt to install the Oculus software.

  1. Download software from https://www.oculus.com/en-us/setup/
  2. Run installer 
  3. Oculus logo fades in from black then fades back out
  4. Nothing else happens. The program stays a black box 
  5. If I click on it on the windows taskbar it immediately gives the windows error "Oculus has stopped working" and prompts me to close the software. Sometimes it does it 2 times in a row before actually closing.
I already ensured my Windows and Nvidia drivers are up to date. I also uninstalled sdk 0.8 and unplugged my DK2. So far none of these steps have had an affect on this issue. 

I don't have my CV1 yet but I would still want to resolve this issue before I receive it so my CV1 isn't a worthless brick when it arrives.

Comments

  • se2se2 Posts: 24
    Brain Burst
    I can report similar issue. I only get an error dialog "Oculus has stopped working" right after starting the setup tool and nothing else (no logo fading in). I just made a clean Windows (7 SP1 64 bit) installation with the newest NVIDIA driver (364.72) in preparation.
  • se2se2 Posts: 24
    Brain Burst
    Event Viewer events for my case:
    Application: OculusSetup.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NotSupportedException
    Stack:
       at System.Net.ServicePointManager.set_SecurityProtocol(System.Net.SecurityProtocolType)
       at Dawn.CertificatePinner.Initialise()
       at Dawn.DawnController.Main(System.String[])
    
    Faulting application name: OculusSetup.exe, version: 1.0.0.0, time stamp: 0x56e7526e
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.17514, time stamp: 0x4ce7bafa
    Exception code: 0xe0434352
    Fault offset: 0x0000b727
    Faulting process id: 0x1754
    Faulting application start time: 0x01d1893c0154d690
    Faulting application path: C:\Users\se\Downloads\OculusSetup.exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    
  • cyberealitycybereality Posts: 25,119 Oculus Staff
    Can you open a File Explorer window and paste this in the URL field:
    %LOCALAPPDATA%\Oculus\

    Then look for "OculusSetup.log" and sent that to me.

    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • RedundantGamingRedundantGaming Posts: 6
    NerveGear
    Can you open a File Explorer window and paste this in the URL field:
    %LOCALAPPDATA%\Oculus\

    Then look for "OculusSetup.log" and sent that to me.


    Will do! Here it is 
  • cyberealitycybereality Posts: 25,119 Oculus Staff
    @RedundantGaming Thanks. I'll have someone take a closer look. At a quick glance, it appears you may have another Oculus Runtime installed. Can you be sure to uninstall everything from Oculus from your computer first?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • RedundantGamingRedundantGaming Posts: 6
    NerveGear
    @RedundantGaming Thanks. I'll have someone take a closer look. At a quick glance, it appears you may have another Oculus Runtime installed. Can you be sure to uninstall everything from Oculus from your computer first?
    Originally I used the windows uninstall system to remove all Oculus software. I just deleted the Oculus directory under local and that had no effect. I can't find any other remaining Oculus directories to delete so I think its completely removed from my system now. 
  • I'm having the same issue.  After installation a black box with the oculus logo appears with colors fading in and out in the background.  I've never installed any oculus software in the past, I've updated my drivers, and the computer is brand new.  Please help.
  • PopopinselPopopinsel Posts: 179
    Art3mis
    [...]I also uninstalled sdk 0.8 and unplugged my DK2[...]

    Did you really only uninstall the old SDK or the old Runtime as well? If the uninstall of the old Runtime didn't went through successfully and you deleted files by hand you might have left a corrupted install left that collides with the new setup. You could try to install the old Runtime again, reboot, uninstall and reboot again. Maybe this cleans the old stuff.
  • RedundantGamingRedundantGaming Posts: 6
    NerveGear
    [...]I also uninstalled sdk 0.8 and unplugged my DK2[...]

    Did you really only uninstall the old SDK or the old Runtime as well? If the uninstall of the old Runtime didn't went through successfully and you deleted files by hand you might have left a corrupted install left that collides with the new setup. You could try to install the old Runtime again, reboot, uninstall and reboot again. Maybe this cleans the old stuff.
    My bad I might of poorly worded that. I went into the windows uninstall system and uninstalled every application with "Oculus" in the name which included the run time. 
  • PopopinselPopopinsel Posts: 179
    Art3mis
    edited March 2016
    OK.

    So the last thing your log file says is "All preflight checks passed". According to my own log file the next thing it wants to do is download the necessary files from the Oculus servers to your temporary download location which is "C:\Users\Kyle\AppData\Local\Temp\OculusSetup-<GUID>". The first file it catches is "teaser.wmv" which is the teaser movie that runs in the background of the Oculus Setup where you only see a black box.

    So maybe a) your AV/Firewall is blocking the download or b) Oculus servers have problems or c) Oculus uses Windows Media Framework and you have removed it from your PC (or uninstalled Windows Media Player).

    Edit: or d) have a look at this thread: https://forums.oculus.com/community/discussion/32469/oculus-1-3-installer-crash-after-showing-oculus-logo#latest
  • RedundantGamingRedundantGaming Posts: 6
    NerveGear
    OK.

    So the last thing your log file says is "All preflight checks passed". According to my own log file the next thing it wants to do is download the necessary files from the Oculus servers to your temporary download location which is "C:\Users\Kyle\AppData\Local\Temp\OculusSetup-<GUID>". The first file it catches is "teaser.wmv" which is the teaser movie that runs in the background of the Oculus Setup where you only see a black box.

    So maybe a) your AV/Firewall is blocking the download or b) Oculus servers have problems or c) Oculus uses Windows Media Framework and you have removed it from your PC (or uninstalled Windows Media Player).

    Edit: or d) have a look at this thread: https://forums.oculus.com/community/discussion/32469/oculus-1-3-installer-crash-after-showing-oculus-logo#latest

    Option D fixed it for me! I had all my libraries redirected to my non SSD because I only use my SSD for storing programs. Thanks for the assistance!
  • dm18dm18 Posts: 25
    Brain Burst
    edited March 2016
    Hey will you try some thing for me? 
    Plug in the USB of the camera and headset. BUT leave the HDMI unplugged. 
    Reboot

    Does oculus now stay open? 

    if so, when you plug in HDMI does it close again? 
  • bo3bbo3b Posts: 64
    Hiro Protagonist
    edited February 2017
    Well, this is still a problem today.  Sigh.  Disappointed.


    Trying to install latest runtime.  Installer crashes at launch with the same exception above.

    This is on completely clean Windows 7 install with all patches, and nvidia driver 378.49.

    Oculus software has never been on this system, appdata has no Oculus folder.


    Faulting application name: OculusSetup.exe, version: 1.10.0.48278, time stamp: 0x583dd00e
    Faulting module name: KERNELBASE.dll, version: 6.1.7601.23572, time stamp: 0x57fd0379
    Exception code: 0xe0434352
    Fault offset: 0x0000c54f
    Faulting process id: 0x1414
    Faulting application start time: 0x01d289bc0bad3f82
    Faulting application path: C:\Users\bo3b\Downloads\OculusSetup.exe
    Faulting module path: C:\Windows\syswow64\KERNELBASE.dll
    Report Id: 4a4ef802-f5af-11e6-b6c7-9cb6d00ae778Application: OculusSetup.exe
    Framework Version: v4.0.30319
    Description: The process was terminated due to an unhandled exception.
    Exception Info: System.NotSupportedException
    Stack:
       at System.Net.ServicePointManager.ValidateSecurityProtocol(System.Net.SecurityProtocolType)
       at Dawn.CertificatePinner.Initialise()
       at Dawn.DawnController.ActualMain(System.String[])
       at Dawn.EntryPoint.Main(System.String[])

  • bo3bbo3b Posts: 64
    Hiro Protagonist
    Well it's still sad that Oculus software is so poorly written, but I found the answer to the System.NotSupportedException crash above.

    You need to install an optional OS update.  KB2565063.

    If it's required by the software, it should check, this is not rocket science.  Sad, sad, sad.
  • bo3bbo3b Posts: 64
    Hiro Protagonist
    One last silly problem.  Even after launching, the installer fails with the message about requiring the Platform Update and a security fix.  Naturally both of those are already installed as proven by downloading the msi and running them.

    You need to bypass the check in an admin cmd, in order to install.
    OculusSetup.exe /bypassHotfixCheck


    So.. yeah.  Missed a check that was actually required, and just crashes.  And then blew the check for stuff that is already there and blocked continuing.  So failing in both directions.

    That's a fine piece of... software right there.

  • AstrotreksAstrotreks Posts: 7
    NerveGear
    edited December 2017
    I have done everything I can think of to get rid of oculus files. It's still not working. I just want to install the new version back. 
    It seems people were having these issues over a year ago. Any updates on fixes that could help me?
  • cakeusercakeuser Posts: 1
    NerveGear
    Just going to add how I got around this for the CV1....

    Try moving the setup exe file to your C drive and launching it from there. Had the same freezing issue as OP, until I moved it to the Windows drive, then it was fine.
Sign In or Register to comment.