New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Disable "Your computer doesn't meet Rift's recommended specifications" message in Oculus Home?

12467

Comments

  • jjkrogsjjkrogs Posts: 52
    Hiro Protagonist
    I have to think at this point it was part of the agreement to "team" up with PC makers like Alienware, and therefore may not be something they can choose to disable.  It's actually quite smart as it is basically an advertisement disguised as a technical message.

    "Your computer sucks..."  but let me actually LINK you to a company that will make you a new one...
  • iczerjonesiczerjones Posts: 67
    Hiro Protagonist
    jjkrogs said:
    I have to think at this point it was part of the agreement to "team" up with PC makers like Alienware, and therefore may not be something they can choose to disable.  It's actually quite smart as it is basically an advertisement disguised as a technical message.

    "Your computer sucks..."  but let me actually LINK you to a company that will make you a new one...
    Which on the flip side is a little extra insulting given a larger proportion of the users in this case (vs. general public) are fully capable of building/upgrading their rigs themselves. (more technically capable)  

    Bury the setting somewhere completely non-obvious or something, but give us an out!   It is especially spurious in my case as my processor is simply a 'Xeon' version of a supported chip - literally the only difference is I have ECC support and the i7 doesn't. (not that I'm using ECC, but that is still the ONLY difference between my chip and the i7-4770)
  • leo1954auleo1954au Posts: 364
    Nexus 6
    When I first installed the rift software every thing worked ok but it was telling my to update my USB3 drivers so I downloaded some drivers from the intel web site and installed them instead of the drivers from gigabyte and all was good for a day or so but now I'm getting { Your Computer doesn't meet Rift Recommended Specifications} message, Good thing I only use the Win 7 drive for showing my friends the rift working and use another drive with Win 10 to play my games and stuff,  Strange thing is the gigabyte drivers for win 10 worked ok and I never had to use the ones off the intel site
  • rum3baerrum3baer Posts: 1
    Same here. My Xeon E3-1241v3 is the same as an i7-4770 (Haswell) and way above the minimum recommended spec CPU. It would be nice if Oculus could at least include the Xeon Versions of the suppported Intel CPUs.
  • leo1954auleo1954au Posts: 364
    Nexus 6
    Strange thing is I switched my PC on this morning started the rift home and no error message, Guess it decided my system did meet the specs
  • ThunderSqueakThunderSqueak Posts: 4
    NerveGear
    Still no official fix for this?  I don't want to modify what chip my PC thinks it has.  It would be nice if there were an official word from someone saying if they were even going to look at the issue.
  • JaRailJaRail Posts: 1
    NerveGear
    Another month has gone by.. I still haven't seen a solution. This is STILL annoying me. Seriously, how hard would it be to add code to bypass this check? A quick read from a regkey and an if statement? Well, who knows but this really needs a fix. I'm sure we'll keep seeing new unrecognized chips/hardware that triggers this.
  • XMercXMerc Posts: 108
    Hiro Protagonist
    Oculus seems to think my CPU is not powerful enough which is a joke because i'm running dual X5690 CPUs (12C/24T 3.73ghz)...its SIGNIFICANTLY more powerful than the minimum I5 recommendation. Any official way to fix this?
  • ndepoelndepoel Posts: 8
    NerveGear
    I have the same problem on my mini-ITX home theater PC with a Core i3-6300, which is more than capable of good VR despite not meeting the recommendations. I figured out an alternative solution. It's not an official fix by any means, but it's cleaner and more permanent than that registry hack.

    Knowing that Oculus Home is a Unity application, I was able to find the bit of code where the hardware specifications are checked and the result gets passed through to the user interface. I made a patch that changes that code to always say the PC meets the recommended specifications, which removes the notification. It's just a single line of code that's changed and doesn't have any other side-effects.

    I wrapped up the whole thing into a simple patcher utility that figures out where Oculus Home is installed and modifies that bit of code. You can get it from Github from the link below. Pre-built binaries can be found in the "releases" tab.

    https://github.com/ndepoel/OculusSpecsPatcher

    Of course this only works on Oculus Home. The notification in the Oculus desktop app remains untouched.

  • Lord_KiRonLord_KiRon Posts: 1
    NerveGear
    +1 for remove this damn message option.
    My CPU is fine, the system is 1080 with 16GB ram and OC-ed i7-2700, runs everything fine, the message annoys.
  • Percy1983Percy1983 Posts: 1,408
    Wintermute
    My fix still works best...
    ...I ignore it, I then launch a game/program and enjoy it.
    Asrock Z77 Extreme 4 + 16GB RAM 1866mhz + i5-3570K at 4.5Ghz + Coolermaster Nepton 140XL cooler
    Sapphire 8GB RX 580 Nitro+
    256Gb SDD Samsung Evo 850 +3x2TB in raid 0 with 64GB SSD cache
    Thermaltake Level 10 GT Snow Edition + Toughpower 875w
  • XMercXMerc Posts: 108
    Hiro Protagonist
    This seriously needs to be added as an option to turn off....
  • ThatOdieGuyThatOdieGuy Posts: 4
    NerveGear
    GTX 1060 here, Oculus say it's not good enough. "Get a 970 or higher" it says... piss off.
  • Westside123Westside123 Posts: 1
    NerveGear
    Exactly this annoying message is not only irritating it stops you from playing (and buying) any games from the Oculus store. 

    I am only borrowing a DK2 at the moment to experiment, but based on my experience so far with it whining about a genuine USB 3.0 port not being good enough and telling me to buy additional hardware or it whining about my 2600k running at 4.6ghz  and it telling me that I need to buy a new PC is quite frankly insulting and arrogant.

    For a tech company that is aiming its products at PC enthusiasts who know what they are doing, they are doing a wonderful job of putting them off buying any of their products. Technologies can sometimes fail because of pricing, unreliability or simply because the people making the hardware really have no idea who or how to interact with their customers.

    At this point if I do invest in VR tech I am at this point more likely to go and buy a Vive.
  • zbosonzboson Posts: 994 Poster of the Week
    GTX 1060 here, Oculus say it's not good enough. "Get a 970 or higher" it says... piss off.
    Are you sure it's due to the GTX 1060?  I was thinking of getting at GTX 1060 in a laptop because I work mobile a lot.
  • zbosonzboson Posts: 994 Poster of the Week
    edited September 2016
    Exactly this annoying message is not only irritating it stops you from playing (and buying) any games from the Oculus store.
    How is it stopping you from playing and buying games from the Oculus Store?  I have had this stupid warning since day 1. I have never used a system that did not have this stupid warning. It's never stopped me from buying or playing games from the Oculus Store.
  • ndepoelndepoel Posts: 8
    NerveGear
    zboson said:
    GTX 1060 here, Oculus say it's not good enough. "Get a 970 or higher" it says... piss off.
    Are you sure it's due to the GTX 1060?  I was thinking of getting at GTX 1060 in a laptop because I work mobile a lot.
    The GTX 1060 is faster on average than the GTX 970 and it has added VR features like simultaneous multi-projection, so it is more than good enough to power the Oculus Rift. I have no idea why it would get rejected by the compatibility tool.
  • TheJoghurtTheJoghurt Posts: 2
    NerveGear
    @Oculus: Please let us switch this off!
  • zbosonzboson Posts: 994 Poster of the Week
    My guess is that Palmer Luckey has had a big influence on this hardware warning and lack of a switch to disable it. He has made multiple arrogant comments about crappy hardware.
  • Techy111Techy111 Posts: 5,140 Volunteer Moderator
    edited September 2016
    Not sure if this is known, but navigate to D (or C or whatever)Oculus\Support\oculus-runtime and simply delete Compatibility.json and restart oculus service. That should remove it both inside and outside the headset without registry tweaks.

    Not from me but on shhhhhhh.........reddit ;)
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.
    And FlyInside Forum Admin.
    Flyinside Flight Simulator RELEASED.
  • zbosonzboson Posts: 994 Poster of the Week
    Techy111 said:
    Not sure if this is known, but navigate to D:  (or C or whatever)Oculus\Support\oculus-runtime and simply delete Compatibility.json and restart oculus service. That should remove it both inside and outside the headset without registry tweaks.

    Not from me but on shhhhhhh.........reddit ;)
    That worked!!!
  • ndepoelndepoel Posts: 8
    NerveGear
    Techy111 said:
    Not sure if this is known, but navigate to D:  (or C or whatever)Oculus\Support\oculus-runtime and simply delete Compatibility.json and restart oculus service. That should remove it both inside and outside the headset without registry tweaks.

    Not from me but on shhhhhhh.........reddit ;)
    That's a very neat solution!

    I did notice that that file seems to get auto-updated regularly, so it's possible that it reappears after a while. Deleting it again should fix it, but depending on how often it gets updated, that might get annoying.
  • owencahillowencahill Posts: 8
    NerveGear
    Nice one....!  That worked a treat.  Thank you.
  • TwoHedWlfTwoHedWlf Posts: 2,216 Valuable Player
    Exactly this annoying message is not only irritating it stops you from playing (and buying) any games from the Oculus store. 
    It doesn't stop you from doing anything, if you can't play or buy games from Home then you have some other problem beyond a extremely minor annoyance from a little message.
  • ChillisteakChillisteak Posts: 22
    Brain Burst
    New to the Rift last week and I'm just glad I don't use the Oculus app for anything, that message upsets me every single time I have to acknowledge it.
    My system is more than capable of running any game I'ver tried in VR at 90fps plus, and I've barely had to drop any visual settings to achieve that. Yet because my CPU isn't on their "required" list it's doesn't meet their specifications.

    A toggle is required, because it's stupid that it keeps throwing it in peoples faces.

  • NoxasaNoxasa Posts: 12
    NerveGear
    edited October 2016
    Oculus changed the location of the compatibility.json file to C:\Users\<<username>>\AppData\Local\Oculus.

    Also, now Oculus tries to get around you deleting the file by automatically downloading a new one with the Oculus VR Runtime servce starts.  It first downloads a file called CompatibilityNew.json and then renames it to Compatibility.json. 

    In order to get around this you will need to either rename the old Compatibility.json file to CompatibilityNew.json or create an empty text file called CompatibilityNew.json and delete the old Compatibility.json file.  Then go to properties for that file and change it's security privileges so that all "Groups and User Names" have "DENY" access.  That way, when the runtime tries to download a new CompatibilityNew.json when it starts, it gets a write error and cannot download the new file, thus, causing it to skip the compatibility testing routines. 

    After modifying the security settings for that file just restart the Oculus VR Runtime service and it will no longer show the nag message.

    I don't know why Oculus is fighting its user base with this nag message considering all the bugs and flat out wrong data in their hardware compatibility lists.  Get with it Oculus, this is why we don't buy Apple computers, we don't need our hands held and you should allow us to switch to expert mode for those that don't need or want it.

  • ndepoelndepoel Posts: 8
    NerveGear
    edited October 2016
    My patcher tool also doesn't work anymore. Looks like Oculus are monitoring this thread and actively counteracting any solution that gets presented here. Way to be hostile towards your customers, Oculus.

    [edit]
    I take that back. They simply moved the various classes in the Oculus Home code into properly named namespaces, which is a programming best practice. The actual code remains the same. I'll create an update for the patcher, if anyone still wants to use it.
  • TwoHedWlfTwoHedWlf Posts: 2,216 Valuable Player
    This has
    Noxasa said:
    Oculus changed the location of the compatibility.json file to C:\Users\<<username>>\AppData\Local\Oculus.

    Also, now Oculus tries to get around you deleting the file by automatically downloading a new one

    Blah blah blah

    After modifying the security settings for that file just restart the Oculus VR Runtime service and it will no longer show the nag message.

    This has definitely gotten to the point it's more trouble than it's worth to get rid of a little message that does no harm beyond wounding the  delicate egos of people who get upset at being told their PC doesn't match a compatibility list. :)

  • ndepoelndepoel Posts: 8
    NerveGear
    TwoHedWlf said:

    This has definitely gotten to the point it's more trouble than it's worth to get rid of a little message that does no harm beyond wounding the  delicate egos of people who get upset at being told their PC doesn't match a compatibility list. :)

    It's a matter of principle. I have two PC's that meet and exceed the recommended specs by Oculus, and one PC with a Core i3 processor that I rarely use VR on anyway, so I'm personally not too bothered by the actual issue. And if it had just been a message of "hey, your PC might not be able to handle VR properly" and you could dismiss it, there wouldn't be any problem at all.

    But the reality is that you can't dismiss the message despite numerous complaints, Oculus chooses not to acknowledge the issue, and even seems to oppose the community from behind the scenes. And especially now that they're promoting horribly underpowered AMD machines for VR use, that message seems to be less about informing customers and more about pushing them to buy new hardware from Oculus' preferred partners.
Sign In or Register to comment.