New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Issue with GearVR development after exporting as Google Android Project

I'm new to Unity development. So, I would like to say sorry if my question is worthless for a forum.

I started learning to develop an application in Unity for GearVR. In my scenario, I want to export Unity app as Google Android Project to Eclipse for further development. In Eclipse, I pass a message to a function in Unity through Sendmessage().

My first step was to develop the application and running in Note4 without enabling "Virtual Reality Support". It worked fine.

However, later I enabled "Virtual Reality Support" and export as a Google Android Project. Then, tried to install and run the application through Eclipse. But app crashed. Errors I was able to find in LogCat were "Fatal signal 11 (SIGSEGV) at 0xfa57132b (code=1), thread 9384 (UnityMain)" and "Unable to find OVRPlugin".

Then, I used "Build and Run" in Unity to install the app to Note4. This time, it worked fine.

So, app doesn't work when "Virtual Reality Support" is enabled and install through Eclipse after exporting it as a Google Android Project.

I reverse engineered the apk created by Unity when I used "Build and Run". I noticed some differences in exported Google Android Project and Reverse Engineered apk Projects. Specially, contents in libs folder were different.

It would be great if anyone can help me to solve this issue.

Answers

Sign In or Register to comment.