New oculust software 1.3 fails during install *My fix* — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

New oculust software 1.3 fails during install *My fix*

DontziDontzi Posts: 1
Every time when i try and install right after its doing the unpacking it gets to 842 and then fails, "please restart your computer and try again"

So after much searching and not finding anything good.
this is my fix to the problem.

I had the program installed earlier but then uninstalled to try an earlier runtime version.
but as i was installing it i got error everytime.

and for me it was failing in installing the visual ccp 2015, dont know why and dont care.

look in my program and features (windows 10) could see that microsoft visual c++ 2015 redistributable was there (2 of them one x86 and x64)

so i manually uninstalled them and then started oculus install again.

Success, no i can complete the install.



My error logs: 
[Debug] [02.04.2016 22:19:04] Installing 'Visual C++ 2013' redistributable.
[Debug] [02.04.2016 22:19:04] Process C:\Users\Dontzi\AppData\Local\Temp\OculusSetup-ffd5e886-1772-4c98-9cf2-45b890648222\visual-cpp-2013.exe exited with code 0 (success).
[Debug] [02.04.2016 22:19:04] Installing 'Visual C++ 2013 x86' redistributable.
[Debug] [02.04.2016 22:19:04] Process C:\Users\Dontzi\AppData\Local\Temp\OculusSetup-ffd5e886-1772-4c98-9cf2-45b890648222\visual-cpp-2013-x86.exe exited with code 0 (success).
[Debug] [02.04.2016 22:19:04] Installing 'Visual C++ 2015' redistributable.
[Debug] [02.04.2016 22:19:05] Process C:\Users\Dontzi\AppData\Local\Temp\OculusSetup-ffd5e886-1772-4c98-9cf2-45b890648222\visual-cpp-2015.exe exited with code 1638 (failure).
[Debug] [02.04.2016 22:19:05] Install 'Install necessary redistributables.' failed.
[Warning] [02.04.2016 22:19:05] Rolling back installation.
[Debug] [02.04.2016 22:19:05] Uninstall 'Install necessary redistributables.' succeeded.

Comments

  • nicoversitynicoversity Posts: 1
    NerveGear
    Hej Dontzi, perfect! I got the exact same problem, followed your instructions, and got the Oculus Setup 1.3 installed properly.

    I am using an new ASUS Oculus-ready machine with Windows 10 (64bit), and out of the box I had both "Microsoft Visual C++ 2015 Redistributable (x64)" and "Microsoft Visual C++ 2015 Redistributable (x86)" installed on the machine, which seemed to have caused the error ("failure") according to the OculusSetup.log in C:\Users\<yourUser>\AppData\Local\Oculus (make sure to tick the option to view "Hidden items" the the Windows explorers "View" tab, because AppData is a hidden folder):

    [Debug] [07/04/2016 09:47:02] Installing 'Visual C++ 2015' redistributable.
    [Debug] [07/04/2016 09:47:03] Process C:\Users\<userName>\AppData\Local\Temp\OculusSetup-25263e4c-3383-4526-ba58-bdd237ae39b1\visual-cpp-2015.exe exited with code 1638 (failure).
    [Debug] [07/04/2016 09:47:03] Install 'Install necessary redistributables.' failed.
    [Warning] [07/04/2016 09:47:03] Rolling back installation.
    [Debug] [07/04/2016 09:47:03] Uninstall 'Install necessary redistributables.' succeeded.
    [Debug] [07/04/2016 09:47:07] Removing temp directory.
    [Warning] [07/04/2016 09:47:07] Couldn't remove temp directory.
    [Debug] [07/04/2016 09:47:07] Exiting with code 1.

    After that, I manually uninstalled both of the above mentioned Visual C++ 2015 Redistributables from the "Apps & features" system settings, restarted the machine and started the Oculus Setup again. This time with success.

    So, I can confirm that this workaround seems to work. Make sure to search for the keyword "failure" within the OculusSetup.log, because it will not be flagged as an [Error] as in some other cases.

    Cheers,
    nico
Sign In or Register to comment.