New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Small Devs (or anyone) with a DK2 and still waiting on CV1...

gazzbassgazzbass Posts: 20
Brain Burst
I am a small dev with a CV1 on order (timestamp 08:15:34, 6th Jan). I was content to wait to install the 1.3 Oculus software when the CV1 arrived (you all know how that is going...).
Anyway, Unreal Engine 4.11.1 was released yesterday (we dev in UE4) with full 1.3.1 support so we took the plunge with the DK2.
Here is how we set up:

1. Uninstalled 0.8 runtime and drivers.
2. Rebooted (keeping the DK2 plugged in).
3. Pulled out an XBox 360 wireless controller for Windows and installed.
4. Navigated to http://www.oculus.com/en-us/setup and downloaded the setup program (2.8Mb).
5. Ran the setup process (844Mb download).
5.a. We already have an Oculus account so when asked, we signed in. (if you don't have one, you can create it here).
6. It complained that the sensor (camera) was a USB2 device and didn't seem to detect the DK2. We ignored this and clicked skip.
7. The setup program asks for your standing height. Other people have reported that the scaling seems wrong in the DK2, so I set my sitting height at 6 feet 8 inches (I am 5'11".. haha).
8. The setup program informed us that there was an update (1.3 to 1.3.1). We installed it.
9. Oculus Home opened up... no problems... I was somewhat surprised (it does state that DK2 is not supported... but it works).
10. Installed Dreamdeck.

Well, at this point, the DK2 felt like a different device, in a very good way. We were kind of blown away.
Everything was MUCH smoother! SDE is still there because well... its a DK2... but immersion leaped up a notch from 0.8!

Proceeded to update Unreal Engine to 4.11.1.

Loaded up our tech demo and hit "VR Preview"

To my utter amazement, it looked MUCH better than in Oculus 0.8/UE 4.10.4!

Now came the acid test.

We usually had to tone down the engine settings (anti-aliasing, post processing, shadows and effects down to medium or low) to minimize judder.
We adjusted the Engine Scalability settings to Epic across the board... guess what... no judder! Unbelievable!

The combination of Epic's UE 4.11.1 optimizations and the 1.3.1 runtime (ATW on there) is quite magical!

NOTE: In our project settings -> Rendering in UE4, we did turn off Ambient Occlusion, Motion Blur, Lens Flare and Anti-Aliasing was set to FXAA.

My dev system specs:

Intel Core i7 4790K Devils Canyon at 4.2 GHz
nVidia GeForce GTX 980 (not a Ti)
32Gb DDR3 2400 RAM
1Tb Samsung SSD
ROG Maximus VII Hero Z97 Motherboard
EVGA 850w Modular PSU
Corsair CPU air cooler

I hope this little write up gives small devs and enthusiasts alike some hope and encouragement.

Thanks for reading... I'm off now to try and kick the shit out of my dev system (or I should say "push the envelope" perhaps).
i7 4790K @ 4.4GHz - GeForce GTX 980 - 32Gb RAM 2400MHz
Dev using UE4
Sign In or Register to comment.