New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Rift + Oculus Ready PC not working :(

FelendisFelendis Posts: 1
edited April 2016 in Support
So I received my Rift today and worked through setting it up on the brand new PC I purchased to have a great VR experience. Unfortunately, the USB ports fail pretty much whenever I plug in the headset. A couple times I have been able to play a game for a few minutes, but it always ends up crashing.

The error I am receiving is:
Power surge on the USB port
Unknown USB Device needs more power than the port can supply.

I have tried probably 10 different configurations of where I plug in the headset, sensor, keyboard, and mouse in the USB slots. I have tried plugging the Oculus items into all of the USB 3.0 and 3.1 slots with the Oculus stickers on them, but no luck.

Below is a link to the computer I purchased. I have been using it for weeks with my Vive with no problems, nothing has gone wrong with it until tonight.
http://www.asus.com/Tower-PCs/ROG-G20CB-Oculus-Ready/

Appreciate any help I can get with this. I have attached my error log. Thanks!

Comments

  • If I was in your position I would contact Asus tech support, It may be an issue with the computer itself and need a RMA.
  • dmorrilldmorrill Posts: 2
    I just posted same thing.  Have you been able to figure anything out?  I have same computer.  I was thinking it was a driver, but no luck.  Interesting enough, I plugged into a laptop and I get the same message with a USB 3.0 device.  I am leaning towards a driver, but cannot find one. 
  • i got the same pc the gtx980 version but didn't have that issue mine was cable related, sorry i can't help
  • chemypanchemypan Posts: 1
    NerveGear
    same issue with me now. have you ever figured it out?
Sign In or Register to comment.