New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Stuck on Connection Status

AdeileiAdeilei Posts: 1
Hello there everyone.

Recentely updated to the new Oculus Software (1.3) for my DK2 and everything went well with the installation itself. However once I got the the configuring part it simply got stuck on the "Connect Your Rift Headset and Oculus Sensor" part, I have connected everything as written but the Headset HDMI and Headset USB just loads without progress. When I was using the 0.8 everything worked without any problems so I am not sure what to make of this so I would appreciate and help I can get!


  • SyntheticSynthetic Posts: 704
    skip skip skip
    it will work fine
  • KarmingtonKarmington Posts: 49
    Brain Burst
    So it does, thanks for the tip Synthetic
  • VoinceVoince Posts: 5
    edited April 2017
    I'm having the same problem connecting my touch controllers. The headset works fine, but the hdmi and usb loading is stuck. It wont set up if i hit skip. What do i do?
    -If i was warned that this device would become irrelevant I would have waited for the consumer version
  • CaptainsEyePatchCaptainsEyePatch Posts: 5
    No sorry. It really does not work.
    It just will not find my damn headset.
    Expensive Brick.

    Has this peice of shit for over a year. And its only ever worked a few weeks.
    Some people at Facebook need there asses fired.
  • McGibs30McGibs30 Posts: 32
    Brain Burst
    You own a DK2 you useless moron, Jesus Christ just shut the hell up already.
Sign In or Register to comment.