New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Problem with DirectX after clean Windows 10 and Oculus install

rodgermoorerodgermoore Posts: 4
NerveGear
edited April 2016 in Support
Did anyone encounter problems with content like "Henry" after a fresh Windows10 and Oculus Home 1.3 install? After some digging I found out some DirectX dependencies were missing on my totally fresh installed system. I tried to run Henry from Oculus Home but after the "VR Warning" screen it just jumped back to Oculus Home living room, with no additional info or error messages whatsoever. Running "Henry" from the Oculus installation directory in "Program Files (x86)" popped up the system error message "xapofx1_5.dll is missing". This is a DirectX related file. Downloading and running the Microsoft DirectX webinstaller from https://www.microsoft.com/en-us/download/details.aspx?DisplayLang=en&id=35 fixed it. Why isn't there a DirectX check included before starting Oculus Home?

edit:changed wrong DirectX link.

Answers

  • cyberealitycybereality Posts: 25,119 Oculus Staff
    That's strange. DirectX should be installed as part of the setup.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.