Everytime I setup Oculus - "Restart Computer" — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Everytime I setup Oculus - "Restart Computer"

elationelation Posts: 11

Everytime I install Oculus and run the set up, after it installs, it goes to this screen saying..

"Restart Computer

Sorry, we encountered an error during installation. Please restart your computer and try running Oculus Setup again. If you still experience issues, contact Oculus Support"

Has anyone else got this and what was your solution. It installs in C drive..

Comments

  • elationelation Posts: 11
    Hmmm... that means a lot of us are having this. I don't feel safe going into the computer code and editing it though, I feel like it might throw something else off. Does everyone have to do this?
  • CreesballCreesball Posts: 72
    Hiro Protagonist
    It's fine to edit that part of the registry.  That part is only there because of the first install attempt.  The highlighted directory below shows which folder to right click.

    Press Windows Key + R
    Type regedit
    Click the > by HKEY_LOCAL_MACHINE
    >SOFTWARE
    >WOW6432Node
    Right click Oculus VR, LLC and click permissions

    Click reorder
    click ok on the next dialog box that pops up.
    Try installing again.




  • elationelation Posts: 11
    For some reason, I don't get the reorder window.

  • elationelation Posts: 11
    Someone pleaseee help me. I've been trying to fix this for like 4 hours already with my Oculus just sitting there. Pleaseeeeee hah.
  • VrSpongeVrSponge Posts: 150
    Art3mis
    Try clicking advanced button...Is it there?
  • elationelation Posts: 11
    Somebody... help thy soul.
  • VrSpongeVrSponge Posts: 150
    Art3mis
    Is your firewall disabled? If it is turn it on. Then try again.
  • VrSpongeVrSponge Posts: 150
    Art3mis

    ) Run regedit.exe

    2) In the left tree view, right-click on HKEY_LOCAL_MACHINE, select "Permissions..."

    3) If a dialog comes up stating that the permissions are incorrectly ordered, click "Reorder"

    4) Click "OK" in the permissions dialog to close it

    5) Repeat step 2-4 on any of the following tree nodes that exist:

    - HKEY_LOCAL_MACHINE/SOFTWARE

    - HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node

    - HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Oculus VR, LLC

    - HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Oculus VR, LLC/Oculus

    - HKEY_LOCAL_MACHINE/SOFTWARE/Wow6432Node/Oculus VR, LLC/Oculus/Config

  • elationelation Posts: 11
    Yeah I've tried that but the "reorder" window does not pop up.
  • elationelation Posts: 11
    bump
  • VrSpongeVrSponge Posts: 150
    Art3mis
    When you open regedit are you right clicking and running as administrator?

    I don't now what else to do, I hope somebody figures it out for you.
  • elationelation Posts: 11
    I do it through Windows Key + R -> regedit.exe
  • KayosKayos Posts: 24
    Brain Burst
    Saw this on Reddit, worth a try:

    Another fix. I figured I'll post it here since this is the top comment.

    I had my Windows firewall disabled. Oculus home software tries adding a firewall rule but can't if it's disabled so the install fails. I re-enabled the firewall, installed, then you can disable it again. Oculus should be checking for firewalls on startup and see if they're enabled, not trying to add rules to firewalls that don't exist and erroring out!

  • Ricktor_BlackRicktor_Black Posts: 198
    Art3mis
    elation said:
    Hmmm... that means a lot of us are having this. I don't feel safe going into the computer code and editing it though, I feel like it might throw something else off. Does everyone have to do this?
    You should be careful what you do in the Registry, but as long as you do exactly as the steps say to do you should be fine.  The Windows Registry is basically the hidden database of all the settings in the background of Windows laid out in a non-consumer-focused way, but it's all setup hierarchically so the changes you make are under the Oculus branch so they should only effect Oculus things.
  • elationelation Posts: 11
    I found out how to fix it:

    1 - Update graphics stuff and drivers
    2 - Restart computer
    3 - Run Oculus compatibility tool
    4 - Uninstall McAfee
    5 - Restart
  • ViswarViswar Posts: 4
    NerveGear
    I had this issue as well, I just had to disable McAfee during installation. I also needed to disable it when installing apps in the store.
  • here's what solved it for me after doing all of the above which didn't work
     https://forums.oculus.com/vip/discussion/34364/another-sorry-we-encountered-an-error-during-installation
Sign In or Register to comment.