New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Rift Sensor Driver not found [SOLVED]

NeotribalNeotribal Posts: 11
NerveGear
I had a problem yesterday that I ended up fixing on my own... decided to post and share my solution in case anyone else can benefit from it (problem stemmed from a botched uninstall.... power outage).

My rift sensor was being reported as "Not detected" within the Oculus App. Device manager was reporting that it was unable to find the driver. Uninstalling and reinstalling the Oculus Software had no effect. I found a folder located in C:\Users\<username>\AppData\Local\Temp\Oculus\ that contained "OculusRiftSensorDriver.msi", but running the installer had no effect on my problem. Here's what worked:


Unpacked the .MSI contents using 7zip and renamed the files as follows:
  • OCULUSCAT > OCUSBVID.CAT
  • OCULUSINF > OCULUSINF.INF
  • OCUSBVID109 > OCUSBVID109.SYS
  • OCUSBVID111 > OCUSBVID111.SYS
Right-clicked OCULUSINF.INF, clicked "Install", driver installed successfully, fixed.

 B) 


«1

Comments

  • carrotnose21carrotnose21 Posts: 2
    NerveGear
    I dont do this very often but Ive had a similiar issue that I just couldnt install even after troubleshooting for 2 whole days straight and I just wanted to say thank you so much, this solved my issue.

    I didnt do exactly what you did (I just dragged the sensor driver program to the desktop and run it) but it seemed to work and I couldnt be more thankful.

    Thank you for your help.
  • +++111 Holy shit! You are awesome dude. My Rift was working 100% until today ( 9/14/16 ) when it prompted me to do a firmware update. After the Oculus storefront/app reset, the sensor ceased to be detected! I tried rebooting, attempting to rerun any official Oculus setup ( what a joke! Why would the setup not attempt to reinstall drivers even if a device is not "detected" [ read: still in detected by Windows as "CV1 External Camera", just with horked drivers] ).

    Then I attempted to install the drivers manually, by opening Device Manager, finding "CV1 External Camera" ( which was in "Other Devices" and not the camera section or whatever ), and pointing it at the folder: C:\Program Files\Oculus VR Runtime Drivers\Drivers\Rift Sensor .. Which SEEMS to have the exact same files as your fix.. but I guess not as Windows complains about not being able to find those. 

    None of that worked!! Until I used your fix and went to that AppData file and extracted the .msi as you suggested and the .inf that came from there installed just fine and my Rift Sensor was immediately detected and working again! Thanks sooo much!
  • Thank you. I hope Oculus can take a look at this and patch in a fix.
  • lord_ashtarlord_ashtar Posts: 8
    NerveGear
    When I try to do this 7zip tells me the files are read only. Can you help?
  • Techy111Techy111 Posts: 3,661 Valuable Player
    Try downloading Winrar and see if it says the same on extraction?
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.
    And FlyInside Forum Admin.
  • lord_ashtarlord_ashtar Posts: 8
    NerveGear
    I'm viewing the contents in winrar but can't seem to find a way to rename the files. I can extract them and rename them but don't know how to get them back into the msi file.
  • lord_ashtarlord_ashtar Posts: 8
    NerveGear
    well it looks like oculus just released a firmware update! lol
  • Techy111Techy111 Posts: 3,661 Valuable Player
    All sorted then ? :)
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.
    And FlyInside Forum Admin.
  • taxtax Posts: 2
    NerveGear
    It worked for me as well.
  • alexportugal1212alexportugal1212 Posts: 1
    NerveGear
    You are a real hero man! Thanks
  • Markus_AF_OculusMarkus_AF_Oculus Posts: 1
    NerveGear
    This also worked: got to ..AppData\Local\Temp\Oculus\OculusRiftSensorDriver.msi

    1) Run it by double clicking.
    2) Open the official Oculus setup program again and reconnect the sensors when prompted. 

    That´s it!
  • karlragkarlrag Posts: 1
    NerveGear
    :)  Thank you so much Neotribal. You helped me too.
  • NeotribalNeotribal Posts: 11
    NerveGear
    Glad this post has helped some people :smile:
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    Neotribal said:
    I had a problem yesterday that I ended up fixing on my own... decided to post and share my solution in case anyone else can benefit from it (problem stemmed from a botched uninstall.... power outage).

    My rift sensor was being reported as "Not detected" within the Oculus App. Device manager was reporting that it was unable to find the driver. Uninstalling and reinstalling the Oculus Software had no effect. I found a folder located in C:\Users\<username>\AppData\Local\Temp\Oculus\ that contained "OculusRiftSensorDriver.msi", but running the installer had no effect on my problem. Here's what worked:


    Unpacked the .MSI contents using 7zip and renamed the files as follows:
    • OCULUSCAT > OCUSBVID.CAT
    • OCULUSINF > OCULUSINF.INF
    • OCUSBVID109 > OCUSBVID109.SYS
    • OCUSBVID111 > OCUSBVID111.SYS
    Right-clicked OCULUSINF.INF, clicked "Install", driver installed successfully, fixed.

     B) 


    Please, can you tell me how to rename this files. My system does not alowed me to do this. Only if I edit it and save, but then, I have to save in other folder that doesn't work.

    I've spent about 10 hours on this issue with no sucess.... 
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    I'm viewing the contents in winrar but can't seem to find a way to rename the files. I can extract them and rename them but don't know how to get them back into the msi file.
    Just like myself. Do you fixed it?
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    Thank you. I hope Oculus can take a look at this and patch in a fix.
    Have you fixed it? I don't know how to rename the files without taking then off the .MSI
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    tax said:
    It worked for me as well.
    How do I rename this files? Please man, help me. 
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    You are a real hero man! Thanks
    Alex, are you from Portugal? I'm from Brazil and don't know how to rename those files. Can you help me with that? Please.
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    edited March 9
    karlrag said:
    :)  Thank you so much Neotribal. You helped me too.
    Can you please tell me how to rename those files. Please.
  • EspiemEspiem Posts: 4
    NerveGear
    Just ran into this problem and your solution worked perfectly. Thanks a ton Neo.
  • VictoryToasterVictoryToaster Posts: 1
    NerveGear
    I did what the first one said and BOOM worked i took those new folders and pasted them into the oculus folder and worked like a charm thank you so much
  • jarolo646jarolo646 Posts: 6
    NerveGear

    Many thanks I came perfect today I updated the rift and I passed the same there was no sensor driver, I run the installer and solved. Thank you
  • LokiLegionerLokiLegioner Posts: 2
    NerveGear
    This method work and for me)))) Great thanks!
  • OoZnarFoOOoZnarFoO Posts: 3
    NerveGear
    Thanks Neotribal!!
  • NeotribalNeotribal Posts: 11
    NerveGear
    :)

    Bruno, did you get sorted out?
  • ten10ten10 Posts: 79
    Hiro Protagonist
    edited May 1
    Neotribal - it worked for me, too, having the old DK2 and DK2-Camera. But since i've had a cleaning program (temp folders and other stuff) running a few days ago, this oculus folder in appdata/local/temp was gone. So i've downloaded the oculussetup.exe , ran it with the "repair" option and the newly created temp/oculus folder was back again. I've copied this folder to another partition as a backup - and followed your description.
    The blue light on the DK2 camera sensor  went on and VR programs are back working again.

    Many, many Thx !  (... now there is still the question left - why the updater didn't do it's job right ...).

  • ajaxlexajaxlex Posts: 2
    NerveGear
    edited May 2
    Hey.  I tried this option out, but the driver install fails, claiming that

    "The third party INF does not contain a digital signature"

    Any suggestions?  I am not excited about disabling integrity checks. 

    [EDIT] - Oops - misspelled the CAT file :smiley:

  • VanSladeVanSlade Posts: 1
    NerveGear
    Thanks a lot, It works!!! you guys are awesome
  • notrevnotrev Posts: 1
    NerveGear
    I dont do this very often but Ive had a similiar issue that I just couldnt install even after troubleshooting for 2 whole days straight and I just wanted to say thank you so much, this solved my issue.

    I didnt do exactly what you did (I just dragged the sensor driver program to the desktop and run it) but it seemed to work and I couldnt be more thankful.

    Thank you for your help.
    I didn't have to move it, just executed it and it worked.
    Thank you, guys.
  • gfk65gfk65 Posts: 1
    NerveGear
    god bless you !
«1
Sign In or Register to comment.