New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Asus Z170-A motherboard incompatibility?

2»

Comments

  • iNeoTroniCiNeoTroniC Posts: 7
    NerveGear

    Asus Z87 Hero VI owner here. Had simliar problems, here's what fixed it on Win10:

    • Uninstall the ASUS USB Charger+ utility
    • Other AISuite components are still running on my System and causing NO issues
    • Disable compatibility Support module (CSM) in BIOS
    • Now the most important part i guess: Disable USB selective power saving in BOTH the balanced AND the high performance profile in windows energy options

    I've also tried the Inateck 4-port USB card, which will NOT work with the drivers from Inateck, ONLY with the default windows driver! (just ignore the warnings at Oculus Home...) The power saving issue stays the same with this card since it seems to be a generic windows problem (?).

    Performance seems to be better with the Z87 ports so I uninstalled the Inateck Card (default windows driver seems to have no UASP support, Inateck driver cause even more issues).

  • iNeoTroniCiNeoTroniC Posts: 7
    NerveGear

    Asus Z87 Hero VI owner here. Had simliar problems, here's what fixed it on Win10:

    • Uninstall the ASUS USB Charger+ utility
    • Other AISuite components are still running on my System and causing NO issues
    • Disable compatibility Support module (CSM) in BIOS
    • Now the most important part i guess: Disable USB selective power saving in BOTH the balanced AND the high performance profile in windows energy options

    I've also tried the Inateck 4-port USB card, which will NOT work with the drivers from Inateck, ONLY with the default windows driver! (just ignore the warnings at Oculus Home...) The power saving issue stays the same with this card since it seems to be a generic windows problem (?).

    Performance seems to be better with the Z87 ports so I uninstalled the Inateck Card (default windows driver seems to have no UASP support, Inateck driver cause even more issues).


    Problem remains, just seems to appear not that often...
  • spetkespetke Posts: 3
    NerveGear
    Yea I got the problem sorted by switching the mobo. Asus Z270F and the rift and even touch and the second sensor work fine with the integrated intel usb.
  • UnFknBLievableUnFknBLievable Posts: 83
    Hiro Protagonist
    I got a z170-AR and experienced the same problems of warping, loss of tracking and the occasional sound dropping off.

    I got the rift to play Assetto Corsa (race sim) so that is my basis of testing.

    i have recently discovered like yourself that I was running Bios 2208 with XMP enabled. Then a new bios update came out 3008? And my System will not boot with XMP enabled so disabling XMP was my only option. My rift during that time was working flawlessly and thought oculus or windows had updated and fixed my issue. A new bios revision came out and I updated last week.

    this fixed my XMP profile again but now my rift is unplayable!!!

    i will test the XMP theory and report back. Finally someone that has my issue!
  • UnFknBLievableUnFknBLievable Posts: 83
    Hiro Protagonist
    Ok so did some testing.
    CPU i7 6700K @ 4.6ghz
    Motherboard Asus Z170-AR Bios 3301
    Ram G-Skill 3000mhz DDR4
    Win 10.

    Now I've posted numerous times about my Rift skipping, loosing track, sound loss, ect and nothing helped with many attempts to fix it.

    So as my above post, I have done the following with testing in Assetto Corsa.
    Ram = 3000mhz
    XMP profile enabled
    Assetto and Oculus Home instability (unplayable)

    Ram = 3000mhz
    XMP profile disabled
    Assetto and Oculus Home instability (unplayable)

    Ram = 2144mhz (RAM underclocked from default)
    XMP profile disabled
    Assetto and Oculus Home = flawless.

    Re-enabled RAM to default 3000mhz (everything else set to Auto)
    XMP disabled
    Oculus and Assetto unstable.

    There is an issue between my Motherboard, RAM and USB.

    Can someone from Oculus investigate this issue with Asus?? I don't want to have to upgrade my motherboard to fix this and that's more money down the drain..

  • UnFknBLievableUnFknBLievable Posts: 83
    Hiro Protagonist
    I had a run with in War thunder, Iracing and Assetto Corsa with XMP ENABLED and RAM frequency set to 2133mhz and has been stable thus far.

  • chilipopperchilipopper Posts: 4
    NerveGear
    I've got the exact same problem. 

    my VR build: 
    6700k i7 @ 4.6ghz
    Asus z170-a
    Gskill Ripjaws 3200mhz DDR4
    Gtx 980 ti


    My overclock is rock solid, haven't had any problems in months until I had to sort out the tracking issues. 
    My USB 3.0 can handle the sensors perfectly only when my ddr4 runs under 2400mhz. sometimes, the sensors setup will indicate a tracking issue when I run the ram at 3200mhz but most of the time i'll lose tracking or will have small twitches without any notification from the app. 

    I updated the bios and mobo drivers prior to the installation so this shouldn't be the issue. 

    i'd rather spend my money on a 3rd sensor than a USB card add on to be honest, but it seems I kinda have no choice. that CAD 820$ price point was a bit steep considering every thing that can go wrong with the rift at the moment. I hope this issue gets resolved as it seems to have been around for quite a while without any acknowledgement from Oculus...
  • RobertsmaniaRobertsmania Posts: 18
    NerveGear
    I can confirm that my Oculus tracking issues with an Asus z170-AR motherboard running at anything but the stock memory speed were resolved by switching to a z270 motherboard.

    With the z170 I had no issues with any other applications/games running with the CPU and memory overclocked - but the Oculus tracking was terrible if the memory ran at anything above 2133Mhz.

    Transplanting everything into a z270 motherboard works fine and I can crank up the CPU and memory speeds while the tracking remains solid.

    I had this motherboard:
    https://www.asus.com/us/Motherboards/Z170-AR/

    This is the one I've switched to:
    https://www.asus.com/us/Motherboards/TUF-Z270-MARK-2/

    With all the other components the same (CPU, memory, Startech USB card, hard drive) in the new z270 all is well with my memory running up to its rated 3000Mhz.  With the z170 it would malfunction if I raised it above 2133Mhz.

    So for me, it appears that it is an issue with the z170 motherboard when it runs at anything but stock memory speed and not the other components/drivers/etc.  

    Here are the specifics for the system:
    CPU: i7-7700K
    Memory: Corsair - Dominator Platinum 16GB (2 x 8GB) DDR4-3000 CMD16GX4M2B3000C15
    GPU: EVGA GeForce GTX 1080 FTW, 08G-P4-6286-KR
    USB: Startech PCIe Quad USB 3.0 PEXUSB3S44V
    Hard Drive: Intel 600P PCIe 3.0 x4 NVMe M.2 SSD
  • WarbudtekWarbudtek Posts: 1
    NerveGear
    Hey everyone,
    I also have the Asus Z170 A motherboard and had endless errors with poor tracking quality and so on.
    Bought the inateck card which didnt help at all :/
    So what fixed it was actually setting the frequency of the RAM to 2133 mhz in my BIOS settings.
    Now it works super good :smile:
    thank you for all the advices here!
  • 0neclickheadsh0t0neclickheadsh0t Posts: 2
    NerveGear
    edited August 1

    I've got the ASUS z170-a overclock problem aswell - slow traction, sensors not tracking, devices not recognized and disconnecting, also this won't let the first time setup to finish. My RAM settings have to be in its default values for vr to work. I can overclock the cpu without touching the XMP. I will try changing the memory values manually later. 


    UPDATE!: IF YOU HAVE XMP ENABLED IN YOUR ASUS Z170-A BIOS THEN THIS IS THE SOLUTION WITH NO SACRIFICES TO YOUR CLOCK SPEEDS. 

    So it turns out that by default XMP overvolts ram and some settings need to be readjusted in the bios. 
    I got it working with the XMP enabled - I set DRAM voltage as low as I could without the pc crashing, I went down in 0.01 volt iterations until it didn't boot then stayed at last working iteration and started benchmarking in windows, if it crashed during loading windows or in the benchmarking application then I added 0.01 volts to DRAM and repeated it until I got it stable.(benchmarked with aida64 for 30min), then I set VCCIO and VCCSA both to 1.15volts(they are located below dram voltage in bios). Now I have perfect traction, a nice overclock and all the sensors light up as green in oculus application under devices. I have the latest 3802 bios version. Go to https://www.asus.com/Motherboards/Z170-A/HelpDesk_Download/ to download the latest update if you don't have it on your z170a and are experiencing the same problem. NO usb hubs etc needed, everything runs from the z170-a motherboard and IT WORKS FINE WITH OC AND XMP ENABLED!(My ram is at 3200mhz with xmp)

    In steps: 
    1. Leave XMP enabled, make sure you have a stable clock on the cpu. (I used adaptive mode for cpu vcore )
    2. Set your DRAM to as low as you can.
    3. Set BOTH VCCIO and VCCSA to 1.15 volts (you can experiment  between 1.10 - 1.25 volts when running into problems, start from the lowest )
    4. Hopefully PROFIT!
Sign In or Register to comment.