How to fix Gear VR not launching when phone is plugged in? — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How to fix Gear VR not launching when phone is plugged in?

MaiNaymMaiNaym Posts: 8
NerveGear
edited May 2016 in Samsung Gear VR
Hello fellow VR explorers  :smile: 

I have a question - one that has been asked (kind of), but rarely at that.
What happens to me, is that after I plug the phone in, OCCASIONALLY the Oculus connection sound will be heard.
Whether it does or doesn't, doesn't matter. It still only shows a black screen and a small white "x" in the left hand bottom corner.
When disconnecting the phone from the Gear VR, I get a brief "Calibrating Gear VR" message, and then the display returns to the home screen.

My Gear VR does not work on my phone (which is a Galaxy S6), but it seems to working flawlessly with a friends Galaxy Note.
So I can at least establish that the problem is within the phone. 

Solutions I've tried so far:

Soft reset the phone
Hard reset the phone
Update the phone to newest android build
Apply more pressure when plugging in the phone to the Gear
"Wiggling" the phone when plugging in
Installing custom roms / old android builds

Absolutely nothing is working and I've gone to EVERY phone repair shop to request assistance, but they all just didn't know either.

ANY HELP IS VERY, VERY, appreciated.

Best Answer

«13

Answers

  • MaiNaymMaiNaym Posts: 8
    NerveGear
    Quick update: Called Samsung support. They said (even after telling them my Gear VR headset worked on a Note 4 with no problems) that I need to visit a Best Buy, where they can test my Gear on other Samsung Galaxy phones themselves to establish that it is in fact, not on the headset's end.

    They gave me no more information as to what will be done to fix my issue.
  • FrozenPeaFrozenPea Posts: 2,535 Valuable Player
    Which version of the Gear VR do you have?

     I'm pretty sure the version you got that works with the Note 4 isn't the same as the version that works with the S6. They have a different gear vr because the Note 4 and S6 are different sizes.
  • MaiNaymMaiNaym Posts: 8
    NerveGear
    From what I was aware, there is the innovator and consumer. I have the cconsumer version. I am aware that the innovator is limited while the consumer is available for muliple Galaxy devices including Note 4 AND my Galaxy S6.

    Thanks for trying to help though!
  • MaiNaymMaiNaym Posts: 8
    NerveGear
    This is such a huge question very recently. Why is this not being solved?
    Anyway, I am listening to Samsung support and going to get my headset tested on even more devices at Best Buy. Posting results here.
  • JinnisaurusJinnisaurus Posts: 49
    Brain Burst
    edited May 2016
    MaiNaym said:
    This is such a huge question very recently. Why is this not being solved?
    Anyway, I am listening to Samsung support and going to get my headset tested on even more devices at Best Buy. Posting results here.
    Just a question. has ur phone on gear vr worked before?
  • chinoychinoy Posts: 8
    NerveGear
    people are mixing up the gear vr made only for the note 4 with the new gear vr made for the s6 and s7
  • MaiNaymMaiNaym Posts: 8
    NerveGear
    edited May 2016
    I can assure you, the Gear VR I previously had was the Consumer Edition. The Innovator Edition only worked on Note 4, as mine (the Consumer Edition) was supposed to work on Note 4 and Galaxy S6/S7. The problem was ithat simply didn't, and declared defective.
  • vovovovo Posts: 4
    My Consumer Edition Gear VR is now doing the same thing. I also noticed the white x on the corner and it moved from one corner to the other. I know the problem is not with the Gear VR as I have two of them and two S6s as well. The wife phone works fine with either Gear VR, mine doesn't work with neither.

    So it's either a software or hardware problem with my phone. Stock, no root. Tried uninstalling/reinstalling the Oculus software and noticed that a couple apps could not be uninstalled.

    I get two kinds of errors, and none of it is with the power cord attached. One error is the "calibrating Gear VR" screen. Which I noticed gets calibrated sometimes but just for a second and then freezes again. The other is the BSOD with the white x on the lower corners. One at a time. Tried pressing the x with no luck, maybe need a third hand and pen to do it.

    For a while I thought the Gyroscope on the phone was borked but I learned that the Gyro is in the headset. And the headset works fine with another phone. So maybe the "calibrating gear vr" is not the problem but something else is slowing the cpu so much that the message is just a consequence of the freeze, not a cause. I dunno.

    I have the two com.falsebook apps but I haven't done a hard reset as it doesn't seem to matter.

    My next move will be to back up my wife's app and install on mine. In the mean time, this is a problem that both Samsung and Oculus need to look into as my Gear VR was working fine until not too long ago. Consumer Edition!
  • vovovovo Posts: 4
    case not closed
  • vovovovo Posts: 4
    MaiNaym, please remove the "case closed" or I'll have to start another thread and explain that it's not the Innovator Edition again.
  • vovovovo Posts: 4
    OK. Did the file replacements and managed to get to the Oculus home. But then it froze there. Even the back button doesn't work. Is there an app that will show what is using the cpu like the task manager in windows?
  • My Gear VR has died after Marshmallow update on S6.
  • Anyone know a fix?
  • XboxiiXboxii Posts: 2
    NerveGear
    Hi, I have gotten the same issue lately. I have the Gear VR consumer version. I bought maybe 6 months ago and the S6 was working perfectly. I stopped playing with it about 3 months ago. Then recently when I tried to connect again it would not launch. Sometimes it goes black then goes back into the home screen of the phone, other times it goes into a black screen with an x and just stays there. 1 out of 10 the oculus home boots and I am in the menu but the buttons wont work. I want to add that somewhere around 1 month ago my USB stopped charging with the old usb charger it only charges now with the modern boost charger. Could be something with the usb connection?
  • ManchershawManchershaw Posts: 3
    NerveGear
    Same issue, same phone s6 edge+. App is up to date, worked previously. Haven't used in a few months, now get a momentary black screen with white x before app closes. Looks like this has been going unresolved. Considering the purchases in app I've made, best bet might be contacting the BBB if Occulus isn't addressing.
  • TraulqTraulq Posts: 6
    NerveGear
    Same problem, earlier today all was working just fine - now inserting the phone will not trigger VR mode. No apparent reason at all!
  • davidcarrolldevdavidcarrolldev Posts: 1
    NerveGear
    Check that the switch on the phone to the goggle connector is set to locked.

    I had an issue where the new VR goggles for the Note 7 was not automatically responding when the Note 7 was attached.

    The VR goggles had previously worked. Once noticing my switch was set to unlocked, I realized my issue. After changing this to locked, everything was working as expected.

    Hope this feedback applies to the other versions of VR goggles and phone models.
  • TraulqTraulq Posts: 6
    NerveGear
    Didn't help unfortunately. Plugging it in seems to trigger VR mode and then drop straight back to the Oculous menu :(
  • ManchershawManchershaw Posts: 3
    NerveGear
    No it does not
  • robertroyrobertroy Posts: 19
    NerveGear
    Looks like a lot of people are having the same issue w/ s7 and gear vr not connecting. Sounds like most everything has been tried with phone settings to no avail. I believe Oculus needs to contact Samsung and get us operational again. Come on guys!!!!!!!!! You owe it to us as customers. PLEASE with sugar on top.
  • FanackapantsFanackapants Posts: 4
    NerveGear
    I have been in contact with Oculus and Samsung and neither of them can offer any assistance with this problem.  Oculus are now suggesting that I take my 1 week old New Gear VR and 1 week old Galaxy S7 back  to my carrier to try another headset and phone...  I have almost a 2 hour return journey to have this sorted and I'm worried that this won't fix the situation anyway since there are so many others with the same issue.  The VR worked well on the first day and then not again since....  :'( 
  • robertroyrobertroy Posts: 19
    NerveGear
    Oculus Support contacted me and we did the following. Uninstalled in this order, gear vr service, updates gear setup wizard, gear vr video, oculus, oculus home and oculus system activities. The reinstalled the oculus app. Did nothing to phone settings!!!!! And it worked. The oculus tech. is Charles. He did good, it worked for me . Hope it does for you.
  • robertroyrobertroy Posts: 19
    NerveGear
    Support contacted me and we did the following. Uninstalled in this order, gear vr service, updates gear setup wizard, gear vr video, oculus, oculus home and oculus system activities. The reinstalled the oculus app. Did nothing to phone settings!!!!! And it worked. The oculus tech. is Charles. He did good, it worked for me . Hope it does for you.
  • FanackapantsFanackapants Posts: 4
    NerveGear
    edited November 2016
    robertroy said:
    Support contacted me and we did the following. Uninstalled in this order, gear vr service, updates gear setup wizard, gear vr video, oculus, oculus home and oculus system activities. The reinstalled the oculus app. Did nothing to phone settings!!!!! And it worked. The oculus tech. is Charles. He did good, it worked for me . Hope it does for you.
    George is helping me, gave me the same instructions which I've followed unfortunately to no avail... 
  • SergioOrtizSergioOrtiz Posts: 3
    NerveGear
    I juat had the same problem today. It was working fine and then i would plug in the phone , get the black screen for 3 seconds and then the regular screen of the phone-. What indid was open the occulus app in my phone. When i opened it, it asked for my login information agaon. I provoded the data lile i did the first time and then it worked again just fine. Its like somehow i was logged out. I hope this helps someone! I have the latest samsung vr headset and the phone is an S6.
  • johnbenvinjohnbenvin Posts: 1
    NerveGear
    Hello,

    Even i am facing the same problem can any one post the correct working solution?
  • murphey1965murphey1965 Posts: 9
    NerveGear
    Putting this issue down to the OTG port on the S6 ,had the same problem for over a week then with it plugged in the vr moved the s6 left to right enough not to remove it and it made the usual noise again and this time worked so defo not a software issue i think the mini usb port are just too weak and constant use with the vr basically wears them out and become a bit loose and do not make the required connection , all phones should be standard usb wouldnt have this issue then 
  • robertroyrobertroy Posts: 19
    NerveGear
    I think you've hit the nail on the head. Common sense and a little jiggle on the connection will probably work for everyone . Thinking too hard on the problem . Peace, Love, Dove :)
  • ThenextlevelThenextlevel Posts: 1
    NerveGear
    My Gear VR stopped working when I plug in my phone, I heard the sound it connected but nothing working, I reinstalled the oculus software still nothing, restart S7 phone nothing work until I decided to remove the connector on the Gear VR and put it back then all worked fine..... that was strange however it worked for me!
Sign In or Register to comment.