New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Head Tracking Freeze, Drift

failingbetterfailingbetter Posts: 7
NerveGear
edited July 2016 in Support
I received my Rift on Friday. Worked fine Friday and Saturday. This morning the head tracking would pause and snap back after a second while playing Technolust. Now it happens during all Rift apps and games, including Home and the setup tool. I tried updating my USB drivers but the problem persists. Occasionally it will freeze for several seconds and continue from the current head location, causing a nauseating tilt that slowly creeps back to level over several more seconds. This occurs when I am sitting 2 feet from the sensor and facing forward.

Any ideas? Anyone else having severe tracking issues?

i5-6600K
16GB DDR4 RAM
ASUS ROG MAXIMUS VIII GENE z170 mATX motherboard
PNY GTX970

Comments

  • failingbetterfailingbetter Posts: 7
    NerveGear
    No responses so maybe this is uncommon. In case someone suffers the same issue, this is how I (hopefully) fixed it.

    Unplug all USB devices (except mouse and keyboard). Restart computer. Run the Rift setup. Plug each USB cable back in one at a time.

    I have no idea what went wrong, if it has to do with specific USB ports (I reorganized my devices during the process), if my updated drivers took a couple of restarts to sort themselves out, or just coincidence. Anyway, works great now.
  • failingbetterfailingbetter Posts: 7
    NerveGear
    This is happening again. Every 30 seconds or so the head tracking will freeze for a second or two and then either snap or drift back into position. It's the worst. Any ideas?
  • konstantin_lozevkonstantin_lozev Posts: 184
    Hiro Protagonist
    Do you have f.lux running?
  • failingbetterfailingbetter Posts: 7
    NerveGear
    No, I do not. I've tried ending all non-essential tasks and it doesn't help. 
  • failingbetterfailingbetter Posts: 7
    NerveGear
    I wish Oculus had a utility to check performance. I'd love to see where the issue is coming from: HDMI, USB, GPU, etc. 

    My best guess is USB, since I was also having problems with my Xbox One controller periodically unpairing with the wireless adapter. But installing the Windows drivers seemed to fix the controller issue but not the Rift.
  • FrozenPeaFrozenPea Posts: 2,535 Valuable Player
    Do your USB3 ports pass the compatability test?

    Also have you checked your rift cable is plugged in properly? Remove the foam face plate and take it out and put it back in :)
  • failingbetterfailingbetter Posts: 7
    NerveGear
    USB 3.0 ports pass the test. Tried reseating all cables on the PC and the headset. No change.
Sign In or Register to comment.