Oculus Rift disables regular speakers — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Rift disables regular speakers

steampvnc1BB0steampvnc1BB0 Posts: 6
NerveGear
edited May 2016 in Support
When I first installed Oculus home to set up the Rift on my windows 10 machine it set Headphones Rift Audio as my default sound playback device on the control panel. This prevented any sound at all from coming out of the speakers I have on my desk. I found I could restore the use of my desktop speakers by setting "Speakers" as my default sound playback device and when running VR games audio comes only out of the Rift headphones as it should be but I have experienced a few problems with audio in various programs. Most significantly in Virtual Desktop all sound comes out of the speakers on my desk instantly and out of the Rift headphones four seconds later. Switching the default sound playback device to the Rift Headphones gets rid of the lag but, again, disables the speakers on my desk for all purposes both in and out of VR.

When you set up your rift how did it interact with your sound settings in windows 10? Was it selected as default? Did you have to change it? Has anyone else had any problems getting sound to come out of their regular speakers when they installed Oculus Home?

Comments

  • aiaustinaiaustin Posts: 80
    Hiro Protagonist
    edited May 2016

    This is definitely a problem for those using speakers and/or other headsets (e.g. USB) on their setup and wanting more control over which is selected for whichever app or program you are using.  Like myself, you may frequently switch between apps, and especially may be using several apps while developing and testing (e.g. in Unity3D), and may have others apps, and even communication programs like Skype, open at the same time.

    To control this without having to use a multiple step process in the Windows audio control panel (or system tray equivalent) and to let me rapidly switch from one output device to another I have installed the free Audio Switcher by Sean Chapman @xenolightning

    http://audioswit.ch/er


  • nalex66nalex66 Posts: 4,380 Valuable Player
    The Oculus software should be diverting only the audio from VR apps to the Rift. Mine never changed the default Windows audio device. It doesn't even switch it while I'm playing a VR game.

    I just did an experiment--I had iTunes playing music over my speakers, and I fired up a game from Oculus Home. The music kept playing over the speakers, while the audio from the game played over the Rift headphones.

    The only time I have to mess with the Windows audio settings is when I'm playing a VR game that isn't launched from Oculus Home (i.e. a Steam game that has Rift support built in). Sometimes there's no audio over the Rift headphones, or it comes out of both the headphones and my speakers. In that case, I switch the default audio device to the Rift headphones, and switch it back when I'm done.

    You can right-click on the Sound icon in the desktop tray to quickly get to the Playback Devices dialogue.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • Jokergod2000Jokergod2000 Posts: 300
    Nexus 6
    There are settings in the Oculus home software too. You can change home to either use the Rift or the Default Windows device. You can make all Oculus home play over your speakers if you want. It's under settings, devices, VR Audio Output/Input pull downs. Not sure if this helps?
  • steampvnc1BB0steampvnc1BB0 Posts: 6
    NerveGear
    VR audio output is set up to rift headphones in settings... Thank you all for your help. I'm gonna swap playback devices when using virtual desktop. It's a relatively painless thing to do.
  • gacoplgacopl Posts: 6
    NerveGear
    what should happen is when you strap on oculus all sound should be routed to rift and when you take it off all shoulbe routed through default device, steamVR can do this with vive.....
  • gacoplgacopl Posts: 6
    NerveGear
    or even better when you take off goggles (or close oculus home) it should disable rift headphones device, and enable them when you put them on, this would be the best non invasive solution
  • TwoHedWlfTwoHedWlf Posts: 2,233 Valuable Player
    gacopl said:
    what should happen is when you strap on oculus all sound should be routed to rift and when you take it off all shoulbe routed through default device, steamVR can do this with vive.....
    That seems to be exactly what the Rift does.
  • nalex66nalex66 Posts: 4,380 Valuable Player
    TwoHedWlf said:
    gacopl said:
    what should happen is when you strap on oculus all sound should be routed to rift and when you take it off all shoulbe routed through default device, steamVR can do this with vive.....
    That seems to be exactly what the Rift does.
    Even better than that, it routes the audio from Oculus apps (not all sound) through the Rift when it is active. It doesn't actually mess with the Windows default playback device at all. As I mentioned earlier in the thread (back in May), I can be playing other audio through Windows over my PC speakers, and that audio stream will be undisturbed while the audio from my VR games will properly play through the Rift headphones.

    A few users have reported problems with this not working as intended. I haven't read of anyone figuring out why that is happening for them or how they might fix it.
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • appl044appl044 Posts: 12
    NerveGear
    This thread was helpful!
Sign In or Register to comment.