Sensor USB not detected - Page 2 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Sensor USB not detected

2»

Comments

  • DARKKiDARKKi Posts: 23
    Brain Burst
    I got all of it working finally after restarts and trying different usb ports :)
    ..:: DARKKi / NZTi! ::..
    Ninja Zero - Prototype v0.4b "ssdd"
  • qalootqaloot Posts: 1
    NerveGear
    edited May 2017
    I fixed this by uninstalling the GeForce Experience and Oculus Rift software, then installing only the GeForce graphics driver (custom install -> check driver + physx only --- no hd audio, no 3d vision, and no geforce experience).  After that I reinstalled the Oculus software and it detected the sensor.  I have an MSI laptop with a GeForce 980m card in it.

    Before doing this, the sensor would appear as "unknown device" in windows device manager.

    Like this post if it helps you :smiley:
  • iguanaking2010iguanaking2010 Posts: 1
    NerveGear
    I put the sensor plug into the cable that came with the Xbox controler, after doing so I've had no problems.
    That worked for me!  Very strange...makes no sense...but my sensor is now happy being connected to my USB 3.0 self-powered hub.  It was always fine with the ports on the machine, but through the hub it just wasn't recognized.  I tried your suggestion through the Xbox controller extender cable, and it works...every time!  THANK YOU! 
  • backflipbedlembackflipbedlem Posts: 2
    NerveGear
    FIXED
    k, so again had lots of issues tried every usb combo.
    Worth saying I had a DK2 which I uninstalled before installing the CV1.
    In end what worked for me was opening device manager going to the oculus and instead of trying to update the drivers, I uninstalled the sensor and clicked to delete the driver.
    I then pulled out the usb and then put it back in. Then under the device manager it showed up as CV1 External camera with a warning sign.
    I then opened up C:\Program Files\Oculus\Support\oculus-drivers in explorer, and ran the oculus-driver.exe and then voila in device manager it switched to being a Rift Sensor, and in Oculus setup it was now detected.
    I guess some old drivers were still lurking around.
    Hope that helps.
  • nichequichenichequiche Posts: 1
    NerveGear
    47thTime said:
    I had this same problem last week, it's fixed now.
    I got my CV1 headset about 4 months and everything was working great.  Then along came a Windows update and suddenly my system would not detect the sensor.  The other devices connected to the USB hub worked just fine. I tried a lot of different things, even connecting to a 2.0 port, rebooted about 30 times, all to no avail.
    My fix, I hope it works for you too.  From the device manager, Update the driver for the Rift Sensor, but not by using Windows to search for the latest driver. Instead, use the "browse my computer...", navigate to the Oculus folder/ sub folder to find the Rift Sensor driver.  Once I did that it all worked again.
    Also, from the Device Manager, go into the properties popup for all your USB root Hubs, and de-select "Allow the computer to turn off this device to save power" located under the Power Management tab.
    Good Luck.
    Bloody genius! Never would have thought to manually update the drivers. Worked a charm. Come on oculus, fix your automatic driver updates!
  • drvrdrvr Posts: 2
    NerveGear
    47thTime said:
    I had this same problem last week, it's fixed now.
    I got my CV1 headset about 4 months and everything was working great.  Then along came a Windows update and suddenly my system would not detect the sensor.  The other devices connected to the USB hub worked just fine. I tried a lot of different things, even connecting to a 2.0 port, rebooted about 30 times, all to no avail.
    My fix, I hope it works for you too.  From the device manager, Update the driver for the Rift Sensor, but not by using Windows to search for the latest driver. Instead, use the "browse my computer...", navigate to the Oculus folder/ sub folder to find the Rift Sensor driver.  Once I did that it all worked again.
    Also, from the Device Manager, go into the properties popup for all your USB root Hubs, and de-select "Allow the computer to turn off this device to save power" located under the Power Management tab.
    Good Luck.
    This did the trick for me as well.

    The exact path to the drivers is C:\Program Files\Oculus VR Runtime Drivers\Drivers\Rift Sensor
  • Batou_mattBatou_matt Posts: 1
    NerveGear
    I had this problem today after installing the inateck 5 port usb 3.0 hub and simply running the oculus-driver.exe solved the issue of sensors not being detected. I didn't need to uninstall any drivers for the sensors. The sensors where showing up in device manager under 'other devices > CV1 Sensor' with an exclamation icon next to them. After running oculus-driver.exe the then showed up in device manager under 'Oculus VR Devices > Rift Sensor' with 2 'Rift Sensor' devices showing up (I'm only using 2 sensors).

    The current path for oculus-driver.exe (after installing the oculus software) on Windows 10 Pro (build 16299) is:
    'C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe'

    I hope this helps people as you really want to be using usb 3.0 hubs for best tracking and it's a super simple fix, assuming your issue was the same as mine.
  • sonofbrycesonofbryce Posts: 17
    NerveGear
    I'm running Windows 10. Sometime in Summer both sensors stopped working in unison. Sometimes I could get them both to work at the same time by playing the "hotswapping USB port" game and hopefully both light up. One seems to work no matter which port and the other is finicky.

    Anyway, tried messing with the drivers as people suggested and running "oculus-driver.exe" didn't seem to do anything, and the drivers showed no errors when I could get both sensors to popups in Device Manager.

    What worked was connecting the finicky sensor with that Xbox extension cord that I forgot existed. Thanks for the tip! Saved such a huge headache dealing with this VR nightmare.
  • owenevans00owenevans00 Posts: 1
    NerveGear
    Confirming that running oculus-driver as above works, in the case where the cameras show as CV1 Sensor and are marked as having errors. If you don't see that, there's a good chance the problem is your wiring.
  • mynameisjohnjmynameisjohnj Posts: 2
    NerveGear
    edited April 2018
    I had this problem today and running the oculus-driver didn't help. I had to run Support\oculus-diagnostics\OculusVRCValidator.exe and then device manager picked up the devices. This is on a USB 3.0 hub, but I tried every possible combination of ports before running the validator. After doing that everything is fine, I just tried my first game out and things were smooth. 

    Oculus - the fact that there's no official response on this and that it doesn't work out of the box makes me think you are a joke of a company. Get it together. 
  • GabrielKzGabrielKz Posts: 1
    NerveGear
    This worked for me: Opened the directory C:\Program Files\Oculus\Support\oculus-drivers, and manually installed the file oculus-driver. The device manager updated to show the sensors, and everything moved forward!

  • SunpuddleSunpuddle Posts: 1
    NerveGear
    Easy fix is to just restart your computer while the Oculus software is still up. After my restart, it prompted me to install an update. Viola, works now.
  • Slayer_FilSlayer_Fil Posts: 2
    NerveGear
    I had same problem.  Headset worked fine in all USB 3 ports, no sensor detected in any of them. I restarted my PC (Win 10 64b) and Oculus detected that it needed to update, I let it update and now everything is detected!  The old... "Try turning it off and back on"
  • Benny_GoodmanBenny_Goodman Posts: 1
    NerveGear
    (fixed!)
    I had the problem that my Sensors wont accept that they are plugged in in USB3.0 plugs.
    I first tried to upgrade the driver via the device manager but this didnt help.
    What you gotta do is to go on the path:
    C:/Programms/Oculus/Support/Oculus-drivers   (more info in the link below)
    and run the exe file "oculus-driver"

    I did this, at first seemingly nothing happened (no window  popped up) but when i restarted the oculus softwere it detected my sensors without any problems.
    I saw alot of people with this problem and didnt find a solution at first, what was quite frustrating, but i hope this helps





Sign In or Register to comment.