"Rift Headphones" Audio Device Missing — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

"Rift Headphones" Audio Device Missing

lord_omegalord_omega Posts: 9
NerveGear
My Oculus Home sound is coming out of my speakers instead of the Rift headset. The Home 'VR Audio Output' is set to "Rift headphones".
The Rift Headphones device is missing from Playback devices in Windows.

I tried re-running the Rift device setup. Now it won't get past the sensor setup part - it just keeps saying "Check Your Setup". I am already 2-5 feet from the sensor with it tilted up toward my face.

Any ideas?

Comments

  • lord_omegalord_omega Posts: 9
    NerveGear
    edited June 2016
    Ok I got the sensor setup again (on my 12th try, I had to sit right infront instead of standing this time). Audio is still coming out of the wrong speakers though...
  • lord_omegalord_omega Posts: 9
    NerveGear
    Under Windows 10 Device Manager>Audio inputs and outputs; "Microphone (Rift Audio)" is showing, but not headphones. Scanning for hardware changes doesn't help.

  • lord_omegalord_omega Posts: 9
    NerveGear
    I fixed it by running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe

  • nikoshaknikoshak Posts: 2
    NerveGear
    Thanks lord_omega. I've had the same persistent problem, especially after every mandatory driver update Oculus has put out. Your suggestion seems to be fixing my situation consistently.
  • lepterlepter Posts: 62
    Hiro Protagonist
    I fixed it by running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe

    I would if the execution file was present in the folder but it isn't there. Disabling the headphone shouldn't remove it from the system. Having to do a full reinstall to see if that will re find the hardware. 
  • lepterlepter Posts: 62
    Hiro Protagonist
    lepter said:
    I fixed it by running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe

    I would if the execution file was present in the folder but it isn't there. Disabling the headphone shouldn't remove it from the system. Having to do a full reinstall to see if that will re find the hardware. 
    Well.....that didn't work so I bit the bullet and did a install of windows 10 thar I was putting off till the summer. All issues sorted. Don't know if it was a quirk of windows 7. 
  • starpilot149starpilot149 Posts: 9
    NerveGear
    I fixed it by running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe


    Thanks man. I've had this problem for a few weeks and that worked for me!
  • MAC_MAN86MAC_MAN86 Posts: 2,107
    Wintermute


    Here's a cool ICON for the Rift.
  • fariazzfariazz Posts: 79 Oculus Start Member
    I'm experiencing this same issue but manually running "oculus-driver.exe" didn't help. Have people found any other solution?
    Virtual Reality Mini-Degree - Learn to code in Unity and build 15 VR games and experiences
  • akteacherjeffakteacherjeff Posts: 1
    NerveGear
    I fixed it by running C:\Program Files\Oculus\Support\oculus-drivers\oculus-driver.exe

    Worked for me too. Thanks. I had just got done running a bunch of MSI updates and then it was screwed. Back to iRacing I go!
Sign In or Register to comment.