New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Win 10 driver error in control panel.

ChazmeisterChazmeister Posts: 256
Nexus 6
Hi, I'm getting a driver error in my Win 10 control panel for the Rift CV1.

In the hardware properties window there is an error for the Generic SuperSpeed USB Hub and the device status is shown as: This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

The request is not supported.

Is there anything I can do to sort this out?

I can't say when this error has first occurred as I've only just noticed it, but it wasn't there from the start when I first installed my Rift, so I'd say it has only been recent.

I also have an issue with my rear tracking LED's no longer working, which I already have a support ticket for, but this has happened since then.

Apart from the rear tracking problem the Rift seems to still work OK though.
«1

Comments

  • al_kovalal_koval Posts: 1
    NerveGear
    Try to disable Power Management for this device. Did the trick for me.
    If Power Management tab is unavailable - try to reconnect USB cord again.


  • I'm having the same problem, but I don't have a Power Management tab:


    Anything else I can do?

  • AndyW1384AndyW1384 Posts: 307
    Trinity
    edited September 2016
    Dengar said:
    I'm having the same problem, but I don't have a Power Management tab:


    Anything else I can do?

    The only workaround I've found (Asus Z97-K motherboard) is;
    1. Restart the PC often works.
    2. Otherwise, uninstall the Generic SuperSpeed USB Hub in device manager, then restart. The Hub always comes back and (so far) always with no error.
    I'm almost certain this is a timing issue at the hardware/driver level between the USB controller and the Rift, and probably a nightmare for Oculus to reproduce and fix.

    Of course, my problem might not be the same cause or workaround as your problem :(.

    [edit]
    Of course, my workaround is more fiddly than just unplugging and re-plugging the headset USB, but at least it avoids physically wearing out or damaging the USB plug/socket. Might wear out the rest of the PC though :smiley:
  • cyberealitycybereality Posts: 23,033 Oculus Staff
    Try installing the drivers for the USB controller. These will typically come from your motherboard vendor.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • AndyW1384AndyW1384 Posts: 307
    Trinity
    Try installing the drivers for the USB controller. These will typically come from your motherboard vendor.
    Doesn't fix it for me, sadly.
  • SlvWolfSlvWolf Posts: 2
    NerveGear
    I managed to solve this issue by reverting Windows 10 to older state. After last (forced) Windows update the XBox controller was not working at all and was seeing the same Generic SuperSpeed USB Hub issue. 
  • AndyW1384AndyW1384 Posts: 307
    Trinity
    For me, the hub issue predates Anniversary update. Neither default Windows Intel chipset drivers nor Asus chipset drivers have any effect. Anniversary update hasn't made it worse.

    Very not the same for all users :)
  • maxpare79maxpare79 Posts: 1,749 Volunteer Moderator
    I just realized I have the same error...been trying all sort of things for a few days now...same wasn't there before the anniversary update
    I am a spacesim/flightsim/racesim enthusiast first :-) I7 4770k@4.3, 16gb RAM/ Asus 1080 Strix Former DK2 Owner/Gear VR owner/CV1
  • clemencaclemenca Posts: 13
    NerveGear
    Same problem here, usb worked until yesterday, no changes made on the system (w10 prof anniv.), now i have this error to
  • WebMaximusWebMaximus Posts: 43
    Brain Burst
    And here's another one with the same issue.

    I've been in contact with Oculus support sending them logs etc but so far they haven't been able to find the culprit or even less address the issue. Also the issue will probably not get very high prio since it doesn't affect the performance of the Oculus hardware, at least not in my case.

    My own guess would be it's a timing issue of some kind since it doesn't happen all the time but only randomly which seems to be the case for a number of people.

    Anyone in here made any progress or even found a solution?
  • acb5544acb5544 Posts: 10
    NerveGear
    Seeing same thing here.  Asus Z170-A mobo.  Everything seems to work alright, but windows device manager shows code 31.
  • No1StatisticanNo1Statistican Posts: 1
    NerveGear
    I am having the exact same problem, has anyone found a solution?
  • philippebackphilippeback Posts: 1
    NerveGear
    Same issue on a Win8.1 Pro. Has the unfortunate side effect or restarting the PC with a CRITICAL_STRUCTURE_CORRUPTION blue screen of death when doing work under VMWare Workstation :-(
  • andrea_lioceandrea_lioce Posts: 1
    NerveGear
    edited January 28
    I've fixed by changing USB ports. I've plugged the rift on the usb 3.0 from the MB back panel and the sensors on the USB 3.0 ports coming from a 19 pin cable attached to a USB 3.0 internal header. Before that the rift and the sensors were inverted and I had the error 31, now the error seems solved.

    Update: not fixed, the error appears randomly anyhow, the only way to solve is unplug then plug again
  • iNeoTroniCiNeoTroniC Posts: 6
    NerveGear

    Same issue here, thought I got it fixed by changing power savings settings but I were unlucky. Sensors and HMD plugged into Z87 USB 3 ports. Seems to appear after the Rift has been used and the PC is started on next day. Then there is a lets say 30% chance of getting the windows prompt saying a USB device isn't working properly and a yellow mark with code 31 in device Manager. Simply restarting windows mostly solves that issue for the next session...

    Changing power management in every way, using differnet ports and even different PCIe controllers have no effect, the problem always remains.

    To me it seems that this is some kind of a timing issue when windows boots, too.

  • flexy123flexy123 Posts: 724 Poster of the Week
    edited February 11
    This is strange since Z87 boards, at least my ASUS, are really stable and I don't have any USB3.0 problems with it, neither on the ASMEDIA nor on the Intel ports. When Windows cannot even initialize a device on the USB ports and/or yellow exclamation marks..this is a more serious issue than a mere timing problem. (Whereas there DO indeed timing problems exist but IMHO they are more related to the Oculus software, such as that one out of 10 times or so Oculus sees the HMD as 2.0 and not as 3.0 or something when starting, but NOT related to anything in device manager).

    In my case when I get "device not recognized" from Windows or yellow exclamation mark in device manager, it's from a "flaky" connection (cable, plugs etc.) from devices...like I have an e-cig connected to my USB with a lose connector that sometimes shows this. So it CAN be a mechanical problem w/ your wires, plugs or ports even. (Dust in the USB ports...all kinds of possible scenarios)

    Anyway, if you cannot get USB devices properly detected and installed in device manager, I recommend you UNINSTALL the USB devices from Win device manager completely, including driver files. You can also get a tool called USBDEVView and de-install your USB devices with it. It's important that you really wipe whatever old drivers are there since there seems to be a conflict somewhere.

    Cold-start your PC and then have it find/install drivers for your USB ports/hubs.

    And then re-install oculus exactly and step-by-step following their instuctions. (I don't remember whether I actually first installed the software and THEN plugged the stuff in or whether I plugged the stuff in and THEN installed...anyway I did it exactly as in the instructions...and there SHOULD not be any problems really).

    Edit: This shouldn't have ANYTHING to do with power management really...
  • GloozyGloozy Posts: 4
    NerveGear
    I had the same problem with my Z87plus.
    I've changed some seetings in the BIOS that solve my problem.

    In the BIOS :

    To Advanced tab, then USB config.
    - Set Legacy USB to disable
    - Set Intel xHCI mode to disable
    - Set EHCI Handoff to disable

    To Boot tab :
    - Set Fastboot to disable
    - Set Hardwarefastboot to disable

    I've only 2 sensors. 1 is plugged on the top back USB panel and 1 on back USB panel at bottom (blue one)
    The rift in plugged on the top back USB panel.

    Hope it's gonna work for you.

    PC Specs: i7-4770k @ 4,5 Ghz (OC), 16 Gb DDR3 2400 Mhz, MSI  GTX 1080 Gaming X 8 gb, SSD Samsung 850 PRO 250 Gb,  SSD Samsung, 850 EVO 500 Go, 650 W Certified PSU, Acer 27" monitor, Xbox360 Controller, Windows 10 64bit.
  • iNeoTroniCiNeoTroniC Posts: 6
    NerveGear
    Gloozy said:
    I had the same problem with my Z87plus.
    I've changed some seetings in the BIOS that solve my problem.

    In the BIOS :

    To Advanced tab, then USB config.
    - Set Legacy USB to disable
    - Set Intel xHCI mode to disable
    - Set EHCI Handoff to disable

    To Boot tab :
    - Set Fastboot to disable
    - Set Hardwarefastboot to disable

    I've only 2 sensors. 1 is plugged on the top back USB panel and 1 on back USB panel at bottom (blue one)
    The rift in plugged on the top back USB panel.

    Hope it's gonna work for you.


    So you just have disabled USB 3 (xHCI) entirely, so all your USB ports are USB2s... Thats not that good...
    v1.11 seems to have solved that problem for me, at least til now...

  • HARE333HARE333 Posts: 12
    NerveGear
    w10 PRO/64 
    ver 1.14
    X99 board

    I now have same above mentioned error.
    uninstall reboot, no go

    rift devices says headset is usb 2.0
  • WebMaximusWebMaximus Posts: 43
    Brain Burst
    Try changing the startup mode for the Oculus service to Automatic (Delayed Start).

    Doing this fixed the problem for me and this again clearly suggests a timing issue as I said before.

    Haven't tested yet if anything changed with the latest drivers that was released the other day. Maybe they finally fixed the problem now meaning this work-around no longer is required.
  • e_m_d88e_m_d88 Posts: 371
    Trinity
    I get the same error as well.  The common link to this is the inateck pcie usb 3 card. 
    ASUS Sabertooth Z170 S, i5 6600K. 16 gigs ram DDR-4 3000 MHZ. SSD Samsung 850 Pro 256 gigs. WD Caviar Black 1 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU 1440p@144 hz, Phanteks Enthoo Pro case. EVGA Supernova 750 G2 PSU. Inatech 4 port USB 3.0.  Rift + Touch.
  • WebMaximusWebMaximus Posts: 43
    Brain Burst
    e_m_d88 said:
    I get the same error as well.  The common link to this is the inateck pcie usb 3 card. 
    Isn't that the card recommended by Oculus to avoid USB issues?
  • e_m_d88e_m_d88 Posts: 371
    Trinity
    e_m_d88 said:
    I get the same error as well.  The common link to this is the inateck pcie usb 3 card. 
    Isn't that the card recommended by Oculus to avoid USB issues?



    Yes.  But the common denominator is that card.  It definitely something going on with the drivers.  Everyone that is getting that error as well as myself is using the inateck card.  Can't be a coincidence. 
    ASUS Sabertooth Z170 S, i5 6600K. 16 gigs ram DDR-4 3000 MHZ. SSD Samsung 850 Pro 256 gigs. WD Caviar Black 1 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU 1440p@144 hz, Phanteks Enthoo Pro case. EVGA Supernova 750 G2 PSU. Inatech 4 port USB 3.0.  Rift + Touch.
  • flexy123flexy123 Posts: 724 Poster of the Week
    I just wanted to say, you should NOT disable xHCI.
  • AndyW1384AndyW1384 Posts: 307
    Trinity
    e_m_d88 said:
    I get the same error as well.  The common link to this is the inateck pcie usb 3 card. 
    Nope. I've been intermittently getting the error for a long time (my posts above September '16), and I'm just using the motherboard (Z97-K) USB.

    I'm not saying that it isn't being largely seen by USB 3 card users, but it isn't exclusively.
  • e_m_d88e_m_d88 Posts: 371
    Trinity
    edited April 23
    So is it some kind of device timing issue with the Rift and USB drivers causing this I wonder?  And my next question is.  Has this been a problem for people that don't have touch controllers? 
    ASUS Sabertooth Z170 S, i5 6600K. 16 gigs ram DDR-4 3000 MHZ. SSD Samsung 850 Pro 256 gigs. WD Caviar Black 1 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU 1440p@144 hz, Phanteks Enthoo Pro case. EVGA Supernova 750 G2 PSU. Inatech 4 port USB 3.0.  Rift + Touch.
  • AndyW1384AndyW1384 Posts: 307
    Trinity
    e_m_d88 said:
    So it's it some kind of timing issue with the Rift and USB drivers causing this I wonder?  And my next question is.  Has this been a problem for people that don't have touch controllers? 
    For me it preceded getting Touch. However, it wouldn't surprise me if adding USB devices could change the timings and increase the number of people seeing the issue.
  • e_m_d88e_m_d88 Posts: 371
    Trinity
    AndyW1384 said:
    e_m_d88 said:
    So it's it some kind of timing issue with the Rift and USB drivers causing this I wonder?  And my next question is.  Has this been a problem for people that don't have touch controllers? 
    For me it preceded getting Touch. However, it wouldn't surprise me if adding USB devices could change the timings and increase the number of people seeing the issue.


    So I wonder if it is Oculus related for the root cause of it then. 
    ASUS Sabertooth Z170 S, i5 6600K. 16 gigs ram DDR-4 3000 MHZ. SSD Samsung 850 Pro 256 gigs. WD Caviar Black 1 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU 1440p@144 hz, Phanteks Enthoo Pro case. EVGA Supernova 750 G2 PSU. Inatech 4 port USB 3.0.  Rift + Touch.
  • WagnardWagnard Posts: 4
    NerveGear
    Having the same problem.... The rift seems to work tho.
    Anything planned o fix this?
  • ChazmeisterChazmeister Posts: 256
    Nexus 6
    I wouldn't worry about it. It seems to come and go with various updates. It's not caused me any issues that I'm aware of though. I still have it even now.
«1
Sign In or Register to comment.