New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Win 10 driver error in control panel.



  • SkScotcheggSkScotchegg Posts: 1,330
    Project 2501
    Just found this thread when searching on google, I get the same error message sometimes in windows too. I'm wondering if it's because we have so many things using USB at same time. Especially since getting Rift and Touch. I have about 10 USB slots on my motherboard and case and all 10 are in use. Perhaps motherboard manufacturers need to make their USB technology more stable in future.

    Everything seems to work fine though, no issues with the PC or my Oculus Rift.
    UK: England - Leeds - - RTX 2080 - Rift CV1 & Rift S - Make love, not war - See you in the Oasis!
  • ChazmeisterChazmeister Posts: 540
    At the moment I'm back on my single sensor setup and still have the error, so I don't think it's that.
  • WebMaximusWebMaximus Posts: 43
    Brain Burst
    I don't have this problem anymore in the latest version of the Oculus software but I worked around it in the past by setting the Oculus service startup mode to automatic with delayed start so you might want to try that. 
  • AndyW1384AndyW1384 Posts: 307
    I don't have this problem anymore in the latest version of the Oculus software but I worked around it in the past by setting the Oculus service startup mode to automatic with delayed start so you might want to try that. 
    It may help, but it's not a guarantee. It made no difference for me, the error continued to crop up erratically and intermittently just as before.
  • WebMaximusWebMaximus Posts: 43
    Brain Burst
    Sorry to hear that.

    Let's hope Oculus will eventually be able to sort this permanently. 
  • CaptainInfamousCaptainInfamous Posts: 58
    Hiro Protagonist
    Is this hardware ID for a USB hub in the HMD or something?  


    That's what my generic superspeed usb hub driver error says its hardware ID is... I have 3 others in my usb device list just like it.  The difference is that the other 3 are all made by Genesys Logic, are the only 3 usb hubs like this i expected to see on my motherboard, and none of them have a VID of 2833, they're all USB\VID_05E3&PID_0616&REV_2221.  

    Seems that either Oculus got into the USB Hub business (since their USB VID is 2833), or some wires were crossed at Microsoft that has caused the wrong driver to be installed and that's why it's constantly throwing up errors, because the driver isn't correct.


  • Ernimus_PrimeErnimus_Prime Posts: 393
    Is it an inateck card by chance? 
    ASUS TUF GAMING X570-PLUS (WI-FI), Ryzen 7 3700x, 16 gigs ram DDR-4 3600 MHZ. SSD XPG 8200 pro 1 TB. WD Black 4 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU [email protected] hz, Phanteks Enthoo Pro case. Corsair rm750x PSU. Rift S.
  • tykotyko Posts: 2
    edited July 2017
    i ran into this problem for a while , no problems using the rift though . but its very annoying that when u starting windows u got that popup thats usb devices not working blablabla.

    Try disabling thing in the bios didnt made the error going away.

    So i dived back into resolving this code 31  issue and for me  changing the powermanagement on all usb controllers (disabling "Allow the computer to turn off this device to save power")  did the trick.
    just like dengar i couldnt change that setting on the "problem device" due to the error.
    But Like i said disabling that on the other controllers did work for me .

    BTW .
    specs are an MSI z87i motherboard  in nightblade barebone with i7 4790k
    using the onboard USB ports (NO usb pci e card in use)  
    GTX 1080  16 GB ram (has nothing to do with it i think ) 

  • Blugamer44Blugamer44 Posts: 1
    I've been getting similar errors as well. First I was getting (in Device Manager):

    Unknown USB Device (Device Descriptor Request Failed)
    Unknown USB Device (Port Reset failed)
    Unknown USB Device (Link in Compliance Mode)
    and now
    Generic SuperSpeed USB Hub with the Yellow Triangle and a device status of:

    This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

    The request is not supported.

    My Rift headset was usually plugged into 1 of 2 of my Front USB 3.0 ports, but Oculus was saying it was plugged into a 2.0 port. I then tried plugging the headset into a 3.0 port in the back, thinking there might be an issue with the Front USB ports, and for a couple minutes it showed up as 3.0 in Oculus, but then went back to being 2.0 after a Windows 10 USB failure notification popped up.

    I've forced my Power Profile to High Performance via. Local Policy due to Oculus and Explorer fighting and switching back and forth between High Performance and Balanced. I've also disabled Power Saving on all the USB devices/hubs.

    Rift still seems to function normally, but wondering if the Rift HMD saying it's on a USB 2.0 port while plugged into USB 3.0 port is degrading the performance of the HMD or Touch controllers.

    Windows 10 x64
    Asus Maximus IX Hero
    3x Sensors (Sensor 1 and 2 connected to USB 3.0/3.1 Gen 1, Sensor 3 connected to USB 3.1 Gen 2 with Active USB 3.0 Extension Cable)
    Headset connected to USB 3.0/3.1 Gen 1 port
  • MowTinMowTin Posts: 1,943 Valuable Player
    I'm getting this problem now too. I only recently updated windows 10 to 1709. That update caused a lot of USB related errors. I had to unplug a USB xbox wireless game controller because it was causing BSOD. It's been so many years since I saw blue screen full crashes. 

    I'll try disabling power management. 

    i7 9700k 2080ti   CV1, Rift-S, Index
  • ChazmeisterChazmeister Posts: 540
    It seems to come and go with various updates. I've got it again as well, and I've even had my Rift black screen games on me a couple of times now after taking it off and putting it back on, prompting an error message to appear within the Home environment.
  • Sephiroth986Sephiroth986 Posts: 6
    how can i resolve this problem? i have an msi h170 gaming m3 motherboard...i have updated all intel drivers...
  • dethswatchdethswatch Posts: 1
    same issue with Rift S- power management is turned off on all the hubs. One is an inatek but it doesn't seem to matter.

    stuck on the Connect Your Headset screen. Previous rift worked fine and I've removed the device from the headquarters.

    The best though is having to redownload 7gb every time it eventually fails. Thanks Oculus!

    errors are:
    This device is not working properly because Windows cannot load the drivers required for this device. (Code 31)

    Then under the events tab:
    Driver Management concluded the process to install driver riftsusb.inf_amd64_6f12f427c4b2bc0e\riftsusb.inf for Device Instance ID FLUSB\VID_2833&PID_2051\07DA0E28294F000600000000 with the following status: 0x0.

    Device FLUSB\VID_2833&PID_2051\07DA0E28294F000600000000 had a problem starting.

    Driver Name: oem5.inf
    Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
    Service: USBHUB3
    Lower Filters: 
    Upper Filters: 
    Problem: 0x1F
    Problem Status: 0xC00000BB

    Device FLUSB\VID_2833&PID_2051\07DA0E28294F000600000000 was configured.

    Driver Name: oem5.inf
    Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
    Driver Date: 03/27/2019
    Driver Version:
    Driver Provider: Oculus VR, LLC
    Driver Section: USB_Install.NT
    Driver Rank: 0x800001
    Matching Device Id: USB\VID_2833&PID_2051
    Outranked Drivers: oem53.inf:FLUSB_11001B73\Class_09:00802002 oem53.inf:FLUSB\Class_09:00802003
    Device Updated: true
    Parent Device: FLUSB\ROOT_HUB_FL30\5&df8c05c&0

    Device FLUSB\VID_2833&PID_2051\07DA0E28294F000600000000 was not migrated due to partial or ambiguous match.

    Last Device Instance Id: USB\VID_1058&PID_25A2\575838314142365031455948
    Class Guid: {36fc9e60-c465-11cf-8056-444553540000}
    Location Path: 
    Migration Rank: 0xF000FFFFFFFFF122
    Present: false
    Status: 0xC0000719

    Device FLUSB\VID_2833&PID_2051\07DA0E28294F000600000000 requires further installation.

  • 6side6side Posts: 1
    MY PROBLEM SOLVED. I had the same problem,I know this post is a lil old but i just started having this problem after the most recent occulus rift update as of 6-1-2020. My rig is windows 10 v1909 msi x570 gaming procarbon wifi, AMD RYZEN 3700x gtx 1080, 16gb kinsgton ddr4.booting off of WD 1tb nvme m2 black drive. when i boot up and enter device manager my usb superspeed hub has the error 31 and a yellow exclamation point to signify the problem. Heres what i do that solves MY problem: boot up like normal,wait a few seconds for all my background programs to load, enter device manager to check the usb superspeed hub. IF it has the error i will disable the device, THEN RESTART, when im back into windows ill pull device manager back up and then ENABLE the usb superspeed hub.BINGO, problem solved(for me at at least) I hope this helps some people as it took me some trial and error to make a work around. The occulus app still says its connected to usb 2.0 but my performance is the same as usb 3.0. My mobo has a dedicated VR usb port which im pretty sure is usb 3.0 minimum but may be 3.2 gen2. Either way when following these steps i dont have any performace problems. hope this helps.
  • DeformeddaveDeformeddave Posts: 1
    Had exactly the same issues as OP. Also have a recommended Inatek 4 port USB3 card. Noticed that the card was using the Microsoft driver. Downloaded and installed Fresco USB3 chipset driver. Installed no problem and seems to have fixed the Code 31 error.
Sign In or Register to comment.