Multi-GPU luid MisMatch? — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Multi-GPU luid MisMatch?

A7xMadA7xMad Posts: 6
NerveGear
Hello all, I would really appreciate someone helping me with this... I am trying to start Oculus video but it won't let me... I keep getting this error in the title, with a description saying this application requires you to plug oculus into the primary video adapter or switch your primary video adapter to the one Oculus rift is plugged in. I can't plug Oculus into the other hdmi port, so how can I switch my primary video adapter? (Note I am using a laptop, with a GTX1070... does it have anything to do with the fact that there is an onboard GPU (intel HD graphics 4600)?) Thank you.

Comments

  • Techy111Techy111 Posts: 5,566 Valuable Player
    I think you'll find laptops aren't supported at all. But you can try going into bios and disabling onboard graphics and see what happens?
    A PC with lots of gadgets inside and a thing to see in 3D that you put on your head.

  • A7xMadA7xMad Posts: 6
    NerveGear
    Techy111 said:
    I think you'll find laptops aren't supported at all. But you can try going into bios and disabling onboard graphics and see what happens?
    I was just playing lucky's tale earlier, so yeah mine is supported Thank God, but idk what's up with that specific app. Thing is when I go to advanced in the BIOS I can't find it, I found something called integrated NIC, which I don't think is what I am looking for?
  • manumanu Posts: 78
    Hiro Protagonist
    Both your Monitor and HMD have to be plugged into the same GPU. No exceptions. I had to disable my Integrated GPU, otherwise Oculus Photo and Video will not work.
  • A7xMadA7xMad Posts: 6
    NerveGear
    Hello again, Thank God I finally fixed it, and to my surprise it was actually simple. Didn't have to disable anything, just go to Nvidia control panel, manage 3D settings, Global settings, High performance Nvidia processor.
    I hope this helps all laptop users. Thanks anyway for the help! :smiley:
  • CrazyManOPCrazyManOP Posts: 2
    NerveGear
    I have the same issue except I’m playing on a desktop tower pc it says the same thing I have a nvidia 1060 3g can anyone help you
  • CrazyManOPCrazyManOP Posts: 2
    NerveGear
    I mean me
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Make sure nothing is connected to the motherboard integrated video port. Rift and all monitors must be on the primary dedicated GPU.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • CovertGamerCovertGamer Posts: 19
    NerveGear
    You are probably going to need a displayport adapter for your video card unless your monitor already supports it. 

    I got this one: 
    https://www.amazon.com/gp/product/B06VV26BLB/ref=oh_aui_detailpage_o04_s00?ie=UTF8&psc=1 

    Then just plugged my rift into the HDMI on the gpu and the monitor into the adapter then the displayport on the gpu.
Sign In or Register to comment.