Oculus Sensor USB 3.0 vs USB 2.0 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Sensor USB 3.0 vs USB 2.0

WarsenTechnologiesWarsenTechnologies Posts: 2
NerveGear
I thought I'd share my experience so anyone wondering the same doesn't have to go and buy several different USB Expansion Cards to get the infamous check-mark on the Oculus Compatibility Check for USB 3.0.

The Check told me that my USB port hardware wouldn't work with the rift, even though I had an expansion card with power supply power, instead of motherboard power, seeing as the Rift gets it's power through USB. The Rift was plugged into the USB 3.0 and said there was no issue at all, but when the sensor was connected to the same card, there was an error. Trouble shooting told me that I needed to get a specific chipset in the card I bought: Fresco Logic FL1100EX chipset.

Oculus recommended this one: https://www.amazon.com/Inateck-Superspeed-Ports-PCI-Expansion/dp/B00B6ZCNGM

Being in Australia, it would've taken weeks to come, and I couldn't find an expansion card in my area with the specific chipset. 

Although when the sensor was plugged into my expansion card (that Oculus didn't approve) everything worked perfectly in Oculus Home and the set up, but the software barred me from playing any games due to the hardware issue. In a last ditch attempt to get the sensor working, I plugged the sensor into a spare USB 2.0 port, and the ban from playing games was lifted, and the sensor worked perfectly.

I assume there is a benefit for using the USB 3.0 sensor, but I think it's odd that the software didn't want me to use a 3.0 port that worked perfectly, while it allowed me to play with a 2.0 port. There might be a hidden reason that this is the case that I don't know.

If anyone is having problems with their sensor not working through their USB 3.0, plug it into USB 2.0. I haven't had a single problem so far. Hope this helped someone.

Comments

  • NZadenNZaden Posts: 33
    Brain Burst
    Just to point out, I live in New Zealand and the pci-e card arrived in just three working days. Priority shipping.
  • kojackkojack Posts: 5,292 Volunteer Moderator
    I haven't been able to find a local usb 3 card with the right fresco logic chip in aus either. I've been thinking of getting the amazon one, but as you point out usb 2 works fine. I did have occasional tracking issues, but those went away when I turned off the usb sleep options in the power profile settings.
  • phoenixdigitalphoenixdigital Posts: 166
    Art3mis
    So does anyone actually know what is happening when we plug the sensors into 2.0 instead of 3.0?

    Is the image from the sensor being reduced in terms of resolution or is the framerate being reduced?
    CPU: i5 6600K (conservative overclock), GPU: Asus GTX1080Ti (not overclocked), motherboard: Asus Z170 Pro Gaming, USB Card 1: Inatek 4 Port, USB Card 2: Startek 2 Port
  • BrokenSymmetryBrokenSymmetry Posts: 250
    Nexus 6
    I discovered the exact same thing as OP did. USB 2+USB 3 works almost perfectly, whereas USB 3+USB 3 gave me a nightmare.
  • DragonfrostDragonfrost Posts: 32
    Brain Burst
    I discovered the exact same thing as OP did. USB 2+USB 3 works almost perfectly, whereas USB 3+USB 3 gave me a nightmare.

    I encounter the opposite, a 2 USB 3 1 USB 2 setup is worse than a full USB 3 setup, I have a inateck card and it doesn't matter what ports you use, the results are the same
  • GlobespyGlobespy Posts: 91
    Hiro Protagonist
    It's all broken drivers on their part and they are getting people spending money on USB 3.0 PCI cards unnecessarily. 
    My system is brand new $3000 gaming PC and my motherboard doesn't have any USB 2.0 ports, they are all 3.0.
    Yet every other day the rift decides it wants to be recognized as a 2.0 device. I have to unplug and plug back in to rectify. I've noticed that in USB 2.0 mode some games can look a little choppy.
    It's all on Oculus, I guess they are busy paying their IP theft fines to fix it. Lol.
Sign In or Register to comment.