New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

auto ASW - performance issues

SyndroidSyndroid Posts: 242
Nexus 6
edited October 2016 in General
So I was messing a bit with ASW, and so far, I'm not 100% happy with how the automatic ASW performs on my system,
In my understanding it is supposed to fix positional judder and ghosting on low fps (and also allowing lower spec PCs to enjoy VR).
While it is very good in fulfilling that promise, what it also does is reducing the overall performance (at least on my system).
I'm not a tech expert and and my english isn't that good, so I've recorded a video.




In the video you can see how I was switching between ASW disabled (ctrl+NUM1) and auto ASW (ctrl+NUM4)
As you can see, without ASW I get steady 90 fps most of the time. 
That "performance headroom" chart is scratching along 0 and dips a bit below 0 occasionally. However, everything is butterly smooth throughout this time. I only get noticible position judder and ghosting artefacts on more drastic dips(something like 87fps).

Now having auto ASW enabled, it seems to kick in way too early and I can notice the difference immediately. it is worse than the native 89-90 mode. 
In an ideal world, auto ASW kicks in at 88fps or respectively when there is true juddering.

That being said, I hope Oculus doesn't plan to force auto ASW in the next updates. 
That would be bad since I optimize most graphic-settings in a way that it is scratching along that 90fps mark and it is working just fine with ATW alone. 

What are your experiences with auto asw? 

Comments

  • DeanOfTheDriversDeanOfTheDrivers Posts: 144 Oculus Staff
    What are you system specifications? Clearly whatever you're running here is just right on the edge of making 90 fps (as shown by the perf headroom being -8 to 0%). This means ASW is triggered early to prevent significant, expected drops below 0% perf headroom. Knowing your system specs may help explain what's going on.
  • SyndroidSyndroid Posts: 242
    Nexus 6
    edited October 2016
    Hi, thanks for the quick response
    Specs:
    GTX 970 gaming 4g
    i7 4790k
    8 gb DDR3
    Win 10


    The rollercoaster demo was running with 1.2 pixel override (default 1.0) to achive that effect.
    Allthough, in both cases there was no positional judder when it was running on the edge of 90fps.

    For me this becomes a problem in Dirt Rally and Asseto Corsa in which I optimized the graphic settings and pixel override in a way that it comes close to that 90fps mark throuout most of the time. and again, without auto ASW, it stays on 90fps for 95% of my playsession time, and there's no judder whatsoever.
    Having auto ASW enabled would cause ASW to be triggered for 90% of the time. 

    It seems like without asw, apps are capable of running on steady and smooth 90 fps even if the headroom is monitoring 1-6% below 0.


  • SakkuraSakkura Posts: 267
    Nexus 6
    I think what you'd have to do is either crank up the graphics settings and run with ASW (lower performance, but more eye candy on screen), or just keep doing native 90FPS. Full 90FPS is still the best quality if/when your rig is powerful enough.
  • JusztinJusztin Posts: 19
    NerveGear
    edited November 2016
    Well, I can understand the benefit of ASW. But not every game works well with ASW. My game -iRacing- is terrible when ASW kicks in. I set up my graphical settings to have a good 90 fps (90%+ of time). If fps sometimes drops to 85, it is hard to notice. But now with ASW I'm getting very bad judders. Ironically I had to lower my settings to make sure ASW never comes in.
    ASW can be good in some games,  but this is not the ultimate solution, and users should be able to choose if they want ti or not.
  • GreymanGreyman Posts: 1,324
    Wintermute
    Try CTRL and the "1" key on the numeric keypad.  I don't know if the hot keys, from the development version, have been retained, but it's worth a try.  
  • whitav8whitav8 Posts: 92
    Hiro Protagonist
    I would just like to disable ASW - I don't like it's effects in DCS World and other apps - and the stutter isn't useful. I looked at the registry for the 
  • GreymanGreyman Posts: 1,324
    Wintermute
    On DCS world, from some fps monitoring I did last night, it would appear that the ASW issues appear when the frame rate drops below 45 fps and as DCS world, 1.5 at least, does not appear to be the most efficient, that can happen even at medium/low graphics settings.

    i tweaked my settings last night and the "wobbling" issues with the HUD and other issues largely disappeared, coinciding with a solid 45fps frame rate.

    it might be worth you trying the same and on the bright side, version 2 of DCS world does appear to deliver higher frame rates.
  • JeepyBJeepyB Posts: 19
    NerveGear
    please give us an easy way to permanently disable ASW.
  • rVRclosetrVRcloset Posts: 386
    Trinity
    Wonder if this causes my issues with Dirt Rally?..
    I have run this game smooth on High/Ultra, and if it got below 90 fps it can't have been often or by much, cause I have never noticed any stutter before.

    But haven't played it for a while, and the other day I started a new championship.
    Now some stages or parts of some stages have become stuttery to the point it's unplayable.. . Most noticeble on really twitchy tracks with many hairpins, when the car goes sideways fast the screen stutters and ripple like crazy..
    And Dirt Rally really need a high graphics setting to look good and clear in the CV1!
    On low settings it's so blurry it feels like I'm about to loose my sight, and my eyes starts hurting..

    Is ASW always on, and how do I know if it have kicked in? 
    And if it is this that causing probles. Let us decide for our selves if we want to use it or not with a permanent setting in Oculus home!!!

    I have both G-sync and V-sync turned off in Nvidia control panel.
    Have AA disabled in game options and using pixel density debug set to 1.4.
    ASUS ROG G752VS
    GeForce GTX 1070 8GB, Core i7-6700HQ 16GB
    The Closet Sim Rig
    Aourus Pro Z390 - i7 8086K 32GB Ram - MSI RTX 2080 Ti Gaming X Trio 11GB - Windows 10  / GT Omega WS - NLR V3 - RS6 - Jetseat kw-908 / Fanatec CSW 2.5 / Fanatec ClubSport V3 pedals / Fanatec SQ Shifter 1.5 / Fanatec CS HB V.1.5 / HE SQ Shifter / SHH Shifter / TH8A Shifter / G27 Shifter - Button Box / DSD Button Box / BBJ Button Box / Wind simulator / Rift - S
  • GreymanGreyman Posts: 1,324
    Wintermute
    I just leave pixel density at 1 and stick the settings up to ultra.  No stuttering yet
  • Comic_Book_GuyComic_Book_Guy Posts: 1,212
    3Jane
    There's no need to disable G-sync as that will only apply to a supported display and Vsync is handled by the ap and/or SDK heppsan.
Sign In or Register to comment.