New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

How to disable ASW

ramonramon Posts: 60
Hiro Protagonist
Is there anyway to disable ASW? 
I dont have a keyboard with num. pad, so I couldnt try if keystrokes still work. I couldnt find any solution so far. 
Im so fu**ing pi**ed, ASW is the next thing oculus is forcing up on us. I hope there will be an option to shut it off real quick!
ASW made everything worse for me, Im running a GTX1080 btw. It is so fu**ing noticable when ASW kicks in. Driving in Assetto corsa now feels like driving drunk, because half the frames are missing. And once the framerate drops to 45fps it constantly keeps staying there, which renders some games unplayable at the moment.
«13

Comments

  • RedRizlaRedRizla Posts: 7,142 Valuable Player
    Why do you want to turn it off? It will only kick in when the game or demo needs it, so why turn it off?
  • RedRizlaRedRizla Posts: 7,142 Valuable Player
    CTRL +1 is the key I think if it's causing problems. Are you sure you haven't just forced it on constantly because  it sounds like you have.
  • ramonramon Posts: 60
    Hiro Protagonist
    I did check the framerate.
    it drops from steady 90 to 45 
    if CTRL+1 is still working, im going for a new keyboard tommorrow!
  • RedRizlaRedRizla Posts: 7,142 Valuable Player
    I thought the Idea of ATW was that it kicks in when it's needed not remain constantly on. I think you might of switched it to be constantly on. Someone correct me if i'm wrong.
  • RedRizlaRedRizla Posts: 7,142 Valuable Player
    These were the Keys for the reg hack. Ctrl + 1 Ctrl +4 Ctrl +2 Ctrl+ 3
  • Protocol7Protocol7 Posts: 333
    Trinity
    The Ctrl + Num Pad controls do work in 1.10. I've been using them to see the differences with and without ASW running.
  • ramonramon Posts: 60
    Hiro Protagonist
    Protocol7 said:
    The Ctrl + Num Pad controls do work in 1.10. I've been using them to see the differences with and without ASW running.
    Thank you Protocol7
  • ramonramon Posts: 60
    Hiro Protagonist
    edited November 2016
    I managed to shut off ASW using Autohotkey.
    I think there should be an option to permanently disable it. because I cant see if its running or not until it kicks in
  • GreymanGreyman Posts: 1,324
    Wintermute
    edited November 2016
    Actually, I might be able to amend my Voice Attack profile, so that it sends Ctrl + 1 to the app, every time it starts up

    edit: if of course the 1.10 version of ASW isn't better than the previous version
  • DeanOfTheDriversDeanOfTheDrivers Posts: 144 Oculus Staff
    Im playing Assetto Corsa using Nvidias DSR at 4X native resolution, combined with a pixel fillrate of 2.0 
    I get a decent framerate as long as im not running a grid of more than 10 cars.
    Anybody running a GTX 1080 with Assetto Corsa should try, its a massive graphics improvement.

    Ramon, I quoted this from your post history since my testing with Assetto Corsa shows it makes frame rate on my lower spec machines. It's very likely that you're well below 45 FPS even with your GTX 1080. ASW doesn't work well for sub-45 rates, otherwise ASW is largely undetectable. 

  • BagnetBagnet Posts: 120
    Art3mis
    I have a 780 gtx which even though it out performs the 960 is a too low spec card (lol). Its flawless without asw.
  • zbosonzboson Posts: 994 Poster of the Week
    I have not found a way to disable it yet. I have update 1.10.
  • ramonramon Posts: 60
    Hiro Protagonist
    Im playing Assetto Corsa using Nvidias DSR at 4X native resolution, combined with a pixel fillrate of 2.0 
    I get a decent framerate as long as im not running a grid of more than 10 cars.
    Anybody running a GTX 1080 with Assetto Corsa should try, its a massive graphics improvement.

    Ramon, I quoted this from your post history since my testing with Assetto Corsa shows it makes frame rate on my lower spec machines. It's very likely that you're well below 45 FPS even with your GTX 1080. ASW doesn't work well for sub-45 rates, otherwise ASW is largely undetectable. 

    This is long time obsolete!
    Im not using DSR anymore since anti aliasing is working again, just cranked up the fillrate to 2.0. When I shut ASW off, I get a constant framerate of 90 for allmost all of the time. With ASW enabled, as soon as it kicks in You can feel it instantly, because its so hard to judge how fast you are going with all those frames missing.
    it looks, feels so terrible and the worst is that the framerate stays down at 45fps once it kicks in. (Assetto corsa)
  • zbosonzboson Posts: 994 Poster of the Week
    How are you disabling ASW? I used the debugtool to look at the frame rate and it hops usually between 90 and 45 and nothing I have tried (e.g. Ctrl-1) changes this.
  • ramonramon Posts: 60
    Hiro Protagonist
    Yes, Ctrl-1 shuts it off.
    at least its working for me
  • zbosonzboson Posts: 994 Poster of the Week
    edited November 2016
    How are you verifying this? With the Oculus Debug Tool or something else?
  • ramonramon Posts: 60
    Hiro Protagonist
    You can use the debug tool,
    In assetto corsa ingame during a race im using the overlay from the right status bar showing rendering stats.
    if you wanna shut ASW off you have to use Ctrl-1 (from the number pad)
  • zbosonzboson Posts: 994 Poster of the Week
    Yes, I use the numberpad. I have tried lots of options but no noticeable change. It still hops between 90 and 45 irrespective of what I do.
  • zbosonzboson Posts: 994 Poster of the Week
    edited November 2016
    I don't need this option in general. I mean I don't need this option in Oculus Home settings or a key combination.

    Maybe it can be part of the Oculus Debug Tool. Perhaps they will do this soon with the next Oculus SDK. I just want it for compassion with and without ASW.
  • BagnetBagnet Posts: 120
    Art3mis
    Easiest way to disable it is to install a Nvidia 780GTX, you will never have trouble making it not work again! :)
  • DeanOfTheDriversDeanOfTheDrivers Posts: 144 Oculus Staff
    You can feel it instantly, because its so hard to judge how fast you are going with all those frames missing.

    Is there any way you can provide logs? I'd like to confirm you're making at least 45 fps. https://forums.oculus.com/community/discussion/33792/how-to-get-logs-for-bug-reports-for-consumer-rift-1-3/p1
  • GreymanGreyman Posts: 1,324
    Wintermute
    I'm not sure if it matters which Ctrl key you use, but you will need to make sure that the numlock light is on.  I use the leftmost Ctrl key, btw, and that seems to work just fine, at disabling ASW.

    sorry if this seems like an "egg-sucking" lesson, but it's worth checking 
  • GreymanGreyman Posts: 1,324
    Wintermute
    it appears to activate again, at least every time you restart the pc and possibly more frequently than that, perhaps even each time a vr application is loaded and i have yet to find a way of setting it to default to off.  In the meantime, i have amended my VA profile to make sure that it is turned off every time i start a new DCS world mission.
  • Samg381Samg381 Posts: 7
    Brain Burst
    Just want to chime in here. Yesterday for some ungodly reason ASW managed to enable itself on my computer. It has made all my simulation games, particularly DCS completely unplayable. I am looking for a way to permanently disable ASW so I can use my $600 headset the way I intend to.

    Otherwise, I would like information on how I can go about obtaining a refund for my defective product that will not render games above 45 fps.
  • GreymanGreyman Posts: 1,324
    Wintermute
    edited November 2016
    at least in the short term, you might have to get into the habit of pressing ctrl and numpad 1 and ctrl numpad 2, whenever you start DCS.

    However, if you use the VAICOM profiles in Voice Attack, which i would highly recommend, especially if you have a HMD on, you can just add a couple of key press actions, one for each of the above ctrl key combos, to the end of the Start Mission command, and whenever you start a new mission, including the first in your session, it turns ASW off.
  • Samg381Samg381 Posts: 7
    Brain Burst
    edited November 2016
    Greyman said:
    at least in the short term, you might have to get into the habit of pressing ctrl and numpad 1 and ctrl numpad 2, whenever you start DCS.

    However, if you use the VAICOM profiles in Voice Attack, which i would highly recommend, especially if you have a HMD on, you can just add a couple of key press actions, one for each of the above ctrl key combos, to the end of the Start Mission command, and whenever you start a new mission, including the first in your session, it turns ASW off.
    When I'm actually loaded up in the cockpit, the control/numpad hotkeys have no effect and I'm capped at 45fps.
    Absolutely hilarious. 
  • GreymanGreyman Posts: 1,324
    Wintermute
    hmmm, then there must be something different between our setups, as ctrl + numpad 1 and 2 certainly turn ASW off for me.  

    Did you have ASW enabled before the update landed?  I did and i wonder if that might be making the difference.  
    It won't explain everything, but does ctrl + numpad 1 or 2 work from anywhere, e.g. from windows before you start up dcs world or from the dcs world menus?

    I'm really guessing now, but do you have ctrl and numpad 1 and/or 2 mapped in your DCS controls.  I'm fairly sure i removed my mappings, as it may be that the key presses are being intercepted by DCS and never land with the ASW software.   Worth a try.  Just select any one of the cells in the keyboard column and press ctrl + numpad 1 and it will take you to the cell that you need to clear.  It will be some fairly obscure view command, so it won't be a major loss.  Then do the same for ctrl + numpad 2.

    Also, and don't shout at me, but please make sure that your numlock light is on.  :)
  • DeanOfTheDriversDeanOfTheDrivers Posts: 144 Oculus Staff
    control/numpad hotkeys have no effect

    Samg381, if they have no affect at all then ASW is not enabled. An update went through but there could potentially be another performance issue unrelated to ASW that you're seeing here.

  • GreymanGreyman Posts: 1,324
    Wintermute
    I know that i'm putting myself in harm's way, but i have to ask.  you do have vsync turned off don't you?
  • Samg381Samg381 Posts: 7
    Brain Burst
    Vsync is off. Gsync is off. I can see ASW flipping between 45 and 90fps when I do CTRL + 1, but it only works in the oculus home, and has no effect in game.
Sign In or Register to comment.