Oculus Sensor Firmware Error!! Please Help! — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Sensor Firmware Error!! Please Help!

Ziegs4LifeZiegs4Life Posts: 1
NerveGear

Hello Oculus Rifters,

So for 5 straight days I have been troubleshooting the Firmware Sensor Error CV1 problem with everything I could find online to fix the solution but nothing worked. Im using the ASUS G20cb computer running Windows 10 64bit. I click the oculus firmware update and it begins the update, during that time I hear the Windows sound of a USB port being plugged in and unplugged twice. After I hear that sound, it shows that there was a sensor error and could not update firmware. Windows shows that the sensor is connected, up to date and working properly. I have uninstalled and reinstalled oculus and all drivers, plugged into different USB 3 ports, reinstalled all oculus drivers, and updated all ASUS USB, BIOS, ect. drivers as well. Sensor worked fine until oculus firmware Sensor update was requested. 

Since the oculus was working before the Windows Anniversary update, I thought a Factory reset of the ASUS G20cb would fix it (SINCE IT WAS AN OCULUS READY PC), which rolls back before the windows anniversary and deletes all files and programs that were on the computer. Believe me, this was my last resort of fixing it because I didnt want to lose everything I had on the computer. Turns out after the factory reset and loading the oculus program back on the computer, it still comes up with a SENSOR FIRMWARE ERROR!

I did a SECOND factory reset and this time ran all the windows Anniversary updates before I installed the oculus program, but I am still getting the same Oculus Sensor error. My computer says all of my USB 2.0, 3.0, and 3.1 drives are working properly, so it is nothing wrong on my end of the computer. 

The ASUS 3.0 USB shows it is plugged in and working correctly, and in the Oculus Device Setting it shows connected, but I get a notification that pops up in the bottom right of my screen that says cannot find sensor please connect. 

****When I look at the Sensor device in Oculus setting it shows the error 178/unknown (Update Required to 178/e9c7e04064ed1bd7a089e738b638b4c8467aa843-DIRTY)

Do I just need a new Oculus Sensor!!??

Please, any insight on this problem would help me out! Thank You!

Comments

  • DarkWormSystem32DarkWormSystem32 Posts: 42
    Brain Burst
    I would say contact support but they might just ditch you, been waiting almost a week to hear from them thinking about returning it
  • papajinoupapajinou Posts: 6
    NerveGear
    My rift and touch works before update, now i must updated my sensor but it's failed again and again.
    Occulus support wake up guys!
  • papajinoupapajinou Posts: 6
    NerveGear
    Win10:

    Occulus setup for rift and touch install driver: "Rift sensor" in "device manager" of windows 10.

    Update firmware install: 
    tweaks
    : remove rift sensor in your "device manager" for apply update correctly. but Despite everything cv1 external camera which doesn't works et display with yellow warning.

    Please I tried everything on this forum on sensor update firmware failed subject.
    Please Help the community.

    the problem has appeared since 2 week. One  week after received my touch.
    I can play only with one sensor because of that and without touch!

  • TopiBabaTopiBaba Posts: 3
    NerveGear
    I am facing the exact same issue & i have the exact same device as your's . Tried contacting support & they are of no good uptill now , expecting my oculus touch within a week. I wonder what could help us all out in this situation :( 
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    It may be a USB issue. I would try different USB ports (USB 2.0 can work better). You can also try getting this USB add-on card. https://www.amazon.com/Inateck-Superspeed-Ports-PCI-Expansion/dp/B00B6ZCNGM
    Finally, you can try plugging the hardware into a different computer as you may be able to update the firmware there and then switch back to the first computer. Hope that helps.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • TopiBabaTopiBaba Posts: 3
    NerveGear
    edited January 2017
    I am using Asus ROG G20CB & i dont think that i should open up my system to install an extra piece of hardware-Also finding another PC with same specs would not be easier,when u r a gamer & have very few real life friends :-p ;-)
  • spoileyspoiley Posts: 1
    NerveGear
    Same issue here. I'm on the new Razer Blade. Any new suggestions?
  • TopiBabaTopiBaba Posts: 3
    NerveGear
    Online support from Oculus have suggested me to claim warranty.
  • Bruno_BGPBruno_BGP Posts: 22
    NerveGear
    Man i'm realy dispointed. There must be a solution update to everybody. Hard to believe that oculus doesn't mind.
  • akic88akic88 Posts: 36
    Brain Burst
    Been playing with my CV1 uneventfully til i updated to Windows 10 creator update, then Oculus app require me to update the sensor firmware (unable to). Call Oculus CS, not any bit helpful at all.

    Then i roll back to previous Windows 10, no more ask for Sensor firmware update in Oculus.
    However, same issue comes again after my Windows updated a Cumulative Update at 18 APR.

    Rift sensor shows normal in Device manager

    Anyone here encounter the same?
  • Felix94KFelix94K Posts: 2
    NerveGear
    edited June 2017
    Has anyone found a solution to this? I'm having the same problem.
    Tried it on 3 different PCs. All Win 10, one is without the creators update.
    Also tried different USB ports (2.0 + 3.0), but nothing worked.
  • felippe.sandrinifelippe.sandrini Posts: 3
    NerveGear
    Any solution ????
     I have the same problem. 
    I already accomplished everything, I can not stand it anymore
  • Felix94KFelix94K Posts: 2
    NerveGear
    I contacted oculus support and they told me to send the sensor in. So it's probably a hardware issue.

    Haven't gotten it back though and according to UPS it's been 3 weeks since they received the package. Originally they said it would take 8-12 business days (including shipping) to replace it. It's day 16 now and I haven't heard anything from them, not even that they received the item. So far I'm pretty disappointed with the customer support here.
  • MostHated_MostHated_ Posts: 29
    NerveGear
    edited August 2017
    I think the problem is the sensor that comes with the touch controllers is just poor quality. That same sensor is the one that has been not working for me for over 2 weeks now and it has been a week now since I heard anything from support on the issue aside from an automated email that said : 

    Thanks for reaching out to Oculus Support.
    We sincerely apologize that we have not yet had time to review your case.
    At this time, we have a larger volume of tickets than usual. Your ticket will be handled in the order it was received.
    Thank you for your continued patience and understanding.

    That was after having daily conversations with them, providing them serial numbers, logs, etc, now they are simply not replying to me. Which tells me that the sensor that comes with the touch controller bundle, in order to make it cheaper.... is cheaper. Probably bad materials and shitty craftsmanship to try and save money to make it cost less. Now they are swamped with people having similar issues.
  • MADracingMADracing Posts: 1
    NerveGear

    I have the same problem with receiving errors on one computer but both sensors work correctly with another computer.  Both are Dell computers one Alienware and one XPS w/ added USB 3.0 controller.  The sensors will not work on USB 3.0 ports on the XPS system but the headset USB3.0 does.  On the XPS I ended up using both sensors on USB 2.0 ports and it works well, im sure it doesn't transfer info as fast but I cant notice. 


    Hope this helps,

    Marc   

  • akic88akic88 Posts: 36
    Brain Burst
    my "Firmware update" issue wasn't solved since April. And I try install it again today and still the same bad result. I tend to think this is not the hardware (sensor) problem. Since the issue shown after an update of Windows 10 (back to March/April). It looks more like the error caused by Windows/Motherboard driver compatibility to this sensor.
  • Drunk3nShamanDrunk3nShaman Posts: 31
    Brain Burst
    Oculus Rift has been the most disappointing purchase of my life...and I owned a sega saturn at 600 dollars day one I paid 399 for the rift and feel ripped off. I'm sick and tired of shit not getting fixed. I'm asking for a refund or replacement if not VIVE here i come, my nephew has had one for over a year now and loves it. 
  • andest2003andest2003 Posts: 2
    NerveGear
    anyone got this fixed yet
  • falken76falken76 Posts: 2,747 Valuable Player
    edited January 2018
    TopiBaba said:
    I am using Asus ROG G20CB & i dont think that i should open up my system to install an extra piece of hardware-Also finding another PC with same specs would not be easier,when u r a gamer & have very few real life friends :-p ;-)
    NVM didn't realize this was a necrothread....

    @andest2003 open a support ticket, they'll probably ultimately have you RMA it, that's what happened to others in this thread.
  • AlanovskiAlanovski Posts: 3
    NerveGear
    March 2019. Same shit. 
  • AlanovskiAlanovski Posts: 3
    NerveGear
    Alanovski said:
    March 2019. Same shit. 
    Ok. Fixed by rerunning the Oculus driver manually (Program Files\Oculus\Support\oculus-drivers).
Sign In or Register to comment.