New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

FIXED : Can't get Medium to work : It returns to Oculus home

CatanoniaCatanonia Posts: 7
NerveGear
edited December 2016 in Oculus Medium
I have downloaded and installed it twice now and when I click it from Oculus home, I get the loading page and it just returns to Oculus home.

All my other touch content is working fine , except for Medium.

Any ideas ?
«1

Comments

  • CatanoniaCatanonia Posts: 7
    NerveGear
    The problem seems to be with NTDLL.DLL on Windows 10 Pro

    Oculus, has Medium been tested on Windows 10 Pro ?
  • psycocyrilpsycocyril Posts: 9 Oculus Staff
    Hi Catanonia. Curious how you diagnosed this to be the issue? Also, did you see a message box with "Oculus Medium has crashed"?
  • CatanoniaCatanonia Posts: 7
    NerveGear
    edited December 2016
    Hi Catanonia. Curious how you diagnosed this to be the issue? Also, did you see a message box with "Oculus Medium has crashed"?
    Myself and 1 other in the oculus facebook pages have exactly the same issue, both on Windows 10 Pro. All of our other Oculus / Touch titles work perfectly and we have similar systems and both fail exactly the same on Medium.

    No messages on screen, but I found the event in the Windows event viewer for Medium and Oculus showing that NTDLL.DLL crashed.
  • Hiro_Protag0nistHiro_Protag0nist Posts: 4,978 Valuable Player
    Won't open for me either.


  • CatanoniaCatanonia Posts: 7
    NerveGear
    Faulting application name: OculusMedium.exe, version: 0.0.0.0, time stamp: 0x583cc27b
    Faulting module name: ntdll.dll, version: 10.0.10586.672, time stamp: 0x580ee321
    Exception code: 0xc0000005
    Fault offset: 0x0000000000039437
    Faulting process id: 0x2ef4
    Faulting application start time: 0x01d24ffa05ca9859
    Faulting application path: C:\Program Files\Oculus\Software\Software\oculus-oculus-medium-retail\bin\OculusMedium.exe
    Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
    Report Id: 506f94e3-0a52-44ad-9f9d-a34df7a1072f
    Faulting package full name: 

  • psycocyrilpsycocyril Posts: 9 Oculus Staff
    Thanks! Looking into the logs.
  • psycocyrilpsycocyril Posts: 9 Oculus Staff
    Interesting. Looks like it is running into trouble trying to create a directory. Sadly I don't have much info on which one (fixing that now). Can you give me any information on if you modified your oculus install directory or your Documents directory?
  • Hiro_Protag0nistHiro_Protag0nist Posts: 4,978 Valuable Player
    Hi cyril.  My install is standard, on the C drive.

    My documents directory is on a networked drive.
  • CatanoniaCatanonia Posts: 7
    NerveGear
    edited December 2016
    My install is on the C drive with 125GB free. My documents is also stored on the network (re-directed). I thought it may be this, but switching off the re-direction is not working as Windows 10 is caching the darn thing.

    Run into this before with 1 other program way back that tries to create a directory. If someone could tell us which directories medium creates at launch, we could pre create them and hopefully it may work as a workaround.
  • psycocyrilpsycocyril Posts: 9 Oculus Staff
    Aha thanks this is super helpful.
    I'll make sure that we add networked Documents directories to our test pass and support that as best we can (I'll need to dig in to understand exactly what is happening).
    In the mean time the quickest way to get you up and running will be to change where the Medium Library is set up. This will involve using regedit.exe to edit HKEY_CURRENT_USER\SOFTWARE\Oculus\Medium\LibraryDirectory to point somewhere else (by default it will point to C:\Users\<username>\Documents\Medium).
    Please let me know if this works as a workaround for now.
  • Hiro_Protag0nistHiro_Protag0nist Posts: 4,978 Valuable Player


    I'm ready for my Artist Spotlight live stream.   :)
  • CatanoniaCatanonia Posts: 7
    NerveGear
    edited December 2016
    Aha thanks this is super helpful.
    I'll make sure that we add networked Documents directories to our test pass and support that as best we can (I'll need to dig in to understand exactly what is happening).
    In the mean time the quickest way to get you up and running will be to change where the Medium Library is set up. This will involve using regedit.exe to edit HKEY_CURRENT_USER\SOFTWARE\Oculus\Medium\LibraryDirectory to point somewhere else (by default it will point to C:\Users\<username>\Documents\Medium).
    Please let me know if this works as a workaround for now.
    Awesome and many thanks for the massive turnaround on this.

    For your reference, my reg key was almost right, it was  
    cat-nas\User Data\Steve Allan\Redirected\Documents\Medium

    It is missing the two \\   (2 backslashes) from the beginning it should have read

    \\cat-nas\User Data\Steve Allan\Redirected\Documents\Medium

    But this didn't work either.

    So I set mine to d:\scratch Folder\Oculus Medium and Medium now works :):)

    Many many thanks for taking this on board and finding a workaround for us so quickly.

    Regards

    Happy Oculus user :)


  • ckelley1311ckelley1311 Posts: 5
    NerveGear
    I am having issues with Medium on windows 10 not starting. No crashes, no error codes- it just will not start. I have re-installed/rebooted ; tried launching from within the headset and from the PC itself. No luck as of yet.
  • ckelley1311ckelley1311 Posts: 5
    NerveGear
    My documents library is on the local machine "C:\Users\Chris\Documents\Medium" but is doing the same the other person had happen.

  • RobotSandwichRobotSandwich Posts: 5
    NerveGear
    I am having issues with Medium on windows 10 not starting. No crashes, no error codes- it just will not start. I have re-installed/rebooted ; tried launching from within the headset and from the PC itself. No luck as of yet.
    im having the same issue....im using windows 10 enterprise...nothing in this thread worked for me
  • RobotSandwichRobotSandwich Posts: 5
    NerveGear
    Talked to a developer....had me go into device manager and right click on my monitor and update the drivers for the monitor itself...that worked for me.
  • mikeferchakmikeferchak Posts: 2
    NerveGear
    For me, it seems like remote desktop and/or f.lux was causing the problem. I uninstalled Splashtop, Duet, and f.lux, updated my video card drivers (nvidia) to the latest version, and Medium started working perfectly.
  • ElmoTheGr8ElmoTheGr8 Posts: 1
    NerveGear
    Aha thanks this is super helpful.
    I'll make sure that we add networked Documents directories to our test pass and support that as best we can (I'll need to dig in to understand exactly what is happening).
    In the mean time the quickest way to get you up and running will be to change where the Medium Library is set up. This will involve using regedit.exe to edit HKEY_CURRENT_USER\SOFTWARE\Oculus\Medium\LibraryDirectory to point somewhere else (by default it will point to C:\Users\<username>\Documents\Medium).
    Please let me know if this works as a workaround for now.
    Hi, my Medium is crashing too but with an error message:

    Opengl high error: 1282 -- GL_INVALID_OPERATION error generated. Cannot modify the default framebuffer object.

    Would your method work for me also? If so would you mind breaking it down a little as I'm new to this? Thanks
  • Emomilol1213Emomilol1213 Posts: 2
    NerveGear
    Running Win 10 Home, got Documents on E:\USER\Documents\Medium . No crash message, tried changing directories in regedit, updating GPU drivers, updating monitor drivers but still not working. I do however get an error in event viewer when I try to launch Medium

    The description for Event ID 0 from source OculusVR cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    07/12 21:42:07.153 {!ERROR!} [LibraryItem] 
    Error [4294967295] returned from library item oculus-oculus-medium-retail

  • ShaosilShaosil Posts: 3
    NerveGear
    Running Win 10 Home, got Documents on E:\USER\Documents\Medium . No crash message, tried changing directories in regedit, updating GPU drivers, updating monitor drivers but still not working. I do however get an error in event viewer when I try to launch Medium

    The description for Event ID 0 from source OculusVR cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.

    If the event originated on another computer, the display information had to be saved with the event.

    The following information was included with the event: 

    07/12 21:42:07.153 {!ERROR!} [LibraryItem] 
    Error [4294967295] returned from library item oculus-oculus-medium-retail


    I had a separate thread about this exact issue. You can find my solution here.
  • NutnhoneyNutnhoney Posts: 16
    NerveGear
    Unhandled exception at 0x00007FFC68601865 (_1_helloworld.dll) in OculusMedium.exe: 0xC000001D: Illegal Instruction.
    00007FFC68601865  blendvps    xmm3,xmm7,xmm0  

    This instruction requires SSE4.1 which my AMD Phenom II X6 does not support.
  • dpearcydpearcy Posts: 1
    NerveGear
    Aha thanks this is super helpful.
    I'll make sure that we add networked Documents directories to our test pass and support that as best we can (I'll need to dig in to understand exactly what is happening).
    In the mean time the quickest way to get you up and running will be to change where the Medium Library is set up. This will involve using regedit.exe to edit HKEY_CURRENT_USER\SOFTWARE\Oculus\Medium\LibraryDirectory to point somewhere else (by default it will point to C:\Users\<username>\Documents\Medium).
    Please let me know if this works as a workaround for now.
    Hi, my Medium is crashing too but with an error message:

    Opengl high error: 1282 -- GL_INVALID_OPERATION error generated. Cannot modify the default framebuffer object.

    Would your method work for me also? If so would you mind breaking it down a little as I'm new to this? Thanks

    I get this same error. Anyone else seeing this? Any ideas how best to troubleshoot? Everything else is working perfectly.
  • thhrashthhrash Posts: 13
    NerveGear
    edited December 2016
    Yes, I get the same type of error (different verbage but same error code).  And Quill will just show a black screen with four strange characters on upper left on the PC window

    Opengl high error: 1282 -- GL_INVALID_OPERATION error generated. Function gl_Push_Attrib is depreciated and not available in preview contexts

  • FatMcNastyFatMcNasty Posts: 24
    Brain Burst
    Im getting this as well.. 

    Opengl high error: 1282 -- GL_INVALID_OPERATION error generated. Cannot modify the default framebuffer object.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    edited December 2016
    Make sure you don't have any GPU overlay/monitor apps running like RivaTuner, Afterburner, Precision, etc.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • ProskurinartworkProskurinartwork Posts: 2
    NerveGear
    nope doesnt work, same error medium opens and quits the white screen on the desktop 
    and thats it, no overlays running 

    updated drivers 10 miutes ago, still nothing.. :/ 
    error is

    Opengl high error: 1282 -- GL_INVALID_OPERATION error generated. Cannot modify the default framebuffer object.
  • SypherxSypherx Posts: 17
    NerveGear
    I'm on Windows 10 Pro Creators Edition and getting this error when in trying to start Medium:


    GLFW Error [65542]: WGL: The driver does not appear to support OpenGL
  • MattHickmanMattHickman Posts: 359 Oculus Staff
    Sypherx said:
    I'm on Windows 10 Pro Creators Edition and getting this error when in trying to start Medium:


    GLFW Error [65542]: WGL: The driver does not appear to support OpenGL
    Have you tried all of the above? Make sure updated GPU drivers, make sure no GPU overlays or tuners are on.
  • SypherxSypherx Posts: 17
    NerveGear
    Sypherx said:
    I'm on Windows 10 Pro Creators Edition and getting this error when in trying to start Medium:


    GLFW Error [65542]: WGL: The driver does not appear to support OpenGL
    Have you tried all of the above? Make sure updated GPU drivers, make sure no GPU overlays or tuners are on.
    My GPU drivers are up to date, and I deleted EVGA OCX.  I have Geforce Experience GPU overlay turned off.  I don't know what is going on.  This is the only application that doesn't work and it used to work.  I haven't made any hardware changes.  I haven't installed any new software, virus protection, or GPU overlays.  All i did was update my GPU driver.  It thought it maybe that so I rolled back my GPU drivers and I'm getting the same error.  So now i have fresh installed the most recent GPU drivers and still nothing.  UGH!!! 
  • MattHickmanMattHickman Posts: 359 Oculus Staff
    Do you run any ad blocking softwares or malware scanners like adaware? Try booting medium not connected to the internet.

    The open gl errors we've seen have to date, always been related to old drivers or tuners or opengl overlays so I'm little at a loss on this one. Can you attach the crash logs?
Sign In or Register to comment.