New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus TrayTool - SuperSampling profiles, HMD disconnect fixes (hopefully)



  • RosgilliesRosgillies Posts: 152
    Well, I`m off. Thanks to all who gave help when needed and especially Apollyonvr. Been with Oculus since the early days but Now after fighting black screens, spending endless time trying to get my 3rd party sims to work reliably, I now have red meteor showers in the headset, ( my third one I might add.) Back to 2d with trackir. At least I can see what I`m doing in ETS2 especialy and with my 1080ti everything in 4k. Not ranting so please dont flame me but I dont have the energy to go through the Oculus support system yet again. Thing that narks me is I cant even sell this HMD as it would`nt be fair to a buyer. Cheerio all. Ross.
  • BlackPixel_BlackPixel_ Posts: 62
    Hiro Protagonist
    Oh wow never heard of TRACKIR before but it looks awesome!
    MSI X99 GODLIKE Board / Intel Core i7-6900K / 32GB Extreme DDR4 2400MHz Memory / GTX 1080 Founders / 

  • ApollyonVRApollyonVR Posts: 378
    @Rosgillies Sad to hear mate :-/. If you want feel free to PM me the stuff you’ve tested so far and what support has said, and perhaps i can think of something else to try.

  • Digikid1Digikid1 Posts: 2,045 Valuable Player
    Just a report that OTT is not switching my audio back to my speakers when not using my rift. Just a FYI. 
  • AymitoAymito Posts: 41
    Brain Burst
    echo arena was recent updated to version 8,  and now ASW mode 45 frame is no longer working  inside the game with Oculus tray tool , I get a profiles errors and game refuse to run, is there a way to force ASW 45 frame mode with the new update 83.1 OTT, thanks
  • ApollyonVRApollyonVR Posts: 378
    @Digikid1 Try resetting the audioswitcher settings and set them again. If that does not fix things, please do a run in debug mode, replicate the issue and then send me the ott.log and i'll have a peek.
    @Aymito ; Sounds like it may be an issue with Echo Arena, perhaps the devs force ASW in the new upate. Also, ASW can be changed during a sessions. So you can try running the game, then changing ASW using the Global ASW dropdown instead. Using the ASW overlay at the same time will show you the change as it happens, so you can easily see what result you get.

  • AymitoAymito Posts: 41
    Brain Burst
    ASW can be changed during a sessions. So you can try running the game, then changing ASW using the Global ASW dropdown instead. Using the ASW overlay at the same time will show you the change as it happens, so you can easily see what result you get.
    I did try to change during the game its not working in the lobby only the startup menu work, after that its not affecting at all, I did a post on Echo Arena discussion to inquire about the new update , but no reply until now  :/
  • JD-UKJD-UK Posts: 2,289 Valuable Player
    edited March 2018
    Still unable to run OTT - it is refusing to start, like it did a while before. I don't know if this was sorted or not, because I uninstalled it for a while (no point in watching it continually trying to run).

    OK - sorted - I disabled Malwarebytes and OTT works okay so far (bloody MBAM is getting annoying with Oculus progs these days!)

  • zissakoszissakos Posts: 3
    Since many versions now the tool just refuses to start. Tried it with 0.83.1.
    I see the black box in the lower right corner saying "Starting up, please wait..." and then nothing hapens!
    It sits there in the task manager, using roughly 50 MB RAM.
    Version 0.70.1 works like a charm though!

    This is the ott.log:
    05.04.2018 13:06:55 Starting up...
    05.04.2018 13:06:55 Version:
    05.04.2018 13:06:55 .NET Framework Version: 4.7
    05.04.2018 13:06:55 Checking Internet connection..
    05.04.2018 13:06:56 Internet connection available
    05.04.2018 13:06:56 Oculus path: C:\Program Files\Oculus\
    05.04.2018 13:06:56 Oculus App Version:
    05.04.2018 13:06:56 Migrating configuration
    05.04.2018 13:06:56 Settings migration complete!
    05.04.2018 13:06:56 ## Current Settings ##
    05.04.2018 13:06:56 ## End Settings ##
    05.04.2018 13:06:56 Getting old profiles
    05.04.2018 13:06:56 Reading configuration parameters
    05.04.2018 13:06:56 Changing active Power Plan to High performance
    05.04.2018 13:06:56 Current Power Plan is High performance
    05.04.2018 13:06:56 High performance has USB Selective Suspend Enabled
    05.04.2018 13:06:56 Done reading configuration parameters
    05.04.2018 13:06:56 Oculus Library paths not set, retrieving them from the registry
    05.04.2018 13:06:56 Could not get Oculus Software path from registry
    05.04.2018 13:06:56 No library paths returned from registry
    05.04.2018 13:06:56 Reading profiles
    05.04.2018 13:06:56 0 profiles found
    05.04.2018 13:06:56   0 monitored using WMI
    05.04.2018 13:06:56   0 monitored using Timer
    05.04.2018 13:06:56 Using C:\Program Files\Oculus\Support\oculus-diagnostics\OculusDebugToolCLI.exe
    05.04.2018 13:06:56 Checking for running DebugTool instances..
    05.04.2018 13:06:56 No Fresco Logic settings found in registry, probably not installed
    05.04.2018 13:06:57 OVR Service is UP
    05.04.2018 13:07:00 Setting new SS to 1.5

    Could it be the line "No library paths returned from registry" ??
    Where in the registry does the tool search for them?
    I have disabled any Antivirus, still no luck.
  • saudarapokersaudarapoker Posts: 5
    anyone can give me a tutorial to setup? 
  • NetheriNetheri Posts: 247
    Nexus 6
    Would it be possible to get the power saving option to change to "performance" when the OculusHome(2) starts and set back to balanced when the OculusHome(2) is shut down instead that those change when OTT starts or closes? Now the power saving goes to "performance" every time when i boot or sign in to Win10 as OTT is on automatic start when Windows starts. Also if i put "not used" to "Set power plan on start", then the "USB selective suspend" can't be used at all? 
    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • ApollyonVRApollyonVR Posts: 378
    @zissakos I've PM'd you.
    @Netheri can make such a change, will probably make it an option somewhere as some users might run games/apps that don't nessecarily require Home, so having it a as some form of toggle makes sence. The selective suspend is tied to the power plan as you can have it enabled/disabled per power plan. And that setting is picked up depending on the plan selected, so not used will disable the feature as it needs a powerplan to adjust the setting.
  • NetheriNetheri Posts: 247
    Nexus 6

    @Netheri can make such a change, will probably make it an option somewhere as some users might run games/apps that don't nessecarily require Home, so having it a as some form of toggle makes sence. 
    That's exactly why i recommended it in future versions. :) 
    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • reevezgod420reevezgod420 Posts: 3
    I'm having an issue where in my games different parts of the screen move seperately.  Its almost like screen tearing with vsync, but it happens in random locations in the world around me.  I've tried it with SS at 1.5 and at 1.1/1.2 and there's no change.  I'm not really sure why its happening.  

    Oculus Rift CV1
    Intel i7 4770 3.40ghz
    16GB 2133mhz DDR3 Gaming Ram
    GTX 1080
    Windows 10 64bit
    OTT 0.83.1
  • ApollyonVRApollyonVR Posts: 378
    @reevezgod420 Could be a graphics driver issue perhaps? If you run without OTT running, does it still happen?
  • zissakoszissakos Posts: 3
    How many people are still haveing problems trying to get the tool to even start after a fresh install?
    On initial start, I can see the tool window, but the mouse cursor keeps cycling.
    On any subsequent startup, I only see the black box in the lower right corner "starting up please wait".

  • JvanEJvanE Posts: 137
    Hiro Protagonist
    edited April 2018
    I just bought Nature Treks VR: I was looking for an experience in which I could just enjoy nature, have the idea I was somewhere else, and this seems to come closest to what I want. (If you know any better experiences, let me know!) However, things look a bit blurred and one reviewer said he used super sampling at 2.0 and things looked better. Now I don't have any experience with this and I wondered if the tray tool still is the best way (or the only way?) to apply super sampling...? Aren't there any other (easier) options yet...? BTW I bought the 'game' from Oculus, not Steam, and Oculus doesn't offer any super sampling options by default afaik.

    Never mind! Found the tray tool is something different than the debug tool Got it all figured out already.
  • pecocuspecocus Posts: 32
    Brain Burst
    Not sure what's changed, but in the last few days, I've noticed that OTT intermittently does not switch to Rift audio and mic.  Even manually, it won't shift.  A reboot or even a restart of OTT seems to fix it.
  • BVV.FrBVV.Fr Posts: 42
    Brain Burst
    Great. Thank you very much
  • OscarOrtizRF2OscarOrtizRF2 Posts: 1
    edited April 2018
    First of all thank you for dedicating your time to help the VR community. I have an issue with tray tool, and with all oculus environment I think, When I start OTT W10 says "Ready (warnings)" in a dark box. Should I worry about? The other problem is about SS and ASW, I use my rift just for playing Rfactor 2, a racing simulator in Steam, if I choose HMD display pixel density, I see PPI 1.37 indepently of SS, with SS 2.0 I should see PPI 2.0, right? I see 2.0 in game menu but not "in race" in race 1.37.  The other problem is with ASW, it does what it wants, if I set 45 FPS sometime is working at 45 other 90 what creates micro sttutering, I dont know what can I do, I tried delete Apollyon folder in appdata/local... Reinstall and it works the same way. Thanks in advance.
    My specs: i7 4790 - 16GB 2400mhz - Gtx 1080.
  • ApollyonVRApollyonVR Posts: 378
    @OscarOrtizRF2 You can see details about hte warning on the log tab of OTT. Most likely it's due to having power managmenet enabled on the sensors.
    Regarding pixel density, it might be that the developers are forcing it in-game, meaning whatever you set outside, e.g. before the game starts, is "overwritten" bu the game. You could try setting it to 0 in-game, if there is such an option, and see if setting it using OTT works after that.
    ASW is a beast of it's own, and again, might be that the developers are foring ASW method. Not sure about that game in perticular as i don't have it. Might be worth checking out if there's a forum for it and see what they say.
    Also, of you only use the rift for Steam games, it might also be worth checking out OpenVR Advanced Settings which is simillar to OTT but for Steam only. OTT does work for steam games but OpenVR Advanced Settings might work better for you in this case. Anyway, check it out at

  • Calimero_OeufCalimero_Oeuf Posts: 53
    Hiro Protagonist
    Hello, can explain me please, it is difficult for me to understand :
    1°) USB Selective suspend
    2°) Fresco registery tweaks
    3°) Fresco power management
    4°) Sensor power management

    I own a Fresco 4x USB 3.0 card and 3 sensors in Win7

    Should I disable 1°) and 2°) and tick 3°) and 4°) ?

    Thanks in advance !

    Ma configuration Oculus Rift + 3 capteurs et câbles longueur 5 mètres :
    Cable USB 3.0 en 5 mètres x4
    Cable HDMI en 5 mètres x1
    Répétiteur HDMI x1
    Hub USB 3.0 pour 1 ou 2 capteurs x1
    Hub USB alimenté pour le casque  x1

  • ApollyonVRApollyonVR Posts: 378
    @Calimero_Oeuf Use those settings if you are getting back screen/disconnects, they might help. If not then there is no need to touch them. But f tou ate having issues i suggest

    1) Disabled. This is tied to the powerplan so if you change that then you need to disable it again for that powerplan. 

    2) again, use if having issues and poor tracking. In raises a bufffer for the Inatack/fresco USB card. 

    3), 4) Tick the boxes. 

  • XerionXerion Posts: 51
    Hiro Protagonist
    Why is there no 1.0 setting on game profiles? The above posts suggest that setting 0 just uses the global setting but I want a global setting of 1.5 and set a specific game to 1.0, which is not possible.
  • ApollyonVRApollyonVR Posts: 378
    @Xerion I'll add this to next version, which i am currently struggling on a bit.
  • bzowkbzowk Posts: 20
    Hey Guys - 

    I just wanted to suggest a feature, please.  One of the things I use the most with OTT is the ability to edit the names and images for 3rd party library items.  When swapping the images in OTT, you may obviously add your own or choose from a few which others have designed - all of which seem to come from a single Reddit post.

    Recently, I found the tool "Oculus Home Third Party Icon Editor" which is in an Alpha stage, but under active development and fantastic!  It allows you to add your own specific custom images per title too, but where it differs is that instead of pulling images from a Reddit post, it can pull the 3rd party images directly from Steam.  No, they aren't the exact ones each app would use if purchased from Oculus if available and sometimes aren't perfect; but are much better than what Oculus adds by default for 3rd party titles.

    I haven't read all posts in this thread so I don't know if it's been brought up before, but the ability to have OTT match a title with Steam and pull the images over like this app would be great.  Perhaps a collaboration could make this somewhat painless, but who knows - just a thought.

    Thanks for your continued work!
  • pecocuspecocus Posts: 32
    Brain Burst
    @ApollyonVR   Love the tool, but wanted to ask a question.  Invariably, if the computer as been asleep, when I run your tool, it fails to switch the default audio as I've configured it to do.  I close the tool (which also shuts down the Oculus service and Oculus home) and restart the tool (thus restarting the service and software) and the audio switch is successful.  Any thoughts?   Thanks!!!

  • NetheriNetheri Posts: 247
    Nexus 6
    @ApollyonVR referring to earlier post: So if i have global SS set to 1.8 and the game specific to 1.8, is it 1.8x1.8 or does the same or higher game profile setting overdrive the global??
    [email protected], ASUS Rog Strix 2080 Super OC , Corsair 32gb 3000MHz DDR4, ROG Strix Z370 H Gaming, 2 x Inateck 4 port USB 3.0 cards.
    Natively Homeless (2.0) Dash, it's a working victory!
  • ApollyonVRApollyonVR Posts: 378
    @bzowk Sounds interessting, i actually have dormant code in there that does something simillar, but i put that on hold to fix other stuff. Will take a peek at it and see if things can be improved.

    @pecocus No, not sure what is causing that but will see if i can fnd the reason. Would be intressting to hear if the others with simillar issue can also confirm that it happens after comp has been sleeping.

    @Netheri ; No, global and profile ss don't "multiply", so in your example you should get 1.8, if the app nativly runs at 1.0.
    If the app nativly runs at anything other than 1.0 you get the multiply effect. So if the app runs at 1.8 and you set 1.8 with ott, the effect should be 1.8x1.8, depending a bit on how the developers of that specific game have done things. Use the Pixel Density overlay after setting a new option to see what you actually get.
  • DracriusDracrius Posts: 15
    @ApollyonVR I just noticed last night that global ASW is failing to set or at least set to off. I posted on Reddit and a few users have confirmed saying that they can only get ASW disabled by toggling the Global setting after an app has launched. Many of us are also having difficulty getting profiles to trigger. At least for myself it's specifically games I own through steam (both OVR and SteamVR) last I tested Oculus store games trigger fine.
Sign In or Register to comment.