Oculus TrayTool - SuperSampling profiles, HMD disconnect fixes (hopefully) - Page 51 — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus TrayTool - SuperSampling profiles, HMD disconnect fixes (hopefully)

14647484951

Comments

  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @lenne0815 That one is a bit out of my hands i'm afraid. While i don't have the Rift S (yet) it sounds really strange that there is no way of setting height or simillar. Reading though the setup process, there is supposed to be a way of setting the floor level during the setup. In Oculus 1.38 it is supposed to be done by touching the floor with one of the contollers (and pressing a button i would guess), and in Oculus 1.39 (currenly in testing) the process for finding the floor is apparently automatic, but there should also be a way of doing it manually. So i would recommend you run through the setup process again and see if there is some way of manually telling the software where floorlevel is.

    Cheers!
  • markhollismarkhollis Posts: 16
    NerveGear
    edited July 5
    hello, it's possible to add something like cable guardian?
  • TopFordTopFord Posts: 2
    NerveGear
    First off, thank you for your hard work on the program. I have been using it for quite sometime.

    I think I found a couple of bugs.

    1. Turn on Pixel Density in the Visual Hud.
    2. Set a Default Supersampling 
    3. Make a game profile with the supersampling lower then what is set in Default Supersampling.
    4. Start the game and it will use the Default Supersampling in lieu of the one in the profile.
    5. This is confirmed by the Pixel Density in the Visual Hud.

    The other one:
    1. Turn on Pixel Density in the Visual Hud.
    2. The Default Supersampling values don't align with what is shown in the Pixel Density (using Oculus Home and the Virtual Desktop). I tried numerous ones. Assuming the Left/Right viewport numbers is screen resolution, they don't alight with supersampling values either. There could also be some sort of adaptive pixel density happening as well.
      
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @TopFord ; I need the ott.log in order to check on things, so drop me PM with the log (you might need to zip in first) and then we can have a look.
  • TopFordTopFord Posts: 2
    NerveGear
    @TopFord ; I need the ott.log in order to check on things, so drop me PM with the log (you might need to zip in first) and then we can have a look.
    Just sent you a PM with the log.
  • MajorDodgerMajorDodger Posts: 3
    NerveGear
    Thank you ApollyonVR, second thing I DLed after learning how to set mine up from Oasis on YT.
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @MajorDodger ; It's my pleasure =)
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    Looking for someone with a Rift S and who is also running with a NVIDIA RTX 20xx GPU to help test some stuff.
    Even better, if there is someone with a Rift S that was previously using a GTX 10xx GPU and has upgraded to a RTX20xx GPU that would be very helpful in doing some comparisson. Just ping me here or in a PM and i'll explain a bit more.

    Cheers!
  • MeTeCMeTeC Posts: 1
    NerveGear
    Hello, thanks for the software it's a life changer.

    I currently have an issue with OTT however. It seems that when OTT is opened my VR games close automaticaly after like 30 seconds when I don't have my headset on my head. 

    Do you any idea what could cause this ? A setting maybe ?
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @MeTeC ; Sounds really wierd, i'll drop you a PM with some questions and we can take it from there.
  • AvengestAvengest Posts: 22
    Brain Burst
    this may have been asked before and sorry if it has.  I'm wondering if there's a way to use the voice commands to tie into obs when streaming.  In short i'm thinking like the xbox where you would say "xbox record that"  but instead maybe a way to say something that would put a Mark in the stream so you can easily find it later to clip.
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @Avengest Currently all voice commands are tied to specific actions like handling ASW or showing an info panel in the headset. I will however be adding custom voice commands, so you can add commands that handle all sorts of stuff like running scripts, pressing buttons, starting external apps and such. No ETA on that though as it’s a pretty big change. But it’s pretty close to the top on the to-do list. 

    Cheers!
  • AvengestAvengest Posts: 22
    Brain Burst
    @Avengest Currently all voice commands are tied to specific actions like handling ASW or showing an info panel in the headset. I will however be adding custom voice commands, so you can add commands that handle all sorts of stuff like running scripts, pressing buttons, starting external apps and such. No ETA on that though as it’s a pretty big change. But it’s pretty close to the top on the to-do list. 

    Cheers!
    thanks for the quick response and look forward to this.
  • markhollismarkhollis Posts: 16
    NerveGear
    @ApollyonVR it's possible integrate a sort of cable guardian on oculus tray tool? it's pretty useful for the rift s cable
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @markhollis That might be possible, i'll put it on the to-do list and see when i get the change to look at it. Thanks for the suggestion!
  • lenne0815lenne0815 Posts: 103
    Art3mis
    @lenne0815 That one is a bit out of my hands i'm afraid. While i don't have the Rift S (yet) it sounds really strange that there is no way of setting height or simillar. Reading though the setup process, there is supposed to be a way of setting the floor level during the setup. In Oculus 1.38 it is supposed to be done by touching the floor with one of the contollers (and pressing a button i would guess), and in Oculus 1.39 (currenly in testing) the process for finding the floor is apparently automatic, but there should also be a way of doing it manually. So i would recommend you run through the setup process again and see if there is some way of manually telling the software where floorlevel is.

    Cheers!
    Problem is - theres no way to get the controller lower than my floor, i already thought about putting it on a rope and rope it out of my window, but i would have to wait until the time of day is perfect for that :D

    It utterly weird indeed, i consider that feature as very basic, but its just not there :(
  • sherpa25sherpa25 Posts: 50
    Hiro Protagonist
    edited July 17
    Hi @ApollyonVR, currently on 0.86.2 .  I wanted to check the option under Service&Startup to 'Send Oculus Home to tray when it starts' and as soon as I click on the box it doesn't get ticked, then the app always hangs and reports 'not responding'.  I also noticed that the right & left arrow on my keyboard would no longer work.... at times then I'd get Unhandled exception error.

    Observing it for days but still happens, which means it's gone through several reboots already.

    Update: I was able to tick that option, after I first unticked 'Send OH to tray when it's minimized', then ticked it again. At least you're aware.
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @sherpa25 Get me the ott.log and i'll take a look, just PM me here or email it to me. Also, if you have hotkeys enabled then the arrow keys are the default for switching ASW mode and showing the info panels in the headset. So if that is enabled then OTT will catch the arrow keys for itself when it's running. So click configure and see what you have there, i did a change to the hotkeys that might require you to re-configure them. The Log tab should show some info on that.

    Cheers!
  • sherpa25sherpa25 Posts: 50
    Hiro Protagonist
    @ApollyonVR, ok, no issue about the keyboard.  Forgot about the mapping and just thought it had to do with the issue I was having about ticking the last option under Service. 
    I'm trying it again now and ticking/unticking now seems to work fine.  Not sure if you'd still like/need to see my ott.log, but I'll PM it \so you may see what may have caused it before.
  • sparkornsparkorn Posts: 6
    NerveGear
    ok i have an issue that ive been trying to fix for a while with uninstall/reinstalling multiple times and get the the point where everthing loads with ott and steam/steam vr with everything detected but i get no hmd image coming up on the oculus rift  . also there is the new update but the file is corrupted and unreadable for 0.86.2.0
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @sparkorn Not sure if that is related to OTT, unless you manage the Ouclus runtime service using OTT and the service is not started. In either case, i would recommend you first

    1) Reboot your PC so that all is fresh.

    2) Verify that the Oculus service is running by
    Right-clicking This PC/My Computer -> Manage -> Left-click Services and Applications in the left window ->
    Left click Services -> Find the 'Oculus VR Runtime Service' and make sure it running and if not start it. Don't worry about the service named 'Oculus VR Library Service', just leave that one alone.

    3) Start Oculus Home and go to Devices and verify that they are all green and happy. If not, try switching USB ports and see
    if that does anything.

    4) Make sure you are running the latest drivers for your graphics card. I had to update my nVidia drivers a week or so ago for the same problem.

    4) Try running a repair on the Oculus installation and see if that fixes things. I've never had to do that myself so not sure if you will need to set everything up from the beginning again.

    Also, the 0.86.2 installation package looks fine, i just tested downloading it and running it myself. It's more likely Windows SmartScreen or your antivirus that is causing that, which in turn might possbily be causing issues with your Oculus installation. So if the above does not help also try temporarily disabling the antivirus to test if that is the issue. I would not recommend keeping it disabled, it's just for testing purposes.

    Cheers!
  • sparkornsparkorn Posts: 6
    NerveGear
    ok i have gone through all these steps and even tried earlier versions of my gpu drivers around the time it was working with no luck . At one point steamvr said there was a problem with the oculus run time and i did the repair with the march 2018.exe which fixed that part but all of what you have recommended ive done . i managed to get the latest version of ott installed thanks 
  • keem85keem85 Posts: 31
    Brain Burst
    Hey. Adding profiles hasn't worked for a few years in any of your versions. I've had to edit the XML files for every game..
    Now I've been away from VR for half a year, and I can't seem to find the XML file to edit for game spesific profiles. Where is this XML file now?
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @keem85 Welcome back! No xml file anymore, i switched to a sqlite database a while ago. If you have issues creating profiles in the current release i’d like to take a look in the ott.log. So send that to me and i’ll have a look. 
  • keem85keem85 Posts: 31
    Brain Burst
    edited July 22
    Hey @ApollyonVR :) Thanks! I attached the file.. I tried to add a profile for Robinson now, right before uploading it to you, so you can see what happens, hopefully.. What happens is that when I create profile and hit "OK", nothing happens. It is as if I should have pressed "CANCEL" instead.. Very weird. I've had this issue for a couple of years afaicr. It was so easy to just edit the XML file directly instead. 

    Oh, and by the way, the working ones further up in the log, like "ETS2", it's working because I edited the xml files a while back. Those xml edited files seems to work with your new database lite version. But all new profiles that are added through your application just vanishes.
    ott.log 25.1K
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    Ok, so that looks a bit weird. If you upgraded from a really old version we probably have a compatibility issue, there's been quite a few changes. I'll send you a PM and we can check on things.
  • keem85keem85 Posts: 31
    Brain Burst
    Thanks man for your PM. The complete reinstall (and deletion of old residue files) helped :)
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    Sweet =)
  • sparkornsparkorn Posts: 6
    NerveGear
    ApollyonVR any other ideas what could be the issue ? ive gone as far as doing a fresh windows install when i found the black display issue and all your suggestions dont fix it :( 
  • ApollyonVRApollyonVR Posts: 368
    Trinity
    @sparkorn Have you tried contacting Oculus Support? Since this has nothing to do with OTT that would be your best bet. Sound like perhaps you have a defective headset or possibly the headset cable needs replacing. But Oculus Support can help you gather logs and stuff they need in order to check on that. Also, from time to time i have similar issues, even after a fresh boot, and then i simply restart tthe Oculus service (even though it's already running) and things are all good again. So if you haven't tried simply restarting the service, then also give that a go. But do contact support and they should be able to help you figure out what's wrong..

    Cheers!
Sign In or Register to comment.