New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

NO HDMI connection

hectorvallehectorvalle Posts: 4
NerveGear

Hi I just bought my oculus and I have read all the forums regarding the problem with the HDMI connection and none of them has worked. 

Here is what I have done:
The HDMI cable is connected directly to the HDMI port of the dedicated graphics. And it is plugged in firmly.
Restarted the oculus rift and restarted my computer. 
Remove the Oculus runtime and reinstall it. 
Upgraded my Graphics card. I have now NVIDIA GTX 1060 and Windows 10 64-bit. Which are the latest versions for each software.

However I am still having trouble with my rift. Apparently it says my HDMI isn't plugged in, but then it appears connected. After this it says poor tracking quality, then no HDMI connection and finally Off. Then again connected and it repeats this command all over again since monday everytime I plugged it in. It also says that my Guardian system isn't working.

I think its a problem with the cable because it says that my computer meets the system specifications for the Rift. 

Could you help me solving this problem? What can I do?

«1

Comments

  • e_m_d88e_m_d88 Posts: 372
    Trinity

    Can you try a TV or monitor that uses HDMI to rule Port on the GFX card out?

    ASUS Sabertooth Z170 S, i5 6600K. 16 gigs ram DDR-4 3000 MHZ. SSD Samsung 850 Pro 256 gigs. WD Caviar Black 1 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU [email protected] hz, Phanteks Enthoo Pro case. EVGA Supernova 750 G2 PSU. Inatech 4 port USB 3.0.  Rift + Touch.
  • hectorvallehectorvalle Posts: 4
    NerveGear
    Yes,  I tested the HDMI port with a monitor and TV and it is working, the problem is when I plugged on the RIFT.
  • e_m_d88e_m_d88 Posts: 372
    Trinity
    It sounds like the Rift plug has an issue.  Unless you can try it on a different PC.  I just got my Rift on Friday.  No connection problem.
    ASUS Sabertooth Z170 S, i5 6600K. 16 gigs ram DDR-4 3000 MHZ. SSD Samsung 850 Pro 256 gigs. WD Caviar Black 1 TB. Windows 10 PRO 64-bit. Gigabyte GTX 1080 G1, Acer Predator XG270HU [email protected] hz, Phanteks Enthoo Pro case. EVGA Supernova 750 G2 PSU. Inatech 4 port USB 3.0.  Rift + Touch.
  • ELUNO11ELUNO11 Posts: 9
    NerveGear
    Have you checked the connection on the Rift's end?
  • hectorvallehectorvalle Posts: 4
    NerveGear
    Yes I checked the connection and it is fine.
  • jet909jet909 Posts: 1
    NerveGear
    edited February 2017
    I'm having this issue right now. It was working fine for a couple weeks but now it just says the HDMI is not connected. I tried resetting everything and then tried on a different computer and got the same message.

    It must be an issue with the Oculus program because when I plugged it into the other computer my audio started playing through the headset while the page said it could not detect my HDMI.

    Update: I deleted all Oculus programs from my computer and vlc media player which I recently downloaded just in case. I then re-downloaded Oculus and it works fine now.
  • hectorvallehectorvalle Posts: 4
    NerveGear
    Mine is not working at all. Not even the audio.
  • SkScotcheggSkScotchegg Posts: 1,252
    Wintermute
    edited February 2017
    Mine is not working at all. Not even the audio.
    Did you buy it retail? What about just taking it back to the shop and exchanging for another one?
    UK: England - Leeds - - RTX 2080 - Make love, not war - See you in the Oasis!
  • SeattlestSeattlest Posts: 11
    NerveGear
    I know you said you checked the connection on the Rift end, but it is possible you need to remove the foam cushion from the headset and re-seat the HDMI connection on the Rift - an unplug and a re-plug. This can make the HDMI connection spotty.
  • AdamlWardAdamlWard Posts: 6
    NerveGear
    also check your usb connections, and maybe try swapping them around too.
  • MikeSpeak24MikeSpeak24 Posts: 31
    Brain Burst
    Seattlest said:
    I know you said you checked the connection on the Rift end, but it is possible you need to remove the foam cushion from the headset and re-seat the HDMI connection on the Rift - an unplug and a re-plug. This can make the HDMI connection spotty.
    I just put on my Rift for the first time in a few weeks and bam!!  "no HDMI connection".

     Been cracking me up for about an hour now trying to fix it. I just read your comment and had no idea the cable plugs into the headset, i thought it was permanantly wired.
     I removed the foam, pulled the cable, reconnected and i am back in business, Thanks man!
  • olpigolpig Posts: 1
    NerveGear
    Seattlest said:
    I know you said you checked the connection on the Rift end, but it is possible you need to remove the foam cushion from the headset and re-seat the HDMI connection on the Rift - an unplug and a re-plug. This can make the HDMI connection spotty.
    Been having this on and off for a few days, checked everything, updated drivers.... never thought of checking the connection at the other end. Problem solved, nice one thanks :)
  • Don-JDon-J Posts: 1
    NerveGear
    I had this same problem, cables were fine, robooted many times, reinstalled Oculus but nothing worked.
    Luckily, thanks to an excellent Oculus support service (credits to Lechlan and Eleonor) I came to find out my Graphics card drivers were outdated, so I downloaded latest drivers (with GeForce experience in my case) and my beloved Rift headset was working again! Could bump my head against the wall for not trying that earlier, so I thought I'd share it here, maybe I'm buying someone some time.
  • lordzedolordzedo Posts: 5
    NerveGear
    (NEW SOLUTION YOU MAY TRY) i have the same problem,..found many solutions on the internet but nothing work for me,..almost gave up until i found a new solution from Youtube (that video was deleted i don't know why?),..follow it and now my Rift work well,..here is what to do (first,..sorry for my bad English):
    i think there are problems between HDMI Port and Circus Board inside the Rift,..so you have to open your foam and cloth pad on your rift (google search to know how to Teardown your Rift),..you'll see a circus board on top,..there is a small Square hole above the board,..use some pieces of paper and insert into that hole to bend the circus board down a little bit (eye sensor will be disabled because when you put the cloth pad back,..the pad will always cover the sensor,..but not a serious problem),..plug in the HDMI cable and try to move your Rift to see if the error don't show anymore,..if it still happen,..then try to bend the circus board a litte bit more and try to move Rift again,..make sure the problem disappeared before put cloth and foam pad back on....hope that'll help you,..:)
  • RodierczRodiercz Posts: 22
    NerveGear
    I had similar problems with touch controlls..   I hear like 5 plug unplug usb sounds.. error messages.. and then it was working :D 
  • MorgrumMorgrum Posts: 1,656 Valuable Player
    If you have a mini display port you can use this to hook you hdmi into your system.
    https://www.amazon.com/gp/product/B00K0UDJFI/ref=oh_aui_detailpage_o02_s00?ie=UTF8&psc=1

    Since im using a gaming laptop thats how I had to do it.
    WAAAGH!
  • HoyterrificHoyterrific Posts: 2
    NerveGear
    I was able to fix my connection issue. For me it was a USB problem.

    I had the same problem with my Rift working for 5-10 seconds and then disconnecting. Then it would reconnect only to disconnect moments later. It kept saying no HDMI connection.

    My fix was to not use any USB 3.0 ports. For whatever reason my headset kept disconnecting while connected to 3.0. My headset and both sensors are now connected to USB 2.0.

    I also changed my windows power settings to not automatically turn off the oculus sensors to save power and also changed my power settings to high performance. Not sure if this actually helped.

    I also had a problem with the HDMI not connecting during setup. It wouldn't connect while my DVI monitor was connected. But unplugging my DVI allowed the Rift to work for a limited amount of time.

    My computer: 

    GPU: AMD R9 280x (I know it's below the recommended settings but it still works, saving up for a better card). 
    OS: Windows 7

  • XeXXeX Posts: 19
    NerveGear
    I has the same issue, for me the solution was uninstrall/install Oculus software and it wokrs

    GPU: 1060
    OS:W10
  • tomhsmithtomhsmith Posts: 3
    NerveGear
    XeX said:
    I has the same issue, for me the solution was uninstrall/install Oculus software and it wokrs

    GPU: 1060
    OS:W10

    I am facing this now with laptop GTX 1060 and W10. I will try to uninstall and reinstall and see if that has any effect..


  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Please reach out to us for help. Thanks.
    https://support.oculus.com/
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • BeNyOoOoBeNyOoOo Posts: 1
    NerveGear
    So I got a tricky one. (DK2)
    Got a macbook. SDK runs on Mac os X flawlessly. But I decided to hook it up with xbox to stream gameplays. So I bootcamped a partition installed windows. First I tried with the runtime 0.8. Was still working neat. Unfortunatelly I had no chance to get the xbox streaming software without the oculus app. I tried to install the oculus app I got the error message about the older runtime. (I found it weird oculus can't work with older oculus runtimes when some of the older games needs the older runtimes but whatever focusing on the project.) Uninstalled the old runtime. Than I installed the app finally. 
    I downloaded the app for streaming. Whoop-whoop. Except I can't set up my hdmi connection with the new runtime. Still whenever I swap back to osx or older runtime works perfect just have no app for the streaming. Or vica-versa. Any suggestions please? 
  • XeXXeX Posts: 19
    NerveGear
    Just in case, do you have battlefield 1 installed? did you do the bypass nvidia version check trick?

    why i'm asking that,  because i found out that modifiyng the nvapi64.dll file, gets me that problem, and i have to modify the file everytime i want to play BF1 and change it back when i want to play VR

    Hope this helps

  • danielevasidanielevasi Posts: 1
    NerveGear
    If it can help, I've solved this same problem by re-running the configuration (Configure Rift => Pair touch)
  • trek554trek554 Posts: 77
    Hiro Protagonist
    I am now randomly getting this same BS issue. Between this and Windows constantly not recognizing the USB from the headset, I am about to just sale this POS. It is either that or smash into the ground...
    Win 10 Pro | i9 9900KF | MSI Gaming Pro Carbon AC | MSI RTX 2080 Gaming X Trio | G.SKILL 32GB DDR4 3200 CL14 | Samsung Evo 860 4TB SSD | Cooler Master CM500 | EVGA SuperNOVA P2 750 watt | Sound Blaster Zx
  • duerrsduerrs Posts: 20
    NerveGear
    I have had this problem on 5 different occasions.  Each time I fixed it a different way.  Uninstalling the oculus software did not fix it this last time.  what did fix it was launching the geforce experience software.  The second I launched it, the hdmi error went away and im able to use oculus in iracing.  Im using the 391.01 drivers....I know they say not to use them and to use 388.xx but all i do is irace in vr and never had a problem with the headset lagging with 391.01.  It seems when i reinstalled the oculus software, its very laggy getting thru the headset config, could not even get thru the test your controlers bs but i just shut that down and iracing is fine.  Have not tried any other oculus games.
  • FullorFullor Posts: 1
    NerveGear
    I had similar issue. Reinstalled Windows and Rift yesterday, everything good and working and today No HDMI connection. Checked the cable, no dice. Downloaded the latest Nvidia drivers and voila it worked again. 
  • doberdusdoberdus Posts: 3
    NerveGear
    tried everything that you all have suggested, i am still not finding an answer, this is the message i get in the setup stage, when i go back to the device tab it says i need a firmware update but i cannot find out how to update it 
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    What kind of PC do you have? Can you submit a ticket? Thanks. https://support.oculus.com/
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • 1Jobe1Jobe Posts: 25
    Brain Burst
    I was getting the "HMD connected" and Warning "not connected" alot today, got sound but nothing visual. Had 125' feet of various length cables hdmi / usb , hdmi repeater junction adapters, wire mesh sleeves and nothing. Bit the bullet though. Simplicity stepped in and I lowered the bar.  3' foot extensions of usb/hdmi with simple connector , and all worked!
  • Carl_LucasCarl_Lucas Posts: 1
    NerveGear
    After sending my rift to oculus hq, and having them send me a different rift, the problem still occurred. So what I did was place my graphics card in another PCI slot, and the problem went away
Sign In or Register to comment.