New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Google Earth won't work

deadreckoning99deadreckoning99 Posts: 4
NerveGear
When I click to play Google earth, it takes about 10 seconds and it says in my headset "sorry google earth VR is taking  a while to load. If this issue Persists, please take off your headset and check this App on your PC

and then a warning box pops up on my desktop "we're unable to run on your current machine settings. Please see the known issues document linked in the store page for potential workarounds.

Error code 0
Function ovr_CreateTextureSwapChainGL"

I've tried updating my Drivers for my Headset, sensors and my PC and my Oculus home has recently been updated and I still can't play it

Comments

  • cyberealitycybereality Posts: 25,833 Oculus Staff
    You have to make sure that Rift and all monitors are connected to the primary dedicated GPU. Nothing can be connected to secondary cards or the motherboard on-board GPU. In addition, on laptop machines, you'll have to make sure you are running on the high-powered GPU, for example setting this in the Nvidia control panel 3D settings.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • deadreckoning99deadreckoning99 Posts: 4
    NerveGear
    Sorry, I don't understand. I don't have a great knowledge of GPU, motherboard etc on a PC.

    All I can say is my Rift HDMI is connected at the top of my PC tower and my Monitor is connected at the bottom. 

    Would it help if I give you my PC make and model?
  • deadreckoning99deadreckoning99 Posts: 4
    NerveGear

    I've attached a photo of my PC's model. I've highlighted the HDMI and USB port in Blue that I have my Oculus Rift attached to and I've highlighted the USB port in Red that I have my Monitor attached to.

    Is that right? all my other games works just fine. Google earth is the only one I've been having trouble with









  • deadreckoning99deadreckoning99 Posts: 4
    NerveGear
    edited May 2017
    When I click to play Google earth, it takes about 10 seconds and it says in my headset "sorry google earth VR is taking  a while to load. If this issue Persists, please take off your headset and check this App on your PC

    and then a warning box pops up on my desktop "we're unable to run on your current machine settings. Please see the known issues document linked in the store page for potential workarounds.

    Error code 0
    Function ovr_CreateTextureSwapChainGL"

    I've tried updating my Drivers for my Headset, sensors and my PC and my Oculus home has recently been updated and I still can't play it


    I don't know anything about GPU and Motherboard etc. So you will need to guide me how to fix this.

    I've attached a photo of my PC's model. I've highlighted the HDMI and USB port in Blue that I have my Oculus Rift attached to and I've highlighted the USB port in Red that I have my Monitor attached to.

    Is that right? all my other games works just fine. Google earth is the only one I've been having trouble with











  • RTdigitalRTdigital Posts: 1
    NerveGear
    edited May 2017
    Same thing here.  Just installed it 100% same issue.
    Currently have two video cards in this pc not in SLI mode and was using the 2nd video card HDMI for the Rift instead of the primary one I have my TV in.  This was the issue for me, simply used a DVI - HDMI for tv and plugged the Rift right into primary video card and is now 100% resolved.  

    I had a hunch this was the issue from the start but oddly enough several home titles worked fine.
  • elbofforelboffor Posts: 2,565 Valuable Player
    the bottom is where your graphics card goes. it should be that what you are using for all your dislay devices. if you are using the ones at the top, then they are running on your onboard graphics and thats not supported
    This is my forum signature.
    There are many others like it, but this is mine.
  • Sterling77Sterling77 Posts: 486 Poster of the Week
    Yep looks  like your plugged into the wrong port - your gcard is at the bottom.
  • flexy123flexy123 Posts: 779 Poster of the Week
    edited May 2017
    He might not even HAVE a dedicated graphics card?

    Asked differently, to start...how many HDMI (monitor) ports do you have? The one on the top of your PC, near the USB and network port is very likely not your dedicated GPU.

    You need to run both, the Rift and your Monitor on the dedicated GPU.

    **
    On your PC, right-click on your PC icon, bring up device manager and then click on display adapter so we can see what GPU you even have. And/Or upload an Oculus log, there is instructions here in the forum sticky how to do it.
  • deadreckoning99deadreckoning99 Posts: 4
    NerveGear
    Sorry about the late Response.

    My PC model is Alienware X51 R3.

    I only have 2 HDMI ports. One at the top of the Case and another at the bottom. So, I can't connect my Headset and Monitor to the same area
  • flexy123flexy123 Posts: 779 Poster of the Week
    edited May 2017
    Yes you can, you need an adapter (or different monitor cable) to connect your monitor. Your PC will in all likelihood not just have a second HDMI port "at the bottom" but also a DVI port or a DisplayPort port (which sort of looks like a USB port). So get a DVI -> HDMI or a DP -> Adapter, they are like $3. Ignore all the display related ports above which belong to the on-board GPU. You need to run all from the same, the discrete GPU, otherwise you will never get this to work.


  • Sterling77Sterling77 Posts: 486 Poster of the Week
  • irishtim1393irishtim1393 Posts: 1
    NerveGear
    I have the exact same problem, only I have just 1 HDMI port. I have an IBUYPOWER trace 930. I get the same message. Can anyone help?
  • TvVlietTvVliet Posts: 7
    NerveGear
    [SOLVED] I've been trying to fix this for WEEKS but i've finally done it:

    I went into Nvidia Control Panel -> manage 3d settings -> select earth VR (or other) -> change CUDA to main GPU, OPENGL to main GPU and Power to maximum



  • TvVlietTvVliet Posts: 7
    NerveGear
    [SOLVED] I've been trying to fix this for weeks but i've finally done it:

    I went into Nvidia Control Panel -> manage 3d settings -> select earth VR (or other) -> change CUDA to main GPU, OPENGL to main GPU and Power to maximum



Sign In or Register to comment.