New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

lens distance moves during game play

DavEvilDavEvil Posts: 3
NerveGear
Hello I've already posted on steam VR but I believe it is an Oculus issue. The message "Distance Between Lens". It pops up every few seconds on my Oculus Rift when playing shooters etc on Steam. My friend doesn't suffer this with his Rift. is there a way to tighten adjuster or do I have a defective Rift? Thanks

Comments

  • YoLolo69YoLolo69 Posts: 678
    Neo
    edited May 20
    I read several times post about it, but weirdly I never saw any pop-up message about lens distance changing, even when adjusting distance between lens on the Fly (not on the green cross dedicated menu), from Home or Steam games/apps.

    “Dreams feel real while we are in them, it's only when we wake up that we realize something was strange.” - Dom Cobb

    "Be careful, if you are killed in real life you die in VR too." - TD_4242

  • DavEvilDavEvil Posts: 3
    NerveGear
    Well, that is strange I wonder why I do?
  • flexy123flexy123 Posts: 723 Poster of the Week
    I wouldn't go by what STEAM says at first. (I've never seen this msg) Does the IPD (lens distance) in-fact change, if you check this from Oculus menu in VR? If this stays the same and doesn't actually change, it must be a problem with Steam and not Oculus or the Slider. (If the lens distance in Oculus would change, try a few times with the slider, this is not always 100% and sometimes my change on its own eg. if you knock the unit a little harder than you should. Might need a few tries to really keep the slider at the position.)
  • cyberealitycybereality Posts: 23,033 Oculus Staff
    I don't believe that is an Oculus message. At least I've never seen it, and I tried moving the IPD slider and there is no popup.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • BoneboysBoneboys Posts: 26
    Brain Burst
    This as far as I'm concerned only happens when playing games that require Steam VR to run.
    There are many posts on reedit and the Steam forums concerning this problem.

    Many have stated that it only occurs in shooter games such as Onward when brusque movements provoke the message popup.
    I do not adhere to that theory because this happens when I'm calmly sitting down playing, or flying in VTOL.
    I have both games.

    This never happens when I play native rift supported games through Steam, I therefore I do not believe it to be a hardware problem such as a loose lense slider that some have suggested but rather an over zealous Steam VR client software.

    If anyone has found a solution or trick to resolve this most annoying troublesome issue please post here, I for one would be most grateful.

    Thanks...
    Get a Grasp, get a Grip, get Rifting.
  • canoeEnthusiastcanoeEnthusiast Posts: 2
    NerveGear
    This is a joke, the message comes up every few seconds playing onward.
  • canoeEnthusiastcanoeEnthusiast Posts: 2
    NerveGear
    Does anyone have a fix for this??? The message comes up frequently while playing any game through steam. PLEASE!!!!!!!! =( makes the experience so shit.
  • Storm_CloudStorm_Cloud Posts: 712 Poster of the Week
    Contact support. I had the same problem playing Eleven, which involves a lot of quick head movement. It was something that became more frequent over time. I tried gumming it up with things like blu-tack but that didn't help. I asked if there was something in software that could disable this message but was told there was not. After several rounds of replies with support which involved making a video showing that the IPD was loose, they agreed to issue a replacement. Good luck.
  • BoneboysBoneboys Posts: 26
    Brain Burst
    edited September 11
    As far as I'm concerned this only happens when running Vive games through Steam VR, never in Steam purchased games that have integrated Rift SDK support.

    Onward and VTOL (and Eleven it seems) have this recurring problem.
    Ultrawings (Steam) does not, Assetto Corsa does not, ED (Steam) does not...
    None of the games that I've purchased on the Oculus Store have this problem.

    This is a Steam VR /Open VR problem, not loose lense adjustment.
    Make my day.
    Prove me wrong !
    Get a Grasp, get a Grip, get Rifting.
  • aerodyneaerodyne Posts: 35
    Brain Burst
    edited September 11
    Do you have steam in game overlay or notifications turned on? I've seen this before but not recently on my system.
Sign In or Register to comment.