New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Audio output only on the rift headphones

direx1974direx1974 Posts: 4
NerveGear
Hi there,

I got the Rift some days ago and everything was fine until I played "Dead Effect 2 VR". This game need Steam VR and the sound only came through my pasive Speakers. So I opened the setup of steam vr and changed the audio to the rift headphones. Everything worked, but after that my speakers are silent. Even when I reset the settings on steam vr, there is no way to get my speakers working. The sound always comes through the Rift headphones, even when I have the oculus app closed. Whe I use the windows audio setup, only the rift headphones are availible. The normal headphone plug isn't availible anymore.
Any suggestions?
Tagged:

Comments

  • GriffJGriffJ Posts: 19
    NerveGear
    Right click on your speaker icon in your systray and click 'playback devices', then select your regular speaker output in that list and click the 'Set Default' button below, and Ok.
  • direx1974direx1974 Posts: 4
    NerveGear
    GriffJ said:
    Right click on your speaker icon in your systray and click 'playback devices', then select your regular speaker output in that list and click the 'Set Default' button below, and Ok.
    That's the problem. My regular speake output was replaced with the oculus output. It's gone ...
  • GriffJGriffJ Posts: 19
    NerveGear
    Try, In 'Playback Devices' list, right click and select 'Show Disabled Devices' and 'Show Disconnected Devices'.. 
  • nalex66nalex66 Posts: 5,061 Volunteer Moderator
    Try right-clicking in the Playback Devices window and checking "Show Disabled Devices" and "Show Disconnected Devices"?
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • MrKaruMrKaru Posts: 315 Poster of the Week
    edited July 2017
    Try right clicking and clicking "show disabled devices", your speakers should be there 
  • nalex66nalex66 Posts: 5,061 Volunteer Moderator
    D'oh! Three times the same advice all typed at the same time!
    i7 5820K @ 4.25 GHz | EVGA GTX 1080 SC | Gigabyte GA-X99-UD4 | Corsair DDR4 3000 32 GB | Corsair HX 750W
    Corsair Hydro H100i | Samsung SSDs: 860 Evo 1 TB, 850 Evo 1 TB, 840 Evo 1 TB | Seagate BarraCuda HDD 3 TB
  • MrKaruMrKaru Posts: 315 Poster of the Week
    nalex66 said:
    D'oh! Three times the same advice all typed at the same time!

    Great minds think alike~

  • direx1974direx1974 Posts: 4
    NerveGear
    Thanx for your thoughts, but there is no disabled device to show up. Already tried that. I have three playback devices.
    1. Realtek Digital Output - not used
    2. Internal Speakers of my Monitor - now in use, cause of the problem
    3. Headphones - now occupied by the rift audio, it should be the realtek headphone plug, not the rift. For some reason that changed for good. There are no more otions to choos from.

    There are several NVIDIA outputs, which are not connected and not used. I'm pretty much helpless here ...
  • GriffJGriffJ Posts: 19
    NerveGear
    edited July 2017
    If you're using on-board audio output, You may have to go into your BIOS settings and re-define that you want to use the on-board audio output. There are times when installing video cards with HDMI output that the system will switch to favour the audio output of the video card / HDMI HD audio. 

    Edit:  It's a shot in the dark, I've had this issue come up in the past.. 
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Also, maybe try unplugging Rift USB cable to see if your built-in audio comes back.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • GriffJGriffJ Posts: 19
    NerveGear
    Does the sound for Rift headphones transmit via the USB or HDMI output?  
  • direx1974direx1974 Posts: 4
    NerveGear
    Thanx for your help guys. After unpluging some cables suddendly the speakers came up again. Problem gone ...
  • aschildbachaschildbach Posts: 7
    NerveGear
    The Oculus devs should stop messing with the audio. The problem is their drivers add another layer of volume and output control, audio panning, etc. in addition to what's already available in Windows.
Sign In or Register to comment.