New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Right Touch controller doesn't register if I press the "A" Button anymore

SRossiSRossi Posts: 3

did anyone already had such a problem and got it somehow fixed? I already wrote a support ticket but I fear that's a hardware failure. I'm not one of the new consumers, in fact I was a Kickstarter backer and bought/ordered the Touch asap and everything worked fine until a somewhat intensive Rez session tonight. In the middle of the boss rush, nothing worked anymore. All the other buttons seem to work fine, I've restarted the service, restarted the PC and swapped the battery of the right Touch controller but nothing helps. What makes me believe that this is a hardware failure is, that sometimes (maybe 1 out of 15), if I "flick" the button it gets registered. If I press it like a normal human being, nothing gets registered ever as far as i can check. 

If that button just gave up I am a bit scared considering that my NES controllers are still working fine and I tortured them way more :smile: . Actually, I can't remember a controller failure ever, and I had/have them all except the PS4 controller. From NES, Gravis Gampad, SNES, Master System, Mega Drive, PS1, DC, XBox, 360 (I replaced one because i used the right analog stick so much that the plastic rubbed off, still is working great on my Steam Link), XBox1 and all that I forgot; all of them are still working as they should.

I hope I can survive not playing Rez.


  • ShyningFadeShyningFade Posts: 9
    Weird that you mention it being the right one. Both the analog stick and trigger on my right touch are starting to act up, and I've had it for maybe two weeks. Kind of worrying me a bit.
Sign In or Register to comment.