OculusSetup fails — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

OculusSetup fails

gimp3695gimp3695 Posts: 2
NerveGear
Guys, I've been going back and forth with tech support for a week now and they've stopped responding to me since Sunday.

Basically when I run the OculusSetup.exe it fails and roll's back. In the Oculus Setup.log file the offending line is:

[Error] [9/7/2017 11:12:23 AM] Error getting files from manifest for oculus-runtime: Unable to read manifest 'H:\Oculus\Manifests\oculus-runtime.json'.

I've tried installing on C:\, G:\ and now H:\ a freshly formated drive using OculusSetup.exe /drive=H. During installation it downloads all required files, and starts to populate the manifests folder. I see the oculus-runtime.json and mini.json files being generated. Before it failed I copied those files out to a different folder and perfomed a JSON validation on them which passed just fine. I've looked through windows system logs and did not see anything relevant.

The OVRLibraryService.log ends with success on the previous installation package as shown below
[Debug] [9/7/2017 11:12:22 AM] Starting up OVRLibraryService v1.16.0.0.
[Debug] [9/7/2017 11:12:22 AM] Starting up.
[Warning] [9/7/2017 11:12:22 AM] IPC connection attempt failed!
[Debug] [9/7/2017 11:12:22 AM] App libraries for this user: []
[Debug] [9/7/2017 11:12:22 AM] OVRLibraryService starting in service mode.  Arguments: [install-package, H:\OculusSetup-DownloadCache\oculus-platform-runtime.zip, H:\OculusSetup-DownloadCache\oculus-platform-runtime.zip.sig]
[Debug] [9/7/2017 11:12:22 AM] IPC thread running; waiting for Oaf to connect.
[Debug] [9/7/2017 11:12:22 AM] Creating NTFS transaction.
[Debug] [9/7/2017 11:12:22 AM] Validating 'H:\Oculus\tmp\a8d9130f-b8ee-4265-a933-77a1d4eb9a97\package.zip' against signature 'H:\Oculus\tmp\a8d9130f-b8ee-4265-a933-77a1d4eb9a97\package.sig.
[Debug] [9/7/2017 11:12:22 AM] File hash for H:\Oculus\tmp\a8d9130f-b8ee-4265-a933-77a1d4eb9a97\package.zip: 78b567852327e6b1eb652f119a763165f1383626ba4f586292b3b52900acce33
[Debug] [9/7/2017 11:12:22 AM] Decrypting ciphertext signature 'XMiIdJUCu4aD1WgWne/Ty1q4XW3XN+LlHQzpkzCyGeTY85rMIXrxJrDwZbtYah/UwYkfjUKq+07c2qqGay/PjdYHGGuUoaStmgyqQScfZzR6fwlLYj3X3J9sGeTy3BsefkXST8eP+S9XeHV2QOp/BCsIBs8Cq/v3IxMjRXXoFZqgDFekCwPC7d3Q1NuOwi11JulRLR+5iTtT7ktxewSspSSTBQxxrnKHmb6qAqwAUfZUyHYIF7EBXzKihHqC8YhIiYDpYwLG8UPfTl9Wmg8uI/kGjITYabiDyL/lHv5bPDF18WxwLIPYXPw1hIIjaW3u82qp0KW+vYf0JRVbKsFuTM33cGKyXu3yaOrxqgKnssieMTF4nJyJ3ZZPSJLUgMO7SX2tDJzSrdDUICjt3Zi8ORC8lLnUyHcw90COFJeJVDDoDFtmUUinhgqzw5QshnpBq8zw3uGXr6XXWt/wX78iZNA+cEJlbilBjuVwTojVrbxJH10Heb25kZeDLMjlGvd9oj6+ll+8Fk1MKcbO8i2ya+3iatv3zCYQTtLlogBq0WQglAeg0zpv/Hh+xA27t6EHjKfXKvKdc0RCYRtwoNr5ngzBJzDlM/Sq1vGTZshlG0SN2g2GMEkPYWUSZbLdskkOf3gqEGU5aBZXdW4d1nGTV/DxzLAypl6WJRMo9V8dP7s=' with primary key.
[Debug] [9/7/2017 11:12:22 AM] Decrypted plaintext signature '78b567852327e6b1eb652f119a763165f1383626ba4f586292b3b52900acce33'.
[Debug] [9/7/2017 11:12:22 AM] Ding!
[Debug] [9/7/2017 11:12:23 AM] Loaded manifest for 'oculus-platform-runtime' version code 631
[Debug] [9/7/2017 11:12:23 AM] Deleting directory 'H:\Oculus\tmp'.
[Debug] [9/7/2017 11:12:23 AM] Deleting directory 'H:\Oculus\tmp\a8d9130f-b8ee-4265-a933-77a1d4eb9a97'.
[Debug] [9/7/2017 11:12:23 AM] Committing changes.
[Debug] [9/7/2017 11:12:23 AM] Exiting with code 0 (Success).

Then nothing else.

Any thoughts? I haven't seen anybody with this problem yet.

Thanks in advance!

Tagged:

Comments

  • gimp3695gimp3695 Posts: 2
    NerveGear
    Wow, FINALLY. Got it figured out.

    I had to completely remove windows firewall service. I couldn't just stop it. I had to disable it in windows service manager. Restart the computer and then install.

    Nothing like downloading the 2 GIG install package probably 30 times in the last week. I hope this helps somebody in the future.
  • YoeyYutchYoeyYutch Posts: 13
    NerveGear
    Thank you very much. I'd put an exclamation mark at the end of that sentence but I'm too exhausted from going to war with Windows over this. I did disable the Malwarebytes service as well so I can't be 100% positive that the firewall caused it. Thanks for pointing me in the right direction regardless. Cool. I get to push 'Next' now... Next battle... Fight!
Sign In or Register to comment.