Oculus Video won't play purchased movie on my rift — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Video won't play purchased movie on my rift

74Loki74Loki Posts: 31
Brain Burst
So I figured I would check out how a 3d movie looks in rift. Bought a movie from Oculus Video and figured that I would be able to download it to my PC and then play it. Nope, stream only. Which, I mean come on, I bought the thing! Would have been nice to know that before I bought it, thanks oculus for the heads up there btw.
Anyway, I go ahead and hit the stream button, being left with no other option. "Getting ready to play your video", comes up on screen and that's it. After about 5 minutes I start thinking it's taking a while but I continue waiting patiently. I think maybe it just needs to load so much of a cache before it starts or something. After about 10 minutes I'm sick of waiting and take the headset off and cover the sensor so that maybe eventually the thing will start playing. I went back to reading a book for about an hour and it still says it. I've tried this a few times but to no avail. This just will not start playing the movie I bought!
Tagged:

Comments

  • HailStorm32HailStorm32 Posts: 3
    NerveGear
    I too have the same problem. Has anyone found a solution?
  • 74Loki74Loki Posts: 31
    Brain Burst
    I saw Oculus Video pushed out an update tonight so I tried streaming the movie afterwards and it now works. Whatever they did fixed the issue for me. I'm still not terribly happy that streaming is the only option but it at least does that now.
  • mike.j.stonemike.j.stone Posts: 2
    NerveGear
    Same problem.
Sign In or Register to comment.