Nvidia drivers and Oculus Rift head tracking stutter / judder — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Nvidia drivers and Oculus Rift head tracking stutter / judder

SitruzSitruz Posts: 66
Hiro Protagonist
Just an information piece really. I've been using Nvidia's 388.00 drivers to date, 388.13 & 388.31 have given me really bad head tracking stutter inside the Rift. So much so that it makes it totally unplayable without making me feel sick. 

Just hoping anyone with the same problem will come across the title of this post as it might help them out if they've updated drivers and not thought to roll back.

Also it's worth deleting the temporary driver folder C:\NVIDIA\DisplayDriver\... (driver version) as Windows 10 keeps taking it upon itself to reinstall the bad driver again on mine if I leave the new extracted driver in that temp install folder.

Comments

  • f1iceman07f1iceman07 Posts: 40
    Brain Burst
    edited November 2017
    do you have after burner or anything like that theres another thread here called rift stutter.
    you can turn the power monitor off if you do have it, see if that helps.

  • f1iceman07f1iceman07 Posts: 40
    Brain Burst
    heres the link thats has some thing for you to try out and especially the geforce experience one.
    https://forums.oculusvr.com/community/discussion/59001/rift-stuttering/p1
  • DaftnDirectDaftnDirect Posts: 4,789 Volunteer Moderator
    edited November 2017

    Hi @Sitruz, Windows will download updated drivers whether that NVIDIA folder is there or not. There's a way though to prevent driver updates via the Control Panel/System/Advanced System Settings, Hardware tab, Device Installation Settings.

    Or a better way is Microsoft's Show or Hide Updates tool, which will allow you to temporarily block individual updates rather than all driver updates. I haven't used either method for a while as I don't seem to have any issues with the latest drivers.... touch wood!!


    Intel 5820K OC@4Ghz, Titan X (Maxwell), 16GB Corsair Vengeance DDR4, ASRock X99 Taichi, Samsung 500Gb 960 Evo M.2, Corsair H100i v2 Cooler, Inateck KTU3FR-4P USB 3 card, Windows 10 Pro v1903 (18362.239)
  • SitruzSitruz Posts: 66
    Hiro Protagonist
    heres the link thats has some thing for you to try out and especially the geforce experience one.
    https://forums.oculusvr.com/community/discussion/59001/rift-stuttering/p1

    Thanks Iceman. Yeah there was a few bits in there I've disabled like the overlay. Yes I am using Afterburner as well so I might try and update to 388.31 now and see if that's made any difference.
  • SitruzSitruz Posts: 66
    Hiro Protagonist

    Hi @Sitruz, Windows will download updated drivers whether that NVIDIA folder is there or not. There's a way though to prevent driver updates via the Control Panel/System/Advanced System Settings, Hardware tab, Device Installation Settings.

    Or a better way is Microsoft's Show or Hide Updates tool, which will allow you to temporarily block individual updates rather than all driver updates. I haven't used either method for a while as I don't seem to have any issues with the latest drivers.... touch wood!!



    Thanks @DaftnDirect. Yeah I found that this morning when it updated again with any involvment from me. I found that Device Installation Settings on some page somewhere and I've done that. Just waiting to see if it affects.

    I do like to run the latest drivers where possible, so want to try 388.31 again to see what happens now I've disabled the Overlay.

    Cheers.
  • SitruzSitruz Posts: 66
    Hiro Protagonist
    Well I made sure Device Installation Settings were set to don't update my shizz, but it still did it anyway. I cannot figure out why Windows thinks its knows better than me. I've DDU's these crappy 388.13 drivers so many times now.

    Is there any definitive way to stop Windows 10 automatically updating my Nvidia driver?  
  • MAC_MAN86MAC_MAN86 Posts: 2,262
    Wintermute
    The October NVIDIA Update caused glitching. Rolling back to previous July Driver worked. I don't have the 38* version numbers as they don't state them in the Device Driver!
  • SitruzSitruz Posts: 66
    Hiro Protagonist
    How do you stop Windows from constantly updating you to a newer version though. I wan to stay on the 388.00 driver as its perfect for me and gives me know head tracking issues whatsoever, except with Arktika.

    Which July driver are you on out of interest?
  • TheGamesCriticTheGamesCritic Posts: 41
    Brain Burst
    I have been going crazy with my USB drivers, uninstalls, etc thinking it was JUST ME! I NEVER had these issues before. Last good date I used Oculus was when Star Trek Bridge Crew came out...after reinstalling windows (CLEAN and all drivers UP TO DATE including NVIDIa)  and reinstalling Oculus - I too experience these same head-motion PICTURE jumps (stutters?)! It's not like a left-to right constant stutter - but rather the picture will JUMP up and down slightly...ever so slightly when I look behind me (rotating my head to the left) and then look directly to my left in an attempt to face forward. It's so strange and a huge immersion killer for me.

    Are you mentioning this as stutter OP? What I mention????

  • UBSERDUBSERD Posts: 348
    Nexus 6
     Go to this link at the bottom to bring you to this magical forum post.  Look at the comment from aisepos! His suggestion actually fixed everything. Oculus has never suggested this but now they will. This man is a genius and he actually figured out why I was having my problems... all 6 months of them.  I can’t guarantee it’s a cure all but I hope this helps you too and give him a shout if you see him. He is a God!!!! 

    Thanks to everyone in their suggestions if they are reading this. I really appreciate all the help and working together to figure out these things for the community.

    See you in the Rift!

    https://forums.oculusvr.com/community/discussion/58073/poor-tracking-quality-audio-glitches-lagging-etc-after-half-hour-of-use#latest
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    edited January 2018
    No, playing aroud with your XMP settings doesn't help (as you already found out yourself in that other thread).

    It's clearly related to NVidia drivers. To me, I had to roll back to 384.94 to get totally rid of all jutters and stuttering. Just as the OP said, the stuttering introduced by newer NVidia drivers feels like it's coming from the tracking... not video performance related. This is the exact stuttering I experience with newer NVidia driver. If I roll back to July/August drivers, the stuttering disappears COMPLETELY!

    So, it's clear that the problems are caused by NVidia drivers. The question now is: What can we do against this? The problem is clearly visible in the current driver release and was already visible in previous NVidia builds. It is NOT mentioned in the KNOWN ISSUES section of the drivers, although the net is full of complaints.

    If you want to experience a buttery smooth Oculus Rift experience, roll back to 384.94, where there's ABSOLUTELY NO STUTTERING AT ALL. Then come back to the current driver and you'll see the difference instantly.

    You can find previous NVidia drivers here:
    http://www.nvidia.com/Download/Find.aspx?lang=en-us
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
Sign In or Register to comment.