New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Stamps grayed out

peachlabpeachlab Posts: 7
NerveGear
 I've been having this issue where whenever I try to import an fbx or obj into stamp format, the stamp in the tool bar looks completely grayed out like how you see in the image i attached. If I try to stamp it into the scene, it works fine, but it's annoying that I cant see what I am choosing in the tool bar because it's grayed out. This never happened before. It used to import fine, but cant seem to understand why it started happening recently...

Comments

  • MattHickmanMattHickman Posts: 335 Oculus Staff
    Yeah sorry about that one, if your mesh doesn't have normals it comes in unshaded like that. We're working on auto-generating them for you but that will be in a future update. If you take them into Maya or Blender or something along those lines and have it generate normals for you, you should be good to go.
  • SassySassSassySass Posts: 3
    NerveGear
    I am also having this issue. I don't think it's a normals problem as I have tested exporting obj from Modo, Houdini, Zbrush and 3D Builder in Windows. All with same greyed out unshaded stamp imports. Also tested FBX with same results. It seems like it's a Medium import issue.
  • MattHickmanMattHickman Posts: 335 Oculus Staff
    Hm, assuming the normals are there it should be loading properly, can you send an example over for us to look at?
  • SassySassSassySass Posts: 3
    NerveGear
    It looks just like the first 2 stamps in peachlab's pic above. It's not making proper previews or something. The stamps seem to work fine but it's hard to see what they are when they are unshaded in the menu. It does seem to be working properly for me importing to reference meshes. Exact same model imported as a mesh in reference meshes shows shaded properly in menus and looks correct.
  • MattHickmanMattHickman Posts: 335 Oculus Staff
    We've only been able to reproduce the issue on meshes that don't have normals. It seems consistent. If you're seeing the issue pictured above on meshes you're sure have normals that would be something we'd like to have a look at if you encounter it again.

    The reason why the reference mesh or the preview for the stamp might look odd but the stamp itself or when you convert to clay looks correct is simply because those previews are meshes and the other instances are converted into our SDF format and we dump all the mesh data and generate our own at that point. 
  • SassySassSassySass Posts: 3
    NerveGear
    I can't seem to get this to work no matter what objs I import exported from any of the many 3D apps I have. Can you provide me with an obj that you can successfully import in the current Medium version and shows properly in the stamps preview and menus? One you know imports properly for you with current Medium version will at least tell me if there is something weird just with my setup.

    Also when I use any stamps I've imported the ghosting on the brush looks grey and when you turn it and look at the other side it slowly turns green. All the stamps that come with Medium look greenish no matter which way I turn them.
    I've tried flipping normals in apps, making them double sided etc. No matter what I try in any app I can't seem to get it to work.
    I've tried deleting app and removing preferences before reinstalling and that didn't help. I have tried importing many objs from many different sources, not just ones I've made myself, all with same non shaded results. I'm not sure what is going on.
  • MattHickmanMattHickman Posts: 335 Oculus Staff
    Here's an OBJ from outside Medium that has a proper thumbnail and imports correctly when brought in as a ref mesh, we are looking at a bug around why normals are getting stomped on import as a stamp. 
Sign In or Register to comment.