New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Voicemeeter and Oculus - No Game Audio

JerryAtricksJerryAtricks Posts: 5
NerveGear
Hey all! So I'm trying to set up my Oculus with Voicemeeter. I've followed almost every tutorial out there but I've run into a frustrating issue. I can hear the audio from the Oculus Home screen through Voicemeeter but when I play any games there is no audio. I'm watching all these setup videos saying "Do it like this and it will work" only to have it not work and I have no idea what is wrong. 

What I've done:

Windows:
Set default Audio Playback Device to Voicemeeter Input (VB-Audio Voicemeeter VAIO)
Set default Recording Device to Voicemeeter Output (VB-Audio Voicemeeter VAIO)

Oculus:
Settings > Devices > Rift > Audio Output in VR > Windows Default 
Audio Input in VR > Rift Microphone

Voicemeeter:
Hardware Input 1 > Microphone Rift Audio
Hardware Input 2 > Cable Output (VB-Audio Virtual Cable)

Any info would be greatly appreciated.

Thanks!

Answers

  • DevilsNipsDevilsNips Posts: 34
    Brain Burst
    hmm, i use voice meeter sometimes. is your HW3 set to rift audio device aswell?
  • JerryAtricksJerryAtricks Posts: 5
    NerveGear
    hmm, i use voice meeter sometimes. is your HW3 set to rift audio device aswell?
    It is not. I can only use one HW input for the Rift microphone. 
  • Mace404Mace404 Posts: 208
    Nexus 6
    edited January 17
    You are missing your hardware outputs in Voicemeeter. On the right side, under A1 select your default speakers, under A2 select your Rift headphones. (Kernel streaming will give lowest latency - I have mine set on 160 samples. 128 gives a bit of crackle)
    Keep in mind that the Oculus software will take exclusive control of the Rift audio device, so best is to close the Oculus software, select the Rift under A2 hardware device in Voicemeeter and then start the Oculus software.


  • JerryAtricksJerryAtricks Posts: 5
    NerveGear
    Mace404 said:
    You are missing your hardware outputs in Voicemeeter. On the right side, under A1 select your default speakers, under A2 select your Rift headphones. (Kernel streaming will give lowest latency - I have mine set on 160 samples. 128 gives a bit of crackle)
    Keep in mind that the Oculus software will take exclusive control of the Rift audio device, so best is to close the Oculus software, select the Rift under A2 hardware device in Voicemeeter and then start the Oculus software.


    No, I have my outputs connected. As I stated in my OP, I can hear sound when I am in the Oculus Home lobby but when I load into the game "Air Car" I have no audio. In some other applications such as Google Earth I have audio so it must be just that game. Weird.
  • JerryAtricksJerryAtricks Posts: 5
    NerveGear
    I realize I said "any game" in my OP, so far it's just been Air Car. My bad.
  • Mace404Mace404 Posts: 208
    Nexus 6
    You only write that you set hardware inputs in Voicemeeter, not outputs.
    You can still have sound in Home/Dash because of the exclusive control. That's why I mentioned its best to close everything Oculus first before starting/setting Voicemeeter.


  • JerryAtricksJerryAtricks Posts: 5
    NerveGear
    Yeah, sorry. I guess I just thought it was a given considering I said I could hear audio.

    So you're saying to start Oculus first then Voice Meeter?
  • Mace404Mace404 Posts: 208
    Nexus 6
    Other way around. Start Voicemeeter first (so it can take exclusive control) and then Oculus
  • PTBBBassManPTBBBassMan Posts: 8
    NerveGear
    I have a similar problem with my setup.  Since the last updates I have the following issues.
    1. With voicemeeter setup of A1input -rift microphone     A1 output  rift audio  A2 ouput Asus Xonar   A3 ouput  onboard realtek audio card.  Voicemeeter is set as default sound card.
    I can launch Assetto Corsa in single screen and everything works great.
    I can launch AC in vr and no sound at all at any output. In fact I can't even launch a race successfully as it crashes back to the main menu.  This occurs with both the standard app and Content Manager.

    If I close down voicemeeter and set the rift audio as the default sound card, I can then get AC to run properly in both the standard app and Content Manager.

    So, with all that said,  is there anyone out there with similar issues? Any solutions?
    thanks
    Gigabyte Z170 mobo, i7-6700, 16gb ram, GTX 1080 ti, OSW DD 20nm wheel, Fanatec F1 and Bmw GT rims, Fanatec V3 pedals, Fanatec Shifter, Fanatec handbrake, 2 DSD button box panels, Oculus Rift CV1, 2 wind sim fans, Thrustmaster T16000 hotas with pedals, GT Omega Pro cockpit, Simshaker Jet Seat
Sign In or Register to comment.