Tuscany Demo: Stuttering & low fps — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Tuscany Demo: Stuttering & low fps

spyrospyro Posts: 339
Art3mis
edited April 2013 in Support
Hi there,

just tried out the Tuscany Demo. When moving arround, I got about 2-3 'stutterings' per second where the framerate drops from 60 down to 42-48 (it doesn't matter if I use my head or my controller). It can also easily be seen on my second screen. Reminds me of the problems with Darksiders 2 where I needed a frame limiter to get this working without flaws. Am I the only one with this problem?

My System:
- Phenom II 920@3,4 GHz (4 Cores)
- 6 GB RAM
- GeForce 560 Ti
- Win7x64

Comments

  • articulitearticulite Posts: 30 Oculus Start Member
    I'm also having stuttering and pulling only ~40fps average on my Alienware M11x R1. Granted, it's on the lower end of powerhouse laptops, but I wasn't expecting this. Upgrade coming soon hopefully that will remedy the situation. It only happens in the Tuscany Demo though so I'm curious to see what the response to this thread is.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Is this on the Unity demo? Can you try the C++ WorldDemo and see if that shows the same problem?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • spyrospyro Posts: 339
    Art3mis
    No, it seems that all Oculus-ready Unity demos have terrible performance (usually below 60 fps on a overclocked GF 560Ti). The native Word Demo runs very smooth. Just can't it play more than 2 minutes because I feel really sick when moving around. :(

    spyro
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Few questions:

    - What resolution are you running the demos in? You may want to select 1280 x 800 (it might default to something higher).
    - Are you running the executables or testing in the Unity editor. It may be choppy in the editor game window.
    - Can you check your Nvidia control panel settings? Specifically "Manage 3D settings"->"Mutil-display/mixed-GPU settings" should be on "Multiple display performance mode".
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • mdkmdk Posts: 356
    Seems a bit weird. I don't have a rift yet, but the Tuscany demo with hydra controls runs at the maximum 60 fps with a 5760 x 1080 resolution on my machine. I have a GTX 590, but at least with my own Unity 3 demo I've noticed that it doesn't use SLI at all. So that demo Is basically running with a GTX 560 on my computer unless Unity 4/Tuscany demo has better SLI support and can use the second GPU. Even so the demo seems very light and I imagine it would run at 60 fps on pretty much any relatively new card especially with the Rift's resolution. Even my own demo runs pretty well considering it's an unoptimized mess that throws all manner of image effects on screen with extremely highpoly models. There is something fishy going on here for sure.
  • spyrospyro Posts: 339
    Art3mis
    Few questions:

    - What resolution are you running the demos in? You may want to select 1280 x 800 (it might default to something higher).
    - Are you running the executables or testing in the Unity editor. It may be choppy in the editor game window.
    - Can you check your Nvidia control panel settings? Specifically "Manage 3D settings"->"Mutil-display/mixed-GPU settings" should be on "Multiple display performance mode".

    - Demos are running in native resolution with fullscreen actived
    - Only compiled versions, not inside the Unity demo
    - Other display is completely deactivated
    - No V-Sync (just for testing)

    spyro
  • spyrospyro Posts: 339
    Art3mis
    I could solve the problem: It was in fact the powermanagement of the CPU which caused this strange problem. Thanks for your help. Enjoying now my new housing in the Tuscany :)

    spyro
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Can you be more specific as to what settings were causing the problem and what you did to solve it?

    It will be helpful for others who may encounter the same issue.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • spyrospyro Posts: 339
    Art3mis
    Ok, my processor reduced his frequency way to fast from 3.4 GHz down to 400 MHz and needed far to long to increase it again back. As this happened several times per second this produced many framedrops. I changed the power profile in windows to "high performance" and they removed instantly.

    I was actually recording a video with FRAPS to show you this effect when I noticed that all the problems were gone as long as I was recording... :D

    spyro
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Awesome. Thanks for following up on this.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.