New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Oculus Won't Download - "Failed to Install App Manager"

I got the message "failed to install app manager" when trying to install the app from the setup wizard. Please help, I've looked it up everywhere searching for a solution and can't find anyone else who had the sane problem.

Best Answer


  • ctz9ctz9 Posts: 1
    I am having the same problem with my Gear VR. It would be nice to have the answer to this.
  • antwainrayyantwainrayy Posts: 2
    Same here Note 5. Factory reset does not work for me. Tried installing before any other App could install. No luck! Help!
  • antwainrayyantwainrayy Posts: 2
    Figured it out. follow this link..All i needed was the bottom link. Fixed my issue.

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Can I ask what phone carrier you use and in which region?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • KrashwardKrashward Posts: 1
    I have a Galaxy S8+. I had tried everything from uninstalling Facebook then reinstalling it to deleting old Oculus files on the sd card. I did a factory reset and then installed the Oculus app and other tools without the sd card in the slot by plugging the phone into the Gear VR. Now my phone works with the VR.
  • Okami_Es7Okami_Es7 Posts: 2
    edited September 2018
    I am in same boat with s8.. i try to download anything in oculus store and it just sits at 0% then later says download failed... cant seem to find some legit help anywhere other then a few shady third party hacks from a year ago.. completely ridiculous this has no clear solution yet

    **EDIT** I may have found a solution for myself.. there was an ad blocker i was using, once removed new downloads started to work.. the old "not installed folder" ones still failed but now seem to be starting to work also.. can now confirm this appears to have been my issue a "third party ad blocker"
Sign In or Register to comment.