New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Oculus stays black after removing from head and putting it back up

wm79wm79 Posts: 12
NerveGear
Hey guys, since a few days, when I play Project Cars 2, remove my headset ingame and put it back on, it stays black. The sound works, the LED in the rift is blue/white (whatever color this is) but there is no picture. When I quit the game I cannot start another VR App, the Rift will stay black. I have to restart the Oculus service in order to restore the screen. Any clues?

Comments

  • ChazmeisterChazmeister Posts: 426
    Trinity
    I'm getting this quite bit recently too. I think it's probably a driver problem rather than a hardware one, as a reboot of windows usually clears it. I suspect one of the recent updates either to Win 10 or Oculus Home has caused it.
  • Draco_Draco_ Posts: 5
    NerveGear
    edited February 11

    I’m having the same problem started after the last Oculus update. Tried updating all drivers to the latest version but I’m still getting this problem. This also only happens when you are playing a game if you are in your home you can put on and take off your headset at any time without a problem.

    It isn’t a USB power save problem sound and mic still function and I have power save disabled on my USB ports.

    AMD Ryzen 7 1700 Eight-Core Processor (16 CPUs), ~3.3GHz
    Asus Crosshair VI Hero
    NVIDIA GeForce GTX 1060 6GB
    Memory: 32768MB RAM
    .

  • General_PapabearGeneral_Papabear Posts: 2
    NerveGear
    Draco_ said:

    It isn’t a USB power save problem sound and mic still function and I have power save disabled on my USB ports.

    I'm having a similar problem and I suspect it has to do with USB power save. Where would I find that option?
  • LZoltowskiLZoltowski Posts: 5,401 Volunteer Moderator
    You can try re-setting your display adapter in Windows

    CTRL + SHIFT + WINDOWS BUTTON + B on your keyboard, your monitor should black briefly.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • cyberealitycybereality Posts: 25,395 Oculus Staff
    If you're on Nvidia, you must use driver 388.59. Newer drivers may cause black screens and other compatibility issues. Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • Draco_Draco_ Posts: 5
    NerveGear

    This issue was occurring before I updated the drivers. Pre-driver update they were 388.59 and rolling them back to that has made no difference.

    Again, this happens only when you launch a game if you stay in the Oculus home 2.0 you can leave your headset off for hours if you like and put it back on and the screen turns on. If you launch a game and take the headset off for a minute it goes into standby and won’t come back on.



  • SabrejetSabrejet Posts: 56
    Hiro Protagonist
    edited February 14
    Are you using Oculus Tray Tools?  The most recent one was most likely the cause of mine doing this.

    Edit:   I was wrong... after a 5 day break, it started up again.
  • Draco_Draco_ Posts: 5
    NerveGear
    edited February 15

    “CTRL + SHIFT + WINDOWS BUTTON + B on your keyboard, your monitor should black briefly.”

    Doesn’t work

    “Try restarting the Oculus service (not the app) rather than rebooting the PC. In the desktop app, go into Settings/Beta, and select Restart Oculus”

    Not only does it not bring back the video it also stops the sound from working.

    Built a second machine with the same specs installed everything from scratch. Worked for a day then the same issues started to happen.

    Only thing installed is Windows 10 Pro and Oculus no other third party programs associated with Oculus.

    So two machines same problem.

  • MradrMradr Posts: 2,469 Poster of the Week
    edited February 15
    Possible a driver issue still... or could be something wrong with the headset. I would recommend at this point creating a ticket with support and see about getting the ball rolling with them on what they want to do. Might include this thread so they can see what you have done and tried already.
Sign In or Register to comment.