New To The Forum? Click Here To Read The How To Guide. -- Developers Click Here.

Experiencing some lags/stutter in games/apps. Laptop gtx 1060. Is hardware the problem?

believrbelievr Posts: 6
NerveGear
Hey there, non-native english speaker here.

First, let's see if the problem is my specs?

  • It's a Laptop
  • i7 7700 HQ 2.8 GHz
  • 32 GB RAM
  • GTX1060 GPU
  • headset pluged in usb 3.0 (but says 2.0) - using an usb 3.0 extension because the usb close to the HDMI is under an Asmedia controller with compatibility issues
  • 1 sensor in usb 3.0
  • 1 sensor in usb 2.0
  • it was expensive (I'm in Brazil)
Driver
  • Nvidia driver 390.77
Secondly, what I've already tried:
  • Set windows settings to performance over quality
  • Disabled USB power saving in windows settings
  • Went to Devices panel and turned off USB power saving option in every USB device possible
  • Disabled windows defender while playing/working (I have no other anti-virus)
  • I have no recording apps or anything with overlay issues that I've read about
  • Disabled game overlay in GeForce Experience
  • Set performance option in Nvidia Cotrol panel
So, what's happening?

I'm trying to work with archviz and chose Unity to do it. I was experiencing some stutter while testing what I was doing and I thought it  was something related to mesh optimization, texture packing and other things. It kinda is but then I started looking elsewhere, like the Oculus app and the Robo Recall game.

The thing is, while trying the Oculus home screen I experience some kind of lag/stutter when I move my head around. It doesn't happen every time (I read someone say micro stutter). It doesn't make it unusable, but it's noticeable and annoying. It also happens in Robo Recall. The game plays well, but like I said, if you try to see the problem you notice it. If you play the game, in the middle of the action you might not see it.

I debugged my app and saw the FPS over 100 frequently. I profiled it and saw frame drops, but couldn't explain to myself what the profiler was saying (the Oculus profiler).

The hard truth I think is that I made a bad choice by choosing a laptop that is not a crazy awesome (and expensive) one.

Not willing to believe in the hard truth... what might be the problem here? I'm going crazy reading a lot in the foruns trying to fit my problem in, but everything I tried based in other people problems are not working.

Did I really messed up by choosing a laptop or is something else?

Best Answer

  • believrbelievr Posts: 6
    NerveGear
    Accepted Answer
    Discovered that the problem might be related to sensor misconfiguration and turning my head back and blocking the headset. Despite me being the problem, there's still a left to right movement that shows some stutter, but most of the issues is me being taking a lot of time to notice something that is logical.


Answers

  • InachuInachu Posts: 37
    Brain Burst
    Hope your laptop drive is a SSD drive and not a spinning one.   
    Optimize your windows operating system.  When was the last time you did any major clean up on it?
    major clean up like emptying all temp folder data trash
    from windows folder and from c:\users\name\appdata\local data\temp

    Other obvious things is to remove stuff you no longer use on the laptop.

  • believrbelievr Posts: 6
    NerveGear
    edited February 13
    Inachu said:
    Hope your laptop drive is a SSD drive and not a spinning one.   
    Optimize your windows operating system.  When was the last time you did any major clean up on it?
    major clean up like emptying all temp folder data trash
    from windows folder and from c:\users\name\appdata\local data\temp

    Other obvious things is to remove stuff you no longer use on the laptop.

    Hi Inachu, I forgot to mention that the laptop is new. It came with Windows 10 Home installed and all the drivers.
    And yes, I have a M.2 SSD drive.

    Here's what's installed:

    Anything on the list that should go away?

    Edit: forgot to mention that I have SSD.
  • falken76falken76 Posts: 2,578 Valuable Player
    Try the previous drivers by Nvidia.  388.71.  390.x does have issues on some peoples hardware currently.  Also, if you are in Beta, try opting out of it and see if it runs more stable.
  • believrbelievr Posts: 6
    NerveGear
    edited February 13
    Hi falken76.

    I tried the driver, but it didn't solve the problem. :(

    Edit: not in Beta.

    Thanks, anyway.
  • cyberealitycybereality Posts: 26,101 Oculus Staff
    Your computer should be powerful enough. I think it's the issue of a driver conflict or incompatibility. First, be sure to be on Nvidia driver 388.59 (this is the most compatible one right now). You may have to uninstall current driver with DDU clean mode uninstall in order to revert. Next, check your USB drivers. This is the main cause of tracking stuttering. Your motherboard / laptop maker may have newer USB drivers on their website. 

    If that doesn't help, see if you can test the headset with only 1 sensor connected at a time. If it doesn't work at first, try different USB ports (USB 2.0 extension cables can help in some cases). If you get it working, try the 2nd sensor by itself on that same port. It's possible one of the sensors is damaged and causing the issue. If both work, then you know it's probably something related to the headset itself, or the cable, or the USB port it's on, etc.

    In any case, please feel free to submit a support ticket for troubleshooting assistance. Thanks.
    https://support.oculus.com/
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • lightmare361lightmare361 Posts: 14
    NerveGear
    edited April 14
    were you ever able to resolve your issue? I have the exact same computer
  • Sharkster-NVRSharkster-NVR Posts: 74
    Hiro Protagonist
    edited April 17
    @lightmare361 @believr - You guys should try 384.94 drivers. These fixed the described issues for us entirely. Also, check out this thread with more info regarding the micro stutters and jitters: https://forums.oculusvr.com/community/discussion/62663/how-nvidia-ruins-the-oculus-rift-experience/p1
    ERAZER X7849 Notebook - CPU: Intel Core i7 6820HK - GPU: GTX 1070, 8 GB GDDR5 RAM - RAM: 32 GB (4x 8 GB DDR4 HYNIX PC4 17000 DUAL CHANNEL) - MAINBOARD: INTEL HM170
  • MAC_MAN86MAC_MAN86 Posts: 1,016
    Neo
    Yes use DDU in Safe Mode which is awkward to find. Hold SHIFT + click Restart, then cancel the ISO repair on reboot, Advanced, it reboots, select Other Options then Safe Mode "4". Once used DDU reboot again once basic driver installs (can set res here), then finally install the 384.94 driver found also on DDU website an extract. I instead use the Microsoft way of Upgrade Driver rather than running the Setup file to avoid Experience and Audio added. I still must remove 3D drivers but you still get VulkanRT which I believe LONE ECHO requires.
  • MAC_MAN86MAC_MAN86 Posts: 1,016
    Neo
    edited April 18
    It came back. I discovered it was my gpu overclocker new version EVGA PrecisionOCX.
    The problem goes away totally if I do not use it. I will revert to the older version PrecisionX16.
  • MAC_MAN86MAC_MAN86 Posts: 1,016
    Neo
    edited April 19
    However, I have finished my testing for Judders I had in E:D now solved.
    RESULT: It was EVGA PrecisionXOC which makes use of the Pascal power of my GTX1080
    This is my overclock/fan control monitor. I had actually been using this in full KBOOST mode always because in my understanding since earlier versions I needed this program open to get my fans to run properly rather than my old GTX970 sat idle too much before over heating. e.g. E:D used to crash when exiting from H-Jumps to Stars without this program running a Custom Fan Profile to get the fans running earlier. In my mind I thought I had to select KBOOST to get the Factory Preset OC2 speeds/settings. Actually, (it does now say in tips) this button it ONLY for Benchmark Stress Testing as it puts the card in overdrive mode at max.
    If I use the older PrecisionX16 it no longer lets me access this tiny button the size of this "." and the program is merely a monitor and fan controller. If I use the latest PrecisionXOC which makes use of the Pascal power of my GTX1080, even with KBOOST=OFF, it still will make E:D goes all crazy glitching but only within the Stations. So with E:D I must not use this program which is a monitor in my use anyways. I simply thought it was a need to have it running due to experience of the old GTX970 which the firmware had a slow startup for fans from idle. The new cards are fine to not require Custom Fan Profiles and if they are Factory Overclocked then that is their new default to not require KBOOST. That button is way too easy to think you need use it!!!
Sign In or Register to comment.