My Oculus app isn't starting up, when I try to start it, an error pops up, why? — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

My Oculus app isn't starting up, when I try to start it, an error pops up, why?

thunderdude18thunderdude18 Posts: 2
NerveGear
Recently, I have been having a problem with Oculus, Every time I try to start Oculus an error pops up saying "Your Oculus software might be updating. Please wait a minute and try again. If the issue continues, contact Oculus Support." This has been happening since yesterday.

Answers

  • OneMintyMooseOneMintyMoose Posts: 3
    NerveGear
    Go into microsoft services, find "Oculus VR Runtime Service" and either start, or restart the service.  If that doesn't work try restarting your computer, I'm kind of in the same boat except for some reason that simple fix I knew isn't working.
  • AztecScribeAztecScribe Posts: 2
    NerveGear
    I'm having the same issue now. Any fixes available? I have restarted the service and restarted my PC but the problem persists.
  • BaZhAnGBaZhAnG Posts: 8
    NerveGear
    me too!
  • BBernesBBernes Posts: 16
    NerveGear
    Just got the Your Oculus software might be updating error and nothing works.
  • BaZhAnGBaZhAnG Posts: 8
    NerveGear
    was about to start a VR game and this damn thing happens
  • VirHarVirHar Posts: 2
    NerveGear
    Yep got the same error - Software might be updating. It worked fine 20 hours ago and nothing has been updated or reinstalled on my PC.......I'm reinstalling Oculus soft to see if it helps.
  • beyondinfinitybeyondinfinity Posts: 48 Oculus Start Member
    edited March 2018
    It's because of an expired certificate (March 7th 2018, 1 PM), unfortunately. We'll have to wait for Oculus to fix, or you can temporarily change the date of your PC to something before that date then restart your PC.

    EDIT: Removed time change workaround as it may have negative consequences with other applications.
  • VirHarVirHar Posts: 2
    NerveGear
    Yep I can confirm that reinstall didn't fix it - Thank Beyondinfinity for pointing it out. Hopefully they will fix it soon.
  • VRWorld001VRWorld001 Posts: 1
    NerveGear
    yep got the same errors on both PCs...yesterday was running without issues
    Please help
  • ZexMorfZexMorf Posts: 1
    NerveGear
    Where do I get the new Certificate ?
  • dburnedburne Posts: 2,528 Valuable Player
    Apparently same thing happening here. Oculus Home 1.24 seems to get stuck on loading, never loads the Home environment. Lost of service launcher errors in event viewer.

    Guess I will be patient and see if this gets sorted over the next few hours...
    Don

    EVGA Z390 Dark MB | I9 9900k| EVGA 2080Ti FTW3 Ultra |32 GB G Skill 3200 cl14 ram | Warthog Throttle | VKB Gunfighter Pro/MCG Pro grip | Crosswind Pedals | EVGA DG 87 Case|
  • Killinu6008Killinu6008 Posts: 1
    NerveGear
    its happening again
  • FrostDog33FrostDog33 Posts: 1
    NerveGear
    @Killinu6008

    Downloaded the hotfix they released back in march and it uninstalled/reinstalled the app and now everything works again. It also updated a few minutes after the reinstall and launch, but still works. 
    https://support.oculus.com/217157135500529/
  • Muscled_DogMuscled_Dog Posts: 1
    NerveGear
    Hey, it seem kind of stupid, but I had same issues, even after 3 restart. 
    My solution was: Go to C:\Program Files\Oculus\Support\oculus-drivers\ and run oculus-driver.exe. 
    It just opened the oculus window and it is working fine now.
  • SkirmySkirmy Posts: 3
    NerveGear
    I just updated Oculus, hadn't played in several months. Now when it starts up it just spins with a circle. I tried the tool tray app, to have the service start up at win boot. It says the service is up, but the app just never starts.
  • VickerCVickerC Posts: 35
    Brain Burst
    @Skrimy: where you able to solve it? I'm having the same issue. Circle just keeps on spinning...
    The best time to plant a tree was 10 years ago, the second best time is now
  • jroc.45448jroc.45448 Posts: 4
    NerveGear
    @vickerc did you ever find a solution.... i am having this same issue
  • magiceyemagiceye Posts: 1
    NerveGear
    same issue here none of the above work thanks.
  • Danzig8Danzig8 Posts: 4
    NerveGear
    Hey, it seem kind of stupid, but I had same issues, even after 3 restart. 
    My solution was: Go to C:\Program Files\Oculus\Support\oculus-drivers\ and run oculus-driver.exe. 
    It just opened the oculus window and it is working fine now.
    This worked first time! Could not have been easier. Thanks Muscled Dog.
    I recommend this approach to all. Copy and past the file path about. Then run the oculus-driver. Then start Oculus.
  • SixGigsSixGigs Posts: 1
    NerveGear
    edited February 5
    I know a fix has already been posted but I got the same issue and fixed it in a different manner so I thought it worth while posting it here as well.

    First of all go through: Settings > Apps > Apps & features. Scroll down until you find "Oculus". Selecting it will give you "Modify" or "Uninstall". Select Modify and allow it to make changes. A small window should open up with the options to "Quit", "Open Oculus", "Uninstall", and "Repair". Click Repair and let it do it's thing! My Oculus has been working ever since.

    This maybe a longer fix for the problem but I thought I better post my findings here in-case. Hope this helps! 
  • Thompsc3Thompsc3 Posts: 1
    NerveGear
    I’m running into same issue. Have tried everything above and everything oculus support sent me in my request #700907. Anyone have any other solutions?   
  • ArkloweArklowe Posts: 1
    NerveGear
    I am running into the same problem as well. Tried everything listed. Anyone have a new solution I can try?
  • XEcksDeeDXEcksDeeD Posts: 3
    NerveGear
    SOLUTION! If you are getting the error "Your Oculus software might be updating. Please wait a minute and try again. If the issue continues, contact Oculus Support." This is how you fix it, you may have to repeat this every time you restart or start up your computer.

    Step one: right-click your toolbar and select "task manager." 
    Step two: select the very right tab or select the "services" tab
    Step three: scroll down until you find "OVRService" right-click and click start

    Finished, now try opening oculus and all should be well! 
  • SpiceLife72SpiceLife72 Posts: 153
    Art3mis
    Use Oculus tray tool.
  • RealJackelOPRealJackelOP Posts: 1
    NerveGear
    None of the above issues work and I even tried going through a quick rundown with a staff member (waiting for another response) to clean any trace of Oculus software and then reinstall and rung but still "Your Oculus software might be updating. Please wait a minute and try again. If the issue continues, contact Oculus Support." 
Sign In or Register to comment.