Fixed lag/latency with HDMI — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Fixed lag/latency with HDMI

fschulzefschulze Posts: 17
edited April 2013 in Support
I had lag on the video output over HDMI to my Rift. I had noticed it before when I connected my Computer to my home theater via HDMI. The solution: Turn off Audio over HDMI in the NVIDIA settings.

It seems like routing audio through HDMI adds a lot of lag/latency to the video output. Has anyone else the same issue and maybe a solution? For the Rift it's not a problem, but I would like to play some games on my big screen with my audio system.

Comments

  • lazydodolazydodo Posts: 76
    Hiro Protagonist
    This sounds like a great testcase for the oculus latency tester! Cybereality can you give this a whirl at oculus HQ and share some numbers with us?
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    I don't believe this is an issue of the HDMI cable causing lag, but most likely the receiver you are using. Many receivers can delay the video to sync with the audio, and this can cause lag. You may want to see if your receiver has a "game mode", this can minimize latency. You can also, or course, plug the cable directly from your PC to the Rift, as this should have no problem.

    I will see if we can run some tests to get a definitive number for the lag, but you can imagine we are very busy here.

    Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • fschulzefschulze Posts: 17
    I already have the game mode activated, without it the lag without audio would be bad. The lag only occurs when I have audio routed over HDMI, if I turn that off in the NVIDIA preferences, it's all gone. I guess I have to get SPDIF working for proper audio.
  • fschulzefschulze Posts: 17
    I played around a bit more and found the real cause for the lag and a fix to get audio over HDMI without lag.

    The problem was that I activated audio over HDMI but still had the internal sound card as the default device. It seems to be automatically routed to the graphics card to be output in HDMI, but that adds latency/lag. Once I selected the audio device on the graphics card as the default device, the latency/lag went away! I then was also able to select 7.1 sound etc and it works great now.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Awesome! Thanks for following up on this.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.