New to the forums? Click here to read the How To guide. -- Developers click here.

Is the review "Submit" button almost hidden in your Oculus app?

FunKingFunKing Posts: 39
Brain Burst
edited April 2018 in Samsung Gear VR

Hi!

I have two devices (Note 4 and S7) that don't properly display the "Submit" button when I write an app review. Does it happen to anyone else? It looks like the screenshot on the left, with only the top part of the button visible (marked in red):


The problem appeared after an update. On previous versions of the Oculus app, the button was completely visible, like this:


I've contacted Oculus support, and despite their efforts, they could not reproduce the problem. I went through several troubleshooting steps, such as uninstalling/reinstalling everything related to Oculus / Gear VR, changing font size, language settings, and so on. Nothing helped.

Now Oculus support is asking me to do a factory reset, but that's a last resort for me: it takes time to do a full backup, there is always a chance for something to go wrong, and I'm sure it won't solve the problem. I believe that because the problem is gone when I install a previous version of the Oculus app (as seen on the screenshots above). I also managed to reproduce the problem on a brand new virtual device using Android Emulator, so there was no change in any default setting that could be triggering the issue. 

Other users on Reddit have the same bug. Here is a list of devices:

  • Note 4 (SM-N910F), Android 6.0.1 (mine)
  • S7 (SM-G930F), Android 7.0 (my wife's)
  • "S7, Nougat"
  • "S8+"
  • "S9, Oreo 8.0.0"

Yet, Oculus support won't escalate the issue because they "have seen no other reports concerning this", and I didn't do a factory reset. I even offered to test their device's APK, and/or send them my APK (to see if with that we could reproduce the error or not), but they are not interested in that.

FWIW, I think the bug is in the Oculus Horizon app (com.oculus.horizon), and from what I've tested, it begun on version 3.36.0.0.2742 (94141202). A quick analysis showed that the view layout have changed considerably since that version.

I tested these versions of the app, where the bug doesn't appear:

  • 3.25.0.6.785
  • 3.29.0.0.1233
  • 3.31.0.0.1502
  • 3.34.0.2.2369
  • 3.35.0.0.2559

The bug appeared for me in the following versions:

  • 3.36.0.0.2742 (94141202)
  • 3.37.0.2.2942 (95646156)
  • 3.38.0.7.3106 (98996091)

So, does anyone else have the same problem? If so, please let me know (including device model, OS version and Oculus app version), and/or please submit a ticket to Oculus support so they can further investigate the issue.

Thanks!

Comments

  • FunKingFunKing Posts: 39
    Brain Burst
    The bug appears (i.e., Submit button is hidden) if I follow these paths (it doesn't matter if the list is filtered by "All", "Installed", "Not Installed" or "Updates":
    • Library > My Apps > app menu > Write a Review
    • Library > My Apps > app menu > Update a Review
    • Library > My Apps > app menu > Details > Write a Review
    • Library > My Apps > app menu > Details > See All > Write a Review
    • Library > My Apps > app menu > Details > See All > Update Review
    The bug DOES NOT appear when I follow:
    • Main page (Store) > [app] > Write a Review
    • Main page (Store) > [app] > See All > Write a Review
    • Main page (Store) > [app] > See All > Update Review
    • Search > [app] > Write a Review
    • Search > [app] > See All > Write a Review
    • Search > [app] > See All > Update Review
    • Notifications > [app] > Write a Review
    • Notifications > [app] > See All > Write a Review
    Yesterday Oculus Support wrote me: "By going through the library to leave a review I was able to reproduce rather than going through the store/search to leave a review. Not many users leave reviews through the library which explains why there weren't any other reports. Please continue to update the app and you should see improvements in a future release."
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    We're looking into the issue now. Thanks.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
Sign In or Register to comment.