Installation failed, DirectX — Oculus
New to the forums? Click here to read the "How To" Guide.

Developer? Click here to go to the Developer Forums.

Installation failed, DirectX

JonaTjahJonaTjah Posts: 9
NerveGear

I can not figure out how to get the software installed..

Comments

  • cyberealitycybereality Posts: 26,156 Oculus Staff
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JonaTjahJonaTjah Posts: 9
    NerveGear

  • LZoltowskiLZoltowski Posts: 6,756 Volunteer Moderator
    What is your OS VERSION?
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • JonaTjahJonaTjah Posts: 9
    NerveGear
    edited April 2018
    Windows 10, 64bit
    I had some problems installing the rift software when i got the Oculus, but after the licence thing i had to re install the software and now im with this problem.
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    This definitely looks like a Windows OS issue. Have you run Windows Update and installed all the updates?
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JonaTjahJonaTjah Posts: 9
    NerveGear
    Yes i did, everything is on the latest update and drivers
  • LZoltowskiLZoltowski Posts: 6,756 Volunteer Moderator
    edited April 2018
    This could be either an issue with the bad avpack file or a corrupted .NET install..

    to start with:

    • Open an elevated command prompt. search for CMD, then right click run as ADMIN
    • Type the following command, and then press ENTER:  sfc /scannow

      The sfc /scannow command scans all protected system files and replaces incorrect versions with correct Microsoft versions.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • JonaTjahJonaTjah Posts: 9
    NerveGear
    I don't know if this will help, but here is something i got from the oculus log,

    Process C:\OculusSetup-DownloadCache\directx-june-2010-.exe exited with code -2147024703 (failure).
    [Error] [9-4-2018 21:54:20] Error installing redistributable DirectX (June 2010): Daybreak.Redists.RedistInstaller+RedistInstallerException: Redistributable DirectX (June 2010) returned an error ---> Daybreak.Util.Mixins+ExecuteProcessException: Process returned an error: -2147024703
       bij Daybreak.Util.Mixins.ExecuteProcessMixin(String path, String arguments, List`1 additionalExitCodes)
       bij Daybreak.Redists.RedistInstaller.InstallRedist(String redistName, String exePath, String redistParams, String redistId)
       --- Einde van intern uitzonderingsstackpad ---
       bij Daybreak.Redists.RedistInstaller.InstallRedist(String redistName, String exePath, String redistParams, String redistId)
       bij Dawn.Setup.InstallRedistributablesStep.InstallImpl()
    [Debug] [9-4-2018 21:54:20] Install 'Dawn.Setup.InstallRedistributablesStep' failed.

  • JonaTjahJonaTjah Posts: 9
    NerveGear

  • LZoltowskiLZoltowski Posts: 6,756 Volunteer Moderator
    Can you dl this, unzip and install the bits highlighted in red

    https://www.dropbox.com/s/3bswzhn76cwgvl1/Drivers.zip?dl=0



    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • JonaTjahJonaTjah Posts: 9
    NerveGear
    I allready have everything installed on my computer, I did repair everything.
  • LZoltowskiLZoltowski Posts: 6,756 Volunteer Moderator
    Just to make sure you may have something wrong with the way your user profile is set up, could you try making a temporary new user in windows, make it admin, and run setup from that profile? Just so we can rule out some things.
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    If you create a new Windows user, try one without any spaces or non-English characters. That can sometimes cause issues.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JonaTjahJonaTjah Posts: 9
    NerveGear
    Ok so i made a new Windows user and installed the Rift software WITHOUT any problems....
    What is causing the issue on my Windows Profile Account ?

  • LZoltowskiLZoltowski Posts: 6,756 Volunteer Moderator
    edited April 2018
    JonaTjah said:
    Ok so i made a new Windows user and installed the Rift software WITHOUT any problems....
    What is causing the issue on my Windows Profile Account ?

    That's a complex question, could be an errand registry permission, could be something that is running on your computer while you are in your old profile, but not running when you are in the new one. 

    In your old profile, can you run this
    tasklist > “C:\processes.txt”

    and attach this here, so I can see what is running on your system
    Core i7-7700k @ 4.9 Ghz | 32 GB DDR4 Corsair Vengeance @ 3000Mhz | 2x 1TB Samsung Evo | 2x 4GB WD Black
    ASUS MAXIMUS IX HERO | MSI AERO GTX 1080 OC @ 2000Mhz | Corsair Carbide Series 400C White (RGB FTW!) 

    Be kind to one another :)
  • cyberealitycybereality Posts: 26,156 Oculus Staff
    Does your new username have spaces or no spaces? I think that could be an issue.
    AMD Ryzen 7 1800X | MSI X370 Titanium | G.Skill 16GB DDR4 3200 | EVGA SuperNOVA 1000 | Corsair Hydro H110i
    Gigabyte RX Vega 64 x2 | Samsung 960 Evo M.2 500GB | Seagate FireCuda SSHD 2TB | Phanteks ENTHOO EVOLV
  • JonaTjahJonaTjah Posts: 9
    NerveGear
    Yes both of my profiles have spaces in them.


  • JusadJusad Posts: 1
    NerveGear
    Just wanted to jump in and suggest this be in the FAQ or sticky it somewhere.

    I had the same problem JonahTjah posted at the beginning of this thread and tried all the usual fixes; I'd manually reinstalled DirectX, done scannow verification, reinstalled my GFX drivers, searched registry, used registry cleaners etc etc 

    Huge thank you to LZoltowski and Cyberreality for their help in this thread - my username has no spaces on Win10 and after creating an account with a space in it, the installation went perfectly???

    A weird fix - but hard to find  :)
  • TIMG1227TIMG1227 Posts: 1
    NerveGear
    I had experienced the same problems with Oculus installation, also a similar problem with installation of Steam direct X files and I discovered that it was (for me anyhow) as there was a space in my username in Windows 10 (was Tim G, now TimG).  Once I removed the space, everything installed correctly.  

    To do this:

    Open start and in search box, type netplwiz, click OK.
    Select the account you want to modify and click on the properties button.
    Change the username to one you want to use (WITHOUT spaces) and click APPLY, OK.
    Restart windows.

    You should now be able to install Oculus software (and STEAM software too) successfully.

    Regards

Sign In or Register to comment.